x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Erroneous SVN checkout spam on blueprint compile

Been using SVN with VisualSVN server/Tortoise on windows as a local repository successfully with no issues on 4.7.6.

Now with 4.8, every time I compile a blueprint, any related blueprint files get tagged as requiring checkout (even if they have been checked out). My screen fills up with "Files need check-out!" notices.

Editor output log is filled with:

LogSourceControl: Attempting "svn status --show-updates --verbose --xml (then file location and SVN settings/credentials)

Clicking the Warning Notice to checkout the file doesn't do anything, and clicking the Source Control menu, then "Checkout Modified Files" doesn't show any of the files mentioned in the editor output log.

alt text

Product Version: UE 4.8
Tags:
svncheckoutbug.png (43.6 kB)
more ▼

asked Jun 10 '15 at 08:15 PM in Bug Reports

avatar image

InterSlayer
11 1 4 8

avatar image Matthew J Jun 11 '15 at 03:02 PM

Hi InterSlayer,

Is this an issue that is only occurring with one project? If so, was this project converted from 4.7.6? Can you try making a fresh project in 4.8 and seeing if the issue also occurs in that instance?

avatar image InterSlayer Jun 11 '15 at 04:59 PM

Hey. I tried making a fresh project in 4.7.6, converted to 4.8, and could not immediately reproduce the issue. Also tried a fresh project in 4.8.0 with no luck.

I tried reconverting my original project, disconnecting it from Source Control, recompiled all blueprints (to fix non-terminating pins) so it wouldn't give any errors, saved, then resubmitted to source (via Tortoise SVN), then reconnected the project in UE4 to Source Control and still had the Checkout Warning spam problem.

I also tried moving the converted 4.8 blueprint-recompile/saved project to a new, empty repository and still had the same problem.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Thank you for reporting this happening again, @James Steininger and @J2S . We currently have a bug report in for this issue back from 4.8 which was never technically fixed. The issue kind of disappeared with 4.9 so we assumed that it was gone and there was no way to test if a fix would work when you can't get the issue to happen. I've bumped the report to let people know that it's occurring again so that it has some attention now.

On another note, even back in 4.8, we never got this issue to reproduce on Perforce so that bug report is only mentioning steps for Subversion at the moment. The hope is that fixing one will fix both, but to be sure, would it be possible for you to provide some reproduction steps on getting this to happen with Perforce?

more ▼

answered Apr 26 '16 at 02:17 PM

avatar image Zaggoth Jul 26 '16 at 08:25 PM

Everyone having this issue, PLEASE upvote it here! https://issues.unrealengine.com/issue/UE-17164

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi InterSlayer,

It seems that this issue has already been fixed in our master branch but the fix itself hasn't been integrated into the releases (4.8) branch yet. If you're using a source code version of the engine as opposed to binary, you can find the fix here and integrate it into your engine if you wish:

https://github.com/EpicGames/UnrealEngine/commit/ca159a7f6e93097bfc4a853d377efd527bbe1982

If you get a 404 error, be sure that you're signed into GitHub and try again.

If you are using binary and do not wish to use source code however, the fix will be coming in an upcoming version.

Have a nice day,

Matthew Clark

more ▼

answered Jun 11 '15 at 06:14 PM

avatar image InterSlayer Jun 11 '15 at 06:39 PM

Got it. Thanks!

avatar image InterSlayer Jun 11 '15 at 11:11 PM

I compiled 4.8 from source with the linked commit and unfortunately still have the same problem with checkout notice spam.

It looks like every time I click compile, it pings any referenced blueprints and also wants them checked out.

Bizarrely, in one instance when I click compile, I get 14 checkout warnings. If I immediately compile the same blueprint, it will then next only give 4 checkout warnings, then alternate between the two for subsequent compiles.

If it's helpful, I can strip most of my project down to just the blueprints if someone would like to take a look. It will have a bunch of load errors for missing stuff (model/texture/sounds etc), but still exhibit the checkout problem when you try to compile a highly referenced blueprint.

avatar image Matthew J Jun 12 '15 at 02:27 PM

What versions are you using for your client and server when it comes to the SVN? It's possible that some conflicts could be happening due to version as I believe our SVN binary has been updated with 4.8.

avatar image InterSlayer Jun 12 '15 at 02:45 PM

VisualSVN 3.3.1 (Apache Subversion 1.8.13)

TortoiseSVN 1.8.11 (Apache Subversion 1.8.13)

Edit: Okay, I think I figured it out. I've been able to re-create it in a fresh 4.8, empty project.

Created a Parent base blueprint, with a cube mesh component, an arbitrary function, and some float/int variables (with an arbitrary default value).

Created 2 child blueprints, made sure they were not data only, added more variables and functions, made sure those functions or variables were called OnEventPlay.

Duplicated the 2 child blueprints 4 times so you basically had a hierarchy of: Parent Child1 Child2 Child1_1 to Child1_4 Child2_1 to Child2_4

For a total of 9 blueprints.

Next, restart UE4 and make sure in the process you are square with SVN.

Now, when you open Parent, and compile, it works fine. However, if you merely view any other files (not compile or save), and try to compile Parent again, those files, and on occasion other files that you didn't open, will be tagged for requiring checkout and show up in the log with checkout spam notices.

If you compile parent again, it will try with another set of files that need checkout, and alternate between the two sets on any subsequent compiles.

In my UE4 Project specifically, it is perpetually in the checkout spam state immediately after conversion to 4.8.

avatar image Matthew J Jun 15 '15 at 02:57 PM

Hi InterSlayer,

Just wanted to let you know, I'm still looking into this issue and I'll get back to you as soon as I find out anything. Thank you for your patience thus far.

avatar image Matthew J Jun 16 '15 at 05:32 PM

So I made myself familiar with Tortoise SVN and tried recreating your issue. I can get the spam to come up once per compile if I don't have the blueprints checked out, but I don't get the issue if they are checked out. If this is only happening when the blueprints aren't checked out, it makes sense as any changes to the Base class are going to affect the children of that class.

avatar image InterSlayer Jun 16 '15 at 05:53 PM

Hey thanks for taking a look.

I had suspected the same thing, though it doesn't seem to be entirely restricted to just parent-child relationships. Compiling another class, that spawns actors from the family of BP's also causes the problem.

I haven't tried this yet in a fresh 4.8 project, but in my converted project, compiling the character blueprint (which can spawn a family of projectile blueprints) will trigger the problem.

That being said, in my project on 4.7.6, if I compile a blueprint it only ever tags that specific blueprint as needing checkout, even if it is a parent blueprint, or referred by another blueprint.

avatar image Matthew J Jun 16 '15 at 06:27 PM

I can only get that problem to happen if I try to compile the projectile itself without having the character checked out. Are you saying that if you have different projectiles that can be spawned (with one base projectile and then others based off that) by a character, then when you try to compile the character without the projectiles being checked out, you can't?

avatar image InterSlayer Jun 16 '15 at 07:03 PM

The compile is successful, but you are hit with all the checkout warning boxes like in the screenshot.

So, for example in the case of my converted project, when I compile Projectile Parent, I get the 14 warnings boxes for "Files Need Checkout!"

The output log seems to be pinging these files for Source Control. which correlates to the checkout warning boxes:

Compile 1

  • Character Blueprint

  • Projectile Child 1

  • Projectile Child 2

  • Unrelated Class that checks for overlaps involving Projectiles

  • Projectile Child 3

  • Projectile Child 4

  • Projectile Child 5

  • Projectile Child 6

  • Another Unrelated Class that checks for overlaps involving Projectiles

If I don't do anything, and compile again, I get this set of files and checkout warnings:

  • Character Blueprint

  • Character Blueprint

  • Character Blueprint

  • Projectile Child 4

  • Projectile Child 5

And again not doing anything, with another compile:

  • Projectile Child 1

  • Projectile Child 2

  • Unrelated Class involving Projectiles

  • Projectile Child 3

  • Projectile Child 4

  • Projectile Child 5

  • Character Blueprint

  • Character Blueprint

  • Character Blueprint

  • Projectile Child 6

If I click Save, it brings up a box telling me to Check Out files, it only indicates the specific file I am working on requires checkout (Projectile Base).

From the viewport, if you click Source Control, the option to "Check out modified files" is disabled, despite everything above.

Finally, if I manually check out all the files mentioned in the log, I do not get the checkout spam problem (manually by right clicking the asset in UE4, Source Control, then Checkout)

Though, in the output log, it is still cycling through all those files for source control.

This was not the behavior in 4.7.6 in the same situation. Doing something to Projectile Base, like compiling or adding a new function, would not tag anything else as requiring checkout.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi InterSlayer,

I've placed a bug into our database with very detailed reproduction steps. Thank you for being very thorough and helping me reproduce this so that I could do so. For your reference, the bug number is UE-17164. I can't guarantee how this bug will go about being fixed as it could be the fact that the errors themselves are false positives or it may be changed in a way so that the "Check Out Modified Files" will be usable for the items that come up in the error messages. Unfortunately, for the moment I don't have anything I could offer as a workaround.

Have a nice day,

Matthew Clark

more ▼

answered Jun 16 '15 at 08:45 PM

avatar image Noeticized Jun 29 '15 at 07:12 PM

I just recently converted my 4.7.6 project. (converted with 4.8.1 binary) Using Perforce, I am experiencing issues exactly as above and reproducible in the same manner.

avatar image Matthew J Jul 06 '15 at 09:14 PM

Hi Noeticized,

I attempted to see if this issue would occur in the most recent internal build with Perforce but I don't see the issue on my end. It is possible that it could have been inadvertently fixed. If the issue does still occur for perforce after the Tortoise SVN issue has been resolved, I'll be sure to pursue it further. Thank you for reporting this.

avatar image InterSlayer Jul 30 '15 at 09:21 PM

Hey Matt. I just checked up on this problem with the recent updates to UE4.

The problem still exists in 4.8.3, but seems to be gone in 4.9p1.

Unfortunately, I'm getting a new problem where when trying to submit to source (from UE4's source control menu), the editor will crash to desktop with a slew of red errors in the log.

Here is an example of the errors:

 [2015.07.30-21.19.09:016][179]LogPackageName:Error: Illegal call to DoesPackageExist: '../../../../../../UE4 Projects/projectname/Content/_ParticleTutorial/_ParticleTutorial/Sprite_GPU/P_GPUSparks.uasset' is not a standard unreal filename or a long path name. Reason: Path should be no less than 4 characters long.

The crash reporter submitted the diag files, let me know if you need anything further from my end.

avatar image Matthew J Jul 31 '15 at 06:03 PM

Hey Interslayer,

I'm glad the original problem is gone but it's unfortunate to see this new problem crop up. Is it possible for you to reproduce this in a fresh project? It may require some sort of very long file directory as the one you're currently using but I've yet to have success testing it that way. I'll be dedicating some time to trying to repro it myself but any extra details would be helpful.

avatar image InterSlayer Jul 31 '15 at 06:45 PM

I have a drive dedicated to UE4 stuff, and a "UE4 Projects" folder at the root. So it's just:

 F:\UE4 Projects\Project1

So in this specific case, the project is called "Test5", which exhibits the crash.

However, in making a new project, called "Test6", it didn't cause the problem.

When attempting to migrate an asset that caused the crash (_ParticleTutorial) from Test5 into Test6, it caused a crash with no dump info.

Then, I manually copied that folder directly into the Test6 content folder, and was able to submit to source with no problems.

Edit:

Noticing some file load errors also that don't consistently show up during project load. Going to try to rule out any hardware issues with the disk just in case.

Edit 2:

No Disk Errors, did a reboot. No longer crashing on submit to source, so I can't explain or immediately reproduce the error anymore at all. Crazy, right? The only thing I did was clear out the /project/saved folder to get some fresh logs/crash dumps. The only other thing I noticed was a lot of starter content logpack debug notices.

Will try a fresh attempt at converting my original 4.7 project and see where it goes this time.

avatar image Matthew J Jul 31 '15 at 07:38 PM

Can you try migrating this asset without source control enabled? Also, would it be possible to get a copy of this project where the crash occurs? If not, it's alright and I'll continue working on trying to nail down the reproduction for the issue.

avatar image InterSlayer Jul 31 '15 at 07:54 PM

Hey, sorry for the runaround. I can't seem to replicate the problem anymore after a diskcheck and reboot. It might have been related to that, I'm not sure.

I just did a conversion of my project from 4.7.6 -> 4.9p1 without any problems. Earlier it was 4.8 -> 4.9p1.

avatar image Matthew J Jul 31 '15 at 08:05 PM

Glad to hear it was a special case. Please be sure to let me know if it ever comes back and I'll be happy to help.

avatar image James Steininger Apr 15 '16 at 09:44 PM

I'm receiving this issue again on 4.11.1 with Perforce.

avatar image Macw0lf Aug 10 '16 at 03:52 AM

Me too. in 4.12.5

avatar image J2S Apr 18 '16 at 09:41 AM

Having same problem on 4.11.1 with Perforce.

avatar image Matthew J Apr 22 '16 at 08:09 PM

Hello James and J2S,

When you both have this issue occur, is it with child blueprints and such as it was with InterSlayer? Is there any particular workflow you follow that causes this to happen? While the issue does have a bug in for it, the reproduction steps may not be the same in newer versions.

avatar image InterSlayer Apr 30 '16 at 10:25 PM

Just wanted to add I also see this problem again in 4.11.2 with VisualSVN / TortoiseSVN.

Same repro steps from my original submission also with the Parent-Child Blueprints.

It looks like when you have a bunch of Parent-child blueprints, when you compile the parent blueprint it fills the screen with complaints that the related child blueprints need to be checked out..

It either use to automatically check the related files out, or never cared that you didn't so didn't give any notifications.

avatar image 00k_ May 06 '16 at 05:20 PM

I wanted to add that I am also seeing this using P4 and 4.11.2. It seems to relate to the source control logic believing that I have modified anything that the object I am compiling has a variable reference to. However these objects do not get marked as "dirty" they just throw the source control spam.

avatar image Nsomnia May 15 '16 at 08:56 AM

Same and on 4.12p3

avatar image Gomo Jul 04 '16 at 09:56 PM

Same here, also 4.12.3

avatar image Raf_L3O Jul 09 '16 at 04:37 PM

Same here on SVN, since 4.12 (currently on 4.12.3)

avatar image Katilio Aug 07 '16 at 12:57 PM

I'm having the same problem too.

avatar image Macw0lf Aug 10 '16 at 03:52 AM

Me too. with perforce on 4.12.5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

We had this problem as well, I went in and had a look at what was causing it for us. I've attached a diff of the change I made to quickly fix it for us, hope it helps. There's a couple of comments in there describing what caused it.

Diff is for the file: UE4/Engine/Source/Editor/UnrealEd/Private/UnrealEdSrv.cpp

more ▼

answered Aug 10 '16 at 01:35 PM

avatar image

Tim.Leonard
5 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question