x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.8 crashing on launch

Crashes seconds after clicking launch. Just installed, All other versions work fine.

MachineId:AE8899524E98CA8433E3EBB223DCFCB1 EpicAccountId:000225a7c326419ba8077d511b86d0b1

Access violation - code c0000005 (first/second chance not available)

""

LibOVRRT64_0_6 LibOVRRT64_0_6 LibOVRRT64_0_6 LibOVRRT64_0_6 LibOVRRT64_0_6 UE4Editor_OculusRift!FOculusRiftHMD::InitDevice() UE4Editor_OculusRift!FOculusRiftHMD::Startup() UE4Editor_OculusRift!FOculusRiftHMD::FOculusRiftHMD() UE4Editor_OculusRift!FOculusRiftPlugin::CreateHeadMountedDisplay() UE4Editor_Engine!UEngine::InitializeHMDDevice() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\engine\private\unrealengine.cpp:1839] UE4Editor_Engine!UEngine::Init() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\engine\private\unrealengine.cpp:739] UE4Editor_UnrealEd!UEditorEngine::InitEditor() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\editor\unrealed\private\editorengine.cpp:425] UE4Editor_UnrealEd!UEditorEngine::Init() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\editor\unrealed\private\editorengine.cpp:580] UE4Editor_UnrealEd!UUnrealEdEngine::Init() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\editor\unrealed\private\unrealedengine.cpp:48] UE4Editor!FEngineLoop::Init() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\launch\private\launchengineloop.cpp:2026] UE4Editor_UnrealEd!EditorInit() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\editor\unrealed\private\unrealed.cpp:63] UE4Editor!GuardedMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\launch\private\launch.cpp:133] UE4Editor!GuardedMainWrapper() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\launch\private\windows\launchwindows.cpp:126] UE4Editor!WinMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\launch\private\windows\launchwindows.cpp:200]

Product Version: UE 4.8
Tags:
more ▼

asked Jun 11 '15 at 03:51 AM in Bug Reports

avatar image

yulaw2k
68 6 9 12

avatar image JJChalupnik Jun 11 '15 at 04:18 AM

I've got the same problem. Running Win 7 Professional. Fully up to date. All other versions appear to be running fine.

avatar image JJChalupnik Jun 11 '15 at 04:44 AM

One of my logs is attached. Thanks.alt text

log capture.jpg (123.2 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello yulaw2k,

After doing a bit more digging I was able to find that this issue is a known issue (UE-16177) and that it has already been sent to the developers for further consideration. Thank you for your time and information.

Make it a great day

more ▼

answered Jun 18 '15 at 02:15 PM

avatar image

Rudy Q ♦♦ STAFF
49.1k 543 128 517

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This isnt a real fix if you use the oculus rift. C:\Program Files\Epic Games\4.8\Engine\Plugins\Runtime I removed the oculusRift folder, and now im up and running. Hopefully they fix this as I am using the rift for developing.

more ▼

answered Jun 11 '15 at 06:43 AM

avatar image

yulaw2k
68 6 9 12

avatar image JJChalupnik Jun 11 '15 at 07:50 AM

Awesome! Thanks yulaw2k! I am also trying to develop on the Rift as well, but at least this will get me up and running. I'll have to test it tomorrow. Since you develop for the Rift, have you had any issues getting the VR preview to consistently work? I feel like I can only get it to work with UE4 occasionally. Mostly it is grayed out. I was hoping for a fix with this new 4.8.

avatar image Rudy Q ♦♦ STAFF Jun 11 '15 at 06:47 PM

Hello yulaw2k,

I was unable to reproduce this issue on our end. I have a few questions that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Does this happen every time that you try and open 4.8?

  2. Does restarting your computer have any effect of the problem?

  3. Could you provide a detail list of steps to reproduce this issue on our end (in case I missed any small steps that you may have taken)?

avatar image Rudy Q ♦♦ STAFF Jun 11 '15 at 06:49 PM

Hello JJChalupnik,

The oculus needs to be plugged in and turned on before starting up the editor, otherwise the VR preview may be grayed out. I have done this a few times myself. I hope this information helps.

avatar image JJChalupnik Jun 11 '15 at 07:01 PM

Hello Rudy, Thank you for your response. It's actually been an ongoing issue for about a week now since I've installed the Oculus DK2 on my machine. I can't speak for yulaw2k, however to answer your previous questions:

  1. Yes, every time.

  2. Rebooting has not solved the problem.

  3. All I did, was install 4.8 from the launcher, then verify, then launch. It crashes at 79% consistently. I actually uninstalled it once and then re-installed and verified just to be sure.

As far as the VR Preview issue. Yes it is plugged in, yes I started the runtime prior to opening the editor. It always reads "Ready" in the utility before I even run the launcher. I've been combing through various posts on this and still haven't found a solution. It occasionally does work, which is why I don't understand. I haven't found a pattern yet, so frankly I don't even know what questions to ask. I would say it works 2 out of 10 times. Here is a link to my previous post on the issue.

https://forums.unrealengine.com/showthread.php?72352-VR-Preview-Grayed-Out

Thanks again for the response!

avatar image seenooh Jun 12 '15 at 09:52 PM

I want to confirm that I have the same exact problem. I'm using Oculus Runtime version 0.6.0

avatar image yulaw2k Jun 11 '15 at 07:05 PM

Everytime. I did try restarting my computer. Could it be that I have the old version of occulus installed? (New versions wont work for me...)

STEPS: Uninstall 4.7 Install 4.8 Click Launch (89% i think it crashes everytime)

So there really are no steps besides installing and clicking launch.

College Finals are today, Will be reinstalling windows tonight and let you know if that worked (I do it every few months, not doing it to fix this problem)

And im on Windows 8 64bit. i7 3630qm, GeForce gtx 670mx. But that probably dosnt help...

avatar image Rudy Q ♦♦ STAFF Jun 12 '15 at 01:40 PM

Hello yulaw2k,

Could you tell me what runtime it is that you are using for the oculus?

avatar image yulaw2k Jun 15 '15 at 10:14 PM

Mine seems to be working after I "Refreshed" My windows 8.

avatar image Rudy Q ♦♦ STAFF Jun 16 '15 at 03:07 PM

Hello yulaw2k,

I am happy that you have it working for you. If this issue occurs again please provide any additional information that you may have and we will be more than happy to assist you further. I did have one more question, did you try verifying your engine? This has been met with some success with similar issues.

avatar image JJChalupnik Jun 17 '15 at 04:42 AM

So is this the only option available, or are you guys still working on a solution to this? I'm on Win. 7 and a fresh install isn't an ideal situation for me at the moment. Do you guys recommend moving to 8.1 in a fresh install?

avatar image werwack Jun 17 '15 at 10:55 AM

Hi guys,

I have the same crash issue. I am on win7, use Oculus DK2 (with drivers 0.4b because somehow I wasn't able to make some games and demos run with 0.6b) and I have a systematic crash on UE just before the UI appears. I didn't test with an Oculus plugged because it isn't easy to work all the time with it plugged. The installation of UE4.8 has been verified and is ok.

A fix for this would be greatly appreciated :)

Thank you very much

avatar image Rudy Q ♦♦ STAFF Jun 17 '15 at 03:19 PM

Hello werwack,

Could you tell me the exact version for the runtime that you are using? There is a known issue with older versions of the runtime being used on the latest versions of the engine.

avatar image werwack Jun 17 '15 at 04:53 PM

![alt text][1] [1]: /storage/temp/46784-oculus.jpg I am using Oculus runtime 0.4.4. It is working with UE4.7.3. I had troubles with their drivers 0.6 and probably have to go dig in it again soon to know eaxacly what is going on.

Does it answer your question?

Thank you

oculus.jpg (31.6 kB)
avatar image werwack Jun 22 '15 at 06:07 PM

Hi Rudy,

Do you have some more info about the crash issues? Or about an upcoming fix?

Thank you very much

avatar image Rudy Q ♦♦ STAFF Jun 22 '15 at 06:30 PM

Hello werwack,

I went ahead and double checked for you and it turns out that this issue has been resolved internally. This solution will be available in a later release of the engine.

Make it a great day

avatar image werwack Jun 22 '15 at 10:14 PM

Thank you very much :)

Best regards

avatar image JJChalupnik Jun 23 '15 at 05:20 AM

Great to know. Thanks!

avatar image JJChalupnik Jun 27 '15 at 02:41 AM

Not sure if I should post a new question or continue this thread, but I still have crashing at 79% on 4.8.1. Any help on this would be appreciated. I've sent the crash reports as well. Seems to be the same problem I had with 4.8. See attached for a screengrab of the crash. I did get one instance where it loaded the Project manager. But crashed trying to load the Kite Demo.alt text

avatar image JJChalupnik Jun 27 '15 at 02:50 AM

Disconnecting the Oculus DK2 Service and turning it off, allows me to open the project.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question