x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.8] Some structs not listed in BP editor

Hi there,

I cannot choose 'S_CarDesignMeshReplacements' as type for a variable in the Blueprint editor, it's just not listed:

alt text

It looks like this, nothing fancy:

alt text

I tried to rename it, but that makes no difference. When I duplicate the struct, the copy is listed. So I tried to replace all the references to the new version, but that didn't work either (got a 'CRITICAL ERROR' instead).

So I tried to recreate the structure with blueprints, but there seems to be another bug.

Product Version: UE 4.8
Tags:
more ▼

asked Jun 11 '15 at 11:55 AM in Bug Reports

avatar image

spyro
1.7k 105 117 229

avatar image TJ V ♦♦ STAFF Jun 11 '15 at 01:44 PM

Hi spyro,

I attempted to reproduce this in 4.8 but I couldn't get your results.

Was this project originally created in 4.8 or was it converted over? Could you try to reproduce this in a new test project and upload it here?

avatar image spyro Jun 11 '15 at 07:25 PM

HI TJ,

yes, it was converted from 4.7.6. No, I cannot reproduce this in a new project (how could I). Is there any information or log I can post for you? Is it possible to read all classes new in or something?

avatar image TJ V ♦♦ STAFF Jun 15 '15 at 06:53 PM

Have you tried making a new blueprint entirely and see if the struct is listed there? If that doesn't work, maybe a new blueprint and a new struct?

See if anything is printing to your Output Log when you try to compile.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

It isn't listed in a new blueprint either. I would just recreate the struct, but the replacement of references when deleting the old one isn't working either (critital error). Guess, I've to rebuild anything by hand.

I'll scan the output log, maybe I can extract a few bits of info out of it.

more ▼

answered Jun 15 '15 at 10:29 PM

avatar image

spyro
1.7k 105 117 229

avatar image TJ V ♦♦ STAFF Jun 24 '15 at 05:38 PM

Hi spyro,

Have you had any luck fixing this issue? Did you find any useful info in the Output Log?

avatar image spyro Jun 24 '15 at 07:03 PM

No, not really thanks. I recreated that stuff, works ok since then.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question