x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.8 Apex Cloth "trembling" on playable Character

I just converted my project to 4.8 and the apex cloth is "trembling" while playing the game. This does not happen while viewing the skeletal mesh in the editor only when playing (in editor or not). This only happens to my playable character, If I place the mesh like a object the problem is gone. In 4.7 everything works as it should.

I tried reimporting and deleting then reimporting the apex assets with no luck.

Product Version: UE 4.8
Tags:
more ▼

asked Jun 11 '15 at 01:32 PM in Bug Reports

avatar image

Loginius
18 4 5 7

avatar image ZzGERTzZ Jun 22 '15 at 03:05 PM

Same problem. As if included simulated wind. In the editor, everything is fine but the gameplay clothing simulated wind. sorry for bad english

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Loginius,

Would you be able to post a video demonstrating the "Tremble" that you've described? I've not been able to see this in any of our Content Examples assets where I can test. I looked at the Owen character in the Animation map of Content Examples that is available via the marketplace.

Thank you!

Tim

more ▼

answered Jun 11 '15 at 08:57 PM

avatar image

Tim Hobson ♦♦ STAFF
49k 886 96 873

avatar image Loginius Jun 11 '15 at 10:03 PM

sure, there you go: https://www.youtube.com/watch?v=j3iE4ndbqMU&feature=youtu.be its subtle but visible, its way more visible with motion blur turned on: https://www.youtube.com/watch?v=ptmUjUz0Rw4

this is the same character in 4.8 in persona: https://www.youtube.com/watch?v=BlYJ-DuH0Qk

in 4.7 this problem was not present. Nothing has been changed on my end.

thanks for looking into this

The cloth in the content example for 4.8 is working as expected when I try it out. So this means something isnt right with my cloth? Do you have any idea what could be the cause? I tried everything I could think of.

avatar image Loginius Jun 15 '15 at 12:27 AM

Any update on this? I cant figure out what is going on.

avatar image Tim Hobson ♦♦ STAFF Jun 18 '15 at 03:55 PM

Apologies for the delay. I've had other priorities I've had to get to first.

I've spent some time this morning trying to replicate the trembling, but I'm not seeing that on my end with a basic cloth asset and character mesh that I created in 3Ds Max.

If you have a test asset that can recreate this I can take a look when I get time, but with my couple of test thus far I'm not able to see the same results unfortunately.

Let me know.

avatar image Tim Hobson ♦♦ STAFF Jun 22 '15 at 07:38 PM

I was able to dig into this one a little bit more and was able to see thanks to ZzGERTzZ's suggestion that wind was having a factor in the tremble.

It looks like wind is on by default for cloth assets whether there is a Wind Directional Source actor in the scene or not. I've reported this with UE-17470.

For the moment you can just place a WDS actor in the scene and set the strength to 0 to get rid of the "tremble" that you're seeing. I will update once there is a fix in for this.

Thank you!

Tim

avatar image Loginius Jun 22 '15 at 10:31 PM

Thank you for looking further into this. Placing a WDS and setting its strength to 0 sadly does not stop the trembling.

I managed to narow down the problem further: Cloth assets are only trembling when attached to a playable character with a "Cloth Blend Weight" other than 1 or 0.

I tested this with the character from the content examples and had the same problem.

avatar image Tim Hobson ♦♦ STAFF Jun 29 '15 at 03:44 PM

Hi Loginius,

I wanted to update you on this. I was able to track this down a little bit further and it appears to be something either that is set wrong with Clothing or something in the Post Process Volume that is causing the issue.

By setting a post process volume that is unbound in your scene and setting the "Motion Blur: Per Object Size: " to a higher value this can resolve the issue for the moment. It will be based on the size of the object in the screen space. For instance. if you setup your character and set the Per Object Size to ~75 seem to correct it for the Owen Character. Also, disabling the motion blur by setting it to 0 resolved the issue as well.

I've started a discussion with the developers on this one and will update with what I hear as soon as I know something more.

avatar image Loginius Jul 05 '15 at 11:46 PM

Hi Tim, awesome, thank you for the workaround, setting the motion Blur per object size to a higher number worked for my character.

Disabling motion blur however did not stop the trembling as long as per object size was at the default value.

avatar image Tim Hobson ♦♦ STAFF Jul 13 '15 at 05:45 PM

Hi Loginus,

I just wanted to update you that this has been resolved in our internal build of 4.9, so this will be fixed fully when that is released. Unfortunately, there is no definitive date set for when this will be released yet. Just keep an eye for updates in the launcher for when 4.9 releases.

Thank you!

Tim

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question