x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Why is my static mesh not moving?

I've been trying to get my mesh to move on my command like in the UFO input example, but so far I've been unsuccesful. Here are the steps I took so far:

  • I created a blank project with starters content.

  • I created a new Pawn Blueprint.

  • I've added a mesh and a camera as child of that mesh. The mesh's mobility is set to Movable.

  • I created a Delta Seconds variable and a Movement speed variable.

  • I've set the movement speed default to 700.

  • I've created input axes MoveForward, MoveUp and MoveRight with corresponding keyboard buttons and scales.

  • I've copy pasted a part of the BP_UFO_Physics example that can be found in the Content Examples. Specifically I've copy-pasted the part that updates the actor's velocity based on Input.

  • I've also added the Event Tick and connected it to set the delta seconds and then connected it to the Set Physics Linear Velocity node, which has as target my mesh.

  • I placed an instance of my Blueprint in the game world and I also set the Auto Possess property to player0

When I press play I can see that the Blueprint is doing its job. The Input Axes have positive values, yet my mesh is not moving. What is going wrong?

Product Version: Not Selected
Tags:
more ▼

asked Apr 03 '14 at 12:08 PM in Blueprint Scripting

avatar image

simmania
185 27 37 120

avatar image bwijerat Aug 24 '18 at 08:32 PM

I'm moving a UStatic Mesh via c++ so I needed to set the static mesh to "movable", since the mesh is statically in the scene I did that in the Unreal Editor by clicking on the static mesh->Transform tab->Mobility set to Movable.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Okay I finally found it. The Physics property Start Awake of the mesh should have been set to true...

more ▼

answered Apr 03 '14 at 12:27 PM

avatar image

simmania
185 27 37 120

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question