x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Sequence Node "Note"

The sequence node in blueprint suddenly shows a blue "Note" bar at the bottom whenever the BP is compiled with more than 1 output connected. The note says "The path is never executed. Then 1" and only the first output is triggered (This is in the construction script).

I may have missed something in the release notes of 4.8, or maybe it has been mentioned somewhere else, but I haven't found anything. This didn't happen in the previous version of the engine.

Product Version: UE 4.8
Tags:
more ▼

asked Jun 13 '15 at 04:22 PM in Blueprint Scripting

avatar image

NickEast
21 2 3 3

avatar image Mavicus Jun 16 '15 at 05:02 PM

The same thing has happened to me in a project I bought over from 4.7 where the function for a "ForEachLoop" worked perfectly fine and displayed a player list, but since bringing into 4.8 it says the same thing and only the first player shows in the list.

Sorry I haven't come with an answer, but I'd be very interested to find out what's happening and will report back if I find anyway around it.

avatar image NickEast Jun 22 '15 at 05:48 PM

For your problem, I think the loop has to finish first, then call the Return Node (perhaps sending the result to that node and let the function return the result)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Okay, so this problem was solved with help from the forums.

Apparently, with 4.8, a function would end completely as soon as the execution path reaches the "Return Node". In my old Blueprint class, each output of the "sequence node" would eventually connect back to the Return node. Since the first output already calls that node, it doesn't continue.

The solution for this is simply to make sure the Return Node is called last so that all the outputs are able to complete, before finishing the function's execution.

more ▼

answered Jun 22 '15 at 05:40 PM

avatar image

NickEast
21 2 3 3

avatar image Mavicus Jul 25 '15 at 07:45 PM

Yo, sorry for late reply, I had no notifications and only just checked Emails for the first time in ages where this appeared lol, but yeah, thanks for the update on the situation, I might try testing my project from 4.7 to 4.8 again to see what's what.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question