x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't Open Launcher - Error 0xc000007b

I downloaded and installed the Epic Games Launcher today, using "EpicGamesLauncherInstaller-2.2.0-2568893.msi" (from the main page). However, I can't start the launcher, since I get an error (0xc000007b). I tried reinstalling the launcher, not using the default directory, as well as reinstalling / repair MVC++2012. Using the Tracker none of the listed Errors appeared in my Log and I can't seem to find the error. Any idea what I could try next?

Log file: Log.txt

Thanks, Khurshid

Product Version: Epic Games Launcher
Tags:
log.txt (568.6 kB)
more ▼

asked Jun 14 '15 at 08:51 PM in Installation & Setup

avatar image

Khurshid
6 1 2 4

avatar image Khurshid Jun 14 '15 at 08:53 PM

Uhm, just to clarify: Of course I meant "Can't open Launcher". Sorry for that.

avatar image TJ V ♦♦ STAFF Jun 15 '15 at 04:59 PM

Hi Khurshid,

It looks like you tried a few things already but could you make sure to go through all of the suggestions in this section of the troubleshooting guide?

If nothing works, follow the instructions towards the bottom of that link to generate your Debug Logs. Post them here, along with your Dxdiag (System Specs).

avatar image Khurshid Jun 15 '15 at 10:29 PM

I did update my graphics driver, but sadly that didn't change anything. Creating the Dxdiag worked fine, generating the Debug Logs however did not. I can't find the created files, since there is no folder 'EpicGamesLauncher' under AppData\Local. Maybe that error will help. Here my Dxdiag file:dxdiag.txt

dxdiag.txt (79.4 kB)
avatar image 0xDEADBEEF STAFF Jun 16 '15 at 03:22 AM

You are probably not getting any launcher logs because it is failing to load one of the required dependencies long before the launcher even has a chance to initialize. The answer in this thread describes how to use a tool called Dependency Walker to generate a log that should help you pinpoint the problem. https://answers.unrealengine.com/questions/12975/unreal-engine-wont-launch-error-code-0xc000007b.html

If you get stuck, we'll be happy to take a look at the log.

avatar image Khurshid Jun 16 '15 at 09:27 AM

I had included the Walker Logs in my first post. However, I did create a new one, seeing as I tried some new things. I did not find any of the errors given in bold, but when searching for "launcher" I found that the 'aqprof.dll' returned NULL (line 5670). After that I tried a 'sfc /scannow', which told me that there are some corrupted files. In the 'CBS.log' I couldn't fine anything (no idea what to look for and it's quite big). I'll just include the Walker log as well as the CBS.

Walker: log.txt CBS: CBS.log

log.txt (568.5 kB)
cbs.log (2.7 MB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

According to your Dependency Walker logs, it appears that you have an x86 version of the following DLL:

Entry from logs:

 [*E ]  c:\windows\system32\VSPERF120.DLL  ...   x86  

The windows\system32 folder should have an x64 version of that dll. Once you get that DLL repaired you should be good to go. The problem now: That DLL does not seem to be part of the VS redist so I'm not sure exactly why the launcher is referencing it or how to repair it. Do you have Visual Studio installed?

more ▼

answered Jun 16 '15 at 09:55 PM

avatar image

0xDEADBEEF STAFF
1.5k 18 12 47

avatar image Khurshid Jun 17 '15 at 07:47 AM

According to my Control Panel I have "MVS 2010 Tools for Office Runtime (x64)", "MVS Express 2013 for Windows - ENU" and "MSV Professional 2013". Just updated / repaired all of those as well.

avatar image 0xDEADBEEF STAFF Jun 29 '15 at 04:16 PM

Try this:

  1. Find and backup your current C:\Windows\System32\VSPERF120.dll. You can do this by renaming it to VSPERF120.dll_BACKUP

  2. (Optional) Test to see if the launcher now runs.

  3. Run the repair option on Visual Stuido 2013.

  4. Check to make sure you have a new VSPERF120.dll.

  5. Run the launcher.

avatar image Khurshid Jul 10 '15 at 02:35 PM

Sorry for the late answere, I kinda lost hope of being able to fix it. Sadly, repairing did not help, even though I do have a newly created VSPerf120.dll. Is it possible that I have the wrong version of Visual Studio 2013?

avatar image 0xDEADBEEF STAFF Jul 10 '15 at 02:58 PM

The 0xc000007b error code can be displayed for a few reasons, it may be that another component is failing now that you fixed up Vsperf120.dll. Perhaps you could post up another Dependency walker log and I'll have a look.

avatar image Khurshid Jul 19 '15 at 10:44 AM

Ok, I just created a new log, also checked for those common errors ( [E], [ ! ] and/or [!6] ) but didn't find anything.

Log: Log.txt

log.txt (575.9 kB)
avatar image 0xDEADBEEF STAFF Jul 21 '15 at 07:47 PM

It looks like you fixed the VSPerf120.dll issue you were having before but there still seem to be some issues in the new log. Here are the log lines that look suspicious.

  • GetProcAddress(0x00007FFECD0D0000 [KERNEL32.DLL], "GetFileInformationByHandleExW") called from "VSPERF120.DLL" at address 0x00007FFEB76A866C and returned NULL. Error: The specified procedure could not be found (127).

  • GetProcAddress(0x00007FFECD0D0000 [KERNEL32.DLL], "SetFileInformationByHandleW") called from "VSPERF120.DLL" at address 0x00007FFEB76A868A and returned NULL. Error: The specified procedure could not be found (127).

  • LoadLibraryW("VtuneApi.dll") returned NULL. Error: The specified module could not be found (126).

  • LoadLibraryW("VtuneApi32e.dll") returned NULL. Error: The specified module could not be found (126).

avatar image FloppyGizmo Jun 21 '16 at 05:31 AM

My log is filled with missing module errors, do you know how I would fix this? :( Log

log.txt (574.1 kB)
avatar image TJ V ♦♦ STAFF Jun 21 '16 at 02:39 PM

Hi,

In order for us to best support you, we have recently modified our process for how we handle Launcher issues.

Please visit: http://help.epicgames.com

Here you will find information and solutions for common issues, as well as a contact form if you still need additional assistance.

Thanks,

TJ

avatar image 0xDEADBEEF STAFF Jun 21 '16 at 04:21 PM

The first thing that jumps out is an issue with XINPUT1_3.DLL. The fix you can try would look something like this:

  1. Backup this file c:\windows\system32\XINPUT1_3.DLL by renaming it to XINPUT1_3.DLL_BACKUP

  2. Run the DirectX setup from here: https://www.microsoft.com/en-us/download/details.aspx?id=8109

  3. Ensure a new version of this file was put here: c:\windows\system32\XINPUT1_3.DLL

If that does not work, we have recently modified the process for how Epic Games can help troubleshoot your Launcher issue. Please visit http://help.epicgames.com/ for technical support, here you can find information and solutions for common issues, as well as a contact form if you still need additional assistance. To access the contact form, please use the "Email Us" button under the "Contact Us" section.

avatar image FloppyGizmo Jun 22 '16 at 01:40 AM

This actually worked perfectly for me! Thank you 0xDEADBEEF! :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question