x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaged game does not work, crashes on launch

I am trying to package my game, so I click on the "Launch" button and wait a few minutes until it has compiled everything and then it starts, but unfortunately then I only get this error:

alt text

I have no idea what it means. All I know is the game runs absolutely fine with "Play in Editor" and also in standalone. Only the packaged version has this problem. So he can't access the Baker while the CollisionCylinder of the CapsuleComponent needs to be loaded? What?

This is how the "Baker" blueprint looks:

alt text

I only have blueprints in my game, not a single line of c++ code. I don't use any plugins. And I'm not sure whether I got this Error with 4.7, but I'm like 70% sure I were able to package the game in 4.7 and were able to run it.

I have attached the log here.

Product Version: UE 4.8
Tags:
strategy.log (18.9 kB)
more ▼

asked Jun 15 '15 at 01:00 AM in Bug Reports

avatar image

John Alcatraz
1.2k 57 136 125

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi John Alcatraz,

I have not located your specific crash in our reporter tool, however, I have located many users experiencing crashes with near identical error messages (all variations on Assertion failed: !HasAnyFlags(RF_NeedLoad|RF_NeedPostLoad) File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.8\Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectLinker.cpp [Line: 96] Detaching from existing linker for 'XXXXproject.umap/.uasset' while object 'XXXX(typically ArrowComponent)' needs loaded) and call stack commonalities involving these modules:

UObject::SetLinker()

FLinkerLoad::Detach()

FLinkerLoad::~FLinkerLoad()

FLinkerLoad::`scalar deleting destructor'()

I have reported this crash; for reference, the issue number is UE-15537. I will update this thread when I have more information regarding the status of the crash.

In the meantime, here is another AnswerHub thread wherein a user was experiencing a similar crash, and the staff was able to provide a workaround. Have a look and see if it is of any use to you.

Thanks!

more ▼

answered Jun 15 '15 at 07:26 PM

avatar image John Alcatraz Jun 15 '15 at 08:29 PM

Thanks! Good to know I'm not the only one having this problem, hopefully you will be able to fix this in a 4.8 hotfix. Also thanks for linking the other thread, but unfortunately I never get the location of a component, so I can't change anything there... I sometimes do stuff like changing the mesh in a StaticMeshComponent or changing it's rotation, but I can't workaround this.

avatar image John Alcatraz Jun 24 '15 at 04:48 PM

It's fixed in 4.8.1, thanks!

avatar image wittlief ♦♦ STAFF Jun 24 '15 at 04:56 PM

Hey, that's great news! Thanks for reporting back that the fix is in.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question