x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

3D Widget Crashing Standalone Mode On Construct

I have 3D widgets that are aligned to the player's camera in-game. They have no other functionality aside from having their text set on startup. They run fine in the editor, but as soon as I launch a test in standalone mode, I get a crash before they can be displayed and get the following error:

 Access violation - code c0000005 (first/second chance not available)
 
 UE4Editor_SlateRHIRenderer!FSlateRHIRenderingPolicy::DrawElements() + 1977 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\slaterhirenderer\private\slaterhirenderingpolicy.cpp:315]
 UE4Editor_SlateRHIRenderer!FSlate3DRenderer::DrawWindowToTarget_RenderThread() + 751 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\slaterhirenderer\private\slate3drenderer.cpp:113]
 UE4Editor_UMG!TGraphTask<`UWidgetComponent::TickComponent'::`15'::EURCMacro_UWidgetComponentRenderToTexture>::ExecuteTask() + 481 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\public\async\taskgraphinterfaces.h:667]
 UE4Editor_Core!FTaskThread::ProcessTasks() + 3125 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\async\taskgraph.cpp:428]
 UE4Editor_Core!FTaskThread::ProcessTasksUntilQuit() + 77 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\async\taskgraph.cpp:271]
 UE4Editor_RenderCore!RenderingThreadMain() + 183 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\rendercore\private\renderingthread.cpp:282]
 UE4Editor_RenderCore!FRenderingThread::Run() + 58 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\rendercore\private\renderingthread.cpp:385]
 UE4Editor_Core!FRunnableThreadWin::Run() + 102 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:73]
 UE4Editor_Core!FRunnableThreadWin::GuardedRun() + 93 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:26]
 kernel32 + 88525 bytes
 ntdll + 178321 bytes

Any idea if there's a workaround for this? It's pretty vital for my project and time is of the essence.

Product Version: UE 4.7
Tags:
more ▼

asked Jun 15 '15 at 04:44 PM in Bug Reports

avatar image

ADaurio
23 4 5 7

avatar image Rudy Q ♦♦ STAFF Jun 15 '15 at 06:32 PM

Hello ADaurio,

I was unable to reproduce this issue on our end. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed set of steps in order to reproduce this issue on our end?

  3. Could you provide screen shots of any blueprints that may be involved with this issue?

avatar image ADaurio Jun 16 '15 at 09:35 PM

I can't seem to reproduce this issue in a fresh project. This is the blueprint I'm using in both the new and old projects to rotate the 3D widget. Nothing else is ever done to the 3D widget aside from setting its text dynamically on startup.

The 'Scene' component is rotated in place of the 3D widget to act as a proxy pivot.

[Edit]: I've discovered that removing this tick functionality and switching the 3D widget to use screen space instead of world space prevents the crash. Unfortunately it doesn't work as well for our purposes. I'd still like to find a solution to this if possible.

alt text

capture.png (312.5 kB)
avatar image Rudy Q ♦♦ STAFF Jun 17 '15 at 02:20 PM

Hello ADaurio,

If you get the position of the player pawn instead of the camera do you still get the crash?

avatar image Rudy Q ♦♦ STAFF Jun 22 '15 at 01:18 PM

Hello ADaurio,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

avatar image spaceharry Jul 19 '15 at 08:51 PM

This just happend to me to with same error log in 4.8.2. After doing the same thing in a new actor and a new widget the crash doesnt happen anymore.

Edit: The crash only happens in standalone or packaged games as well.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello spaceharry,

With the information that you provided and after doing a bit of digging I believe this is a known issue (UE-16915). It has been sent to the developers for further consideration. Thank you for your time and information.

Make it a great day

more ▼

answered Jul 20 '15 at 01:28 PM

avatar image

Rudy Q ♦♦ STAFF
47.3k 545 132 525

avatar image spaceharry Jul 20 '15 at 01:55 PM

I think I found a way how to produce the same error log for this.

Make a third 3person bp project with actor containing a 3d widget. Then set the custom size of the widget to 8000*4000. Put in a text component with font size 700.

In the actor exp. widget set same size for the 3d widget and pivot x and y to 0. With event tick inside the actor get the game time and put in set text for text widget.

This crash happens on my pc with only 8gb ram and r290.Sometimes it only crashes in standalone

Edit: It seams that only text size 700 alone in the widget text can crash the editor when beeing modified over 3d widget.

avatar image TheFoyer Mar 31 '16 at 03:30 AM

Currently ran into this issue in 4.10. Had a font in a 3d widget that was over 800. After updating the text 3 times the editor would crash. Lowered font size fixed the issue.

avatar image tusso Nov 12 '15 at 03:40 PM

spaceharry you saved our lives! It was 3 days wandering around this crazy crash... we just removed a setfont inside the tick event of a userwidget blueprint... et voilà! It doesn't crash anymore!

Please Epic fix this!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question