x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Launch/Build on iOS failed to install

Hi,

I am new to iOS deploy process.

I created a new project from a template "Third Persion". Then, I refer to [iOS quick start] document, and follow IPhonePackager.exe created .key file and .mobileprovision file. After restart Launcher and load up my project, I press the Lauch all ios device button. It failed.

Please help thanks.

attached is the log file.

and here is some final lines:

LogPlayLevel: DeploymentServer: [DD] ... Install is 40% complete at phase 'VerifyingApplication' LogPlayLevel: DeploymentServer: Install \ Update of "MyProject4.ipa" failed with There is a problem with the entitlements for this application (0xE8008016) in 11.31 seconds LogPlayLevel: DeploymentServer: [DD] LogPlayLevel: DeploymentServer: Exiting. LogPlayLevel: CommandUtils.Run: Run: Took 22.1042643s to run DeploymentServer.exe, ExitCode=1 LogPlayLevel: ErrorReporter.Error: ERROR: AutomationTool error: Command failed (Result:1): C:\Program Files\Epic Games\4.8\Engine\Binaries\DotNET\IOS\DeploymentServer.exe Install -ipa "D:\temp\MyProject4\Binaries\IOS\MyProject4.ipa" -device All_iOS_On_RICHARD-PC -additionalcommandline "-SessionId=9EC89C4D4100B7A3E549639316DB0B4C -SessionOwner=Richard -SessionName='Play On Device' ". See logfile for details: 'DeploymentServer.1.txt' LogPlayLevel: BuildCommand.Execute: ERROR: BUILD FAILED LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception: LogPlayLevel: Program.Main: ERROR: Exception in AutomationTool: Command failed (Result:1): C:\Program Files\Epic Games\4.8\Engine\Binaries\DotNET\IOS\DeploymentServer.exe Install -ipa "D:\temp\MyProject4\Binaries\IOS\MyProject4.ipa" -device All_iOS_On_RICHARD-PC -additionalcommandline "-SessionId=9EC89C4D4100B7A3E549639316DB0B4C -SessionOwner=Richard -SessionName='Play On Device' ". See logfile for details: 'DeploymentServer.1.txt' LogPlayLevel: Stacktrace: 於 AutomationTool.CommandUtils.RunAndLog(String App, String CommandLine, String Logfile, Int32 MaxSuccessCode, String Input, ERunOptions Options, Dictionary`2 EnvVars) LogPlayLevel: 於 IOSPlatform.Deploy(ProjectParams Params, DeploymentContext SC) LogPlayLevel: 於 Project.Deploy(ProjectParams Params) LogPlayLevel: 於 BuildCookRun.DoBuildCookRun(ProjectParams Params) LogPlayLevel: 於 BuildCommand.Execute() LogPlayLevel: 於 AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands) LogPlayLevel: 於 AutomationTool.Automation.Process(String[] CommandLine) LogPlayLevel: 於 AutomationTool.Program.MainProc(Object Param) LogPlayLevel: 於 AutomationTool.InternalUtils.RunSingleInstance(MainProc Main, Object Param) LogPlayLevel: 於 AutomationTool.Program.Main() LogPlayLevel: Program.Main: ERROR: Command failed (Result:1): C:\Program Files\Epic Games\4.8\Engine\Binaries\DotNET\IOS\DeploymentServer.exe Install -ipa "D:\temp\MyProject4\Binaries\IOS\MyProject4.ipa" -device All_iOS_On_RICHARD-PC -additionalcommandline "-SessionId=9EC89C4D4100B7A3E549639316DB0B4C -SessionOwner=Richard -SessionName='Play On Device' ". See logfile for details: 'DeploymentServer.1.txt' LogPlayLevel: ProcessManager.KillAll: Trying to kill 0 spawned processes. LogPlayLevel: Program.Main: AutomationTool exiting with ExitCode=1 LogPlayLevel: Domain_ProcessExit LogPlayLevel: ProcessManager.KillAll: Trying to kill 0 spawned processes. LogPlayLevel: copying UAT log files... LogPlayLevel: RunUAT.bat ERROR: AutomationTool was unable to run successfully. LogPlayLevel: Completed Launch On Stage: Deploy Task, Time: 33.752706 LogPlayLevel: BUILD FAILED PackagingResults:Error: Error Deployment failed! Unknown Error

link text

Product Version: UE 4.8
Tags:
faillog.txt (291.0 kB)
more ▼

asked Jun 16 '15 at 08:29 AM in Packaging & Deployment

avatar image

rz1974
146 11 15 22

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi,

Me again. I found the problem is that in Project settings => Platforms => iOS Boundle Identifier should be changed from com.YourCompany.[PROJECT_NAME] to com.RealCompanyNameThatMatchAppID.[PROJECT_NAME] So the entitlement of App to be install on device is ok now. This question can be mark as [RESOLVED]. But, please update iOS quick start online document. It does not mention this requirement and the integration of IphonePackager into Editor.

more ▼

answered Jun 17 '15 at 07:00 AM

avatar image

rz1974
146 11 15 22

avatar image JGI-Tom Jul 07 '15 at 09:53 AM

Hi, I'm having struggels with this aswel. Could you show me a sceenhot of the settings? My company name has spaces and dots in it, so i'm not sure how to enter.

Thanks

avatar image leadermax Oct 03 '18 at 11:16 AM

For everyone else having the same problem, i'm building remotely on a mac and my proble was that Xcode was running causing some interference. Closing it solved it. No need to change fake company name

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question