x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Android build fails

I compiled 4.8 source in both 'Development Editor' and 'Development' separately.Out of which Development Editor didnt allow me to package for any platform but 'Devlopment' allowed for only win64 packaging and not android.

1.Automation tool unable to run 2.missing reciept 'UE4Game-Android-Development.target.xml' error

are what i got but have no idea about them.

I last used 4.7 binary version which was able to package only for win 64 and Android ETC2.It confirms Android sdk is set up properly.

here is complete log. link text

Product Version: UE 4.8
Tags:
log.txt (406.5 kB)
more ▼

asked Jun 16 '15 at 12:35 PM in Packaging & Deployment

avatar image

lazysnake61
26 1 3

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

After setting up TADP sdk, i ran setup.bat and when prompted about certain files modification i chose no.After that i ran generateprojectfiles,bat and then used Build UE4 in VS with Development config and Android platform. I can export to Android now...strange.

more ▼

answered Jun 17 '15 at 02:23 PM

avatar image

lazysnake61
26 1 3

(comments are locked)
10|2000 characters needed characters left

Hi!

For Engine, which were built from Git sources, you need build additional libs for Android. In VS 2013 select Development Editor/ Android-Tegra build configuration and select Build. And try to create package for android again.

more ▼

answered Jun 16 '15 at 01:28 PM

avatar image

svv3dUDN
8.4k 254 41 399

avatar image lazysnake61 Jun 16 '15 at 03:29 PM

There is no such option as Development Editor/ Android-Tegra in VS community edition.

avatar image svv3dUDN Jun 16 '15 at 03:40 PM

VS solution always generated with this configuration.

alt text

tyegra.png (6.3 kB)
avatar image lazysnake61 Jun 16 '15 at 04:18 PM

i dont have that in my list.

avatar image wittlief ♦♦ STAFF Jun 16 '15 at 05:15 PM

Hi lazysnake61,

Do you have the TADP version of Android SDK (now called NVIDIA AndroidWorks) , or the stand alone Android SDK?

avatar image lazysnake61 Jun 17 '15 at 02:49 AM

stand alone

avatar image lazysnake61 Jun 17 '15 at 12:05 PM

i also downloaded TADP version but it still fails.

avatar image wittlief ♦♦ STAFF Jun 17 '15 at 01:50 PM

Can you see Tegra-Android as a selection in Visual Studio, now?

avatar image lazysnake61 Jun 18 '15 at 06:47 AM

No the tegra option is not in VS list but it is listed in the window that opens after selecting from the platform list.However selecting it gives error "operation could not be completed".

btw i can package only development build (not shipping) build now.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question