x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Textures sometimes blurry, sometimes not

Hi there,

In about 3 of 10 cases, all my textures are looking blurry as hell, even in the editor:

alt text

When i start a PIE session and end it (sometimes I need to do that more than once), they look right:

alt text

If this is the case, it doesn't matter how long I am waiting, the textures just stay blurred.

There seems no way to just load the textures and not stream them at all. So I tried to run this function on startup on my car blueprint:

alt text

But this doesn't work in a reliable way. I tried to use the console command 'r.textureStreaming 3' to improve quality, but it just has no effect. If I deactivate texture streaming with 'r.textureStreaming 0' all textures disappear completely.

These are the settings of one of the textures (they are all configured the same):

alt text

So

  • How to stabilize the texture streaming OR

  • Make sure, that always the highest quality texture is been used

Many thanks,

spyro

Product Version: UE 4.8
Tags:
more ▼

asked Jun 16 '15 at 12:48 PM in Rendering

avatar image

spyro
1.7k 105 116 229

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi!

If you not needed texture streaming, you can disable this in two ways.

  1. In Texture parameters disable streaming set Never Stream (global)

alt text

  1. In Mesh Details increase Streaming distance Multiplayer (per object)

alt text

texturest01.png (291.9 kB)
texturest02.png (163.9 kB)
more ▼

answered Jun 16 '15 at 01:55 PM

avatar image

svv3dUDN
8.4k 254 39 399

avatar image spyro Jun 16 '15 at 02:46 PM

Many thanks,

so there is no global setting, I have to manually set this to every single texture?

The strange thing is, that I did already set the streaming distance multiplier on meshes, but this sometimes just has no effect...

avatar image Tim Hobson ♦♦ STAFF Jun 17 '15 at 09:55 PM

If you want no textures to ever stream you can adjust this for the entire project via the Project Settings > Rendering > Textures > Texture Streaming checkbox.

It's enabled by default. Disabling this can have performance implications since textures get streamed based on distance to lower the resolution for better performance. It's better to adjust in the individual textures or materials the mip values than using this option.

avatar image spyro Jun 18 '15 at 09:59 AM

Hi Tim,

if I uncheck this box, ALL the textures are blurry (it's the same as 'r.texturestreaming 0'. Shouldn't it be the other way around?

avatar image Yahiya Jasem Jun 30 '15 at 06:54 PM

Have the same issue!

avatar image spyro Jun 22 '15 at 05:06 PM

Er, hello...? ;)

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question