x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cannot lunch my game on android device.

Hello. I have a problem with lunching the project on android device. I have tried to lunch the basic project on Samsung galaxy S5. Everything is fine until the last PERFORMING FINAL APK PACKAGE OPERATION where in the log is error with ant.bat. I have install everything according to this tutorial https://www.youtube.com/watch?v=e9YApCIx18Q, Set all envirnomental variables in the Windows and set all information in the AndroidSDK in UE4. I even reinstalled UE4, JavaSDK and still have the same problem. If you know what might cause this problem, Please writ it.

I have attached the build log below

link text

Product Version: UE 4.8
Tags:
more ▼

asked Jun 17 '15 at 12:43 PM in Packaging & Deployment

avatar image

Rafciok_6
6 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Rafciok_6,

I see this in your logs:

Error: Target id 'lastest' is not valid.

You will want to set your SDK to 'android-19' and not 'lastest'. That might fix the problem entirely.

If not, the error you're getting is

ERROR: Exception in UnrealBuildTool: ERROR: cmd.exe failed with args /c "C:/NVPACK/apache-ant-1.8.2/bin/ant.bat" debug

which is hard to diagnose. Here is another thread with several suggestions of what might be causing the problem.

Good luck!

more ▼

answered Jun 26 '15 at 09:04 PM

avatar image Rafciok_6 Jun 28 '15 at 12:25 PM

Hi Thanks for your answer. I have solved this problem. The problem was with the ant.bat and java. I had multiple version of java and two versions of ant installed on the computer. After reinstall windows and install sdk on the fresh installed system problem disappeared. This is probably not the best solution but it worked for me. Hope this advice will help someone. Thanks

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question