Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

ActorComponent in Actor is crashing UE4 in standalone and on editor opening

I have created an Actor component which does not do much, is inherits from one Interface and is has one function of the interface implemented and then set's the custom time dilation of it's owner.

But if I add this Actor Component to one of my Actors and try to run the game in standalone, the standalone process crashes with this log

The Error is:

 Assertion failed: !HasAnyFlags(RF_NeedLoad|RF_NeedPostLoad) [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.8\Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectLinker.cpp] [Line: 96] 
 Detaching from existing linker for I:/Unreal Projects/Projekte/Strategy 4.8/Content/Assets/Characters/Civilian.uasset while object PauseComponent_C /Game/Assets/Characters/Civilian.Civilian_C:PauseComponentBD49C2AB4053139B89950CAE76A89DF9 needs loaded

And even worse, it's even crashing the editor on opening. I noticed this by accident, actually I wanted to get into the "Saved" folder to access the logs, but I "missclicked" and instead double clicked the uproject file so that my project loaded, and then I saw it does not even load, it just crashes. This really was luck, if I would not have noticed it I would not be able to open my project again the next time I have closed it (I would have had to replace the Civilian.uasset with an autosave). Now I had the possibility to look into the log and see that the ActorComponent is causing this and I have removed it, so I can open my project again. The whole time the editor itself stayed opened and did not crash, neither on compile of any blueprint nor on save.

Product Version: UE 4.8
more ▼

asked Jun 17 '15 at 04:20 AM in Bug Reports

avatar image

John Alcatraz
1.3k 60 139 128

avatar image Samantha Sutton ♦♦ STAFF Jun 19 '15 at 04:53 PM


Have you tried deleting the intermediate, config and saved folders from your project file? If so, did that allow your project to open? Could you also try to move those assets to a blank project and see if you receive the same crash or not? I'm curious whether or not the asset is corrupted, or if the blueprint is set up incorrectly. What happens if you take those assets out of your project temporarily, do you still run into issues with your project?

Looking forward to hearing back from you, thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi John,

This has been fixed with this commit: https://github.com/EpicGames/UnrealEngine/commit/7259ef4fd26e4f4c10c3ba0cce0e17650abc74c1

You had some really gnarly cyclical dependencies in there.

more ▼

answered Jul 15 '15 at 06:28 PM

avatar image

User-1420270633 STAFF
968 27 26 58

avatar image John Alcatraz Jul 15 '15 at 08:02 PM

Hi Mike, great to hear, thanks!

Do you know whether there will be a 4.8.3 or will I have to wait for 4.9 to have this fix?

avatar image Samantha Sutton ♦♦ STAFF Jul 16 '15 at 06:39 PM

Hey John,

Looking over the UE-17388 bug report, it looks as if it'll be fixed in 4.9.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Thanks, but I don't have any problems with my project now because I removed the ActorComponent from the Actor while the editor was still running. If I add it and save I can't open the project, if I remove it and save I can open it. If I remove the ActorComponent completely of course I can't run into any issues because it's not there :P It will for sure also happen in a blank project, just set the ActorComponent up as I descriped and it will crash. I guess it's just some bug with the CustomTimeDilation Node with the owner as the target.

more ▼

answered Jun 19 '15 at 05:05 PM

avatar image

John Alcatraz
1.3k 60 139 128

avatar image Samantha Sutton ♦♦ STAFF Jun 19 '15 at 05:45 PM

Hey John,

Could you please zip your project with the asset included, or simply provide us the actor that's causing this issue so that we can investigate this crash further? I've entered a bug report to our developers, which is listed as: UE-17388.

Thank you, and I'm so glad that removing the actor from your project fixed the issue.

avatar image John Alcatraz Jun 20 '15 at 01:48 AM

Thanks! I have tried to reproduce it in a clean project but I have not get it to crash there, so I migrated the Component into a new project with the files it references and removed some stuff inside there to make it as small as possible, I will send you a download link to this in a PM in the forums! The project crashes on startup, so you won't be able to see much there. Thanks again! :)

avatar image Samantha Sutton ♦♦ STAFF Jun 22 '15 at 05:38 PM

Hey John,

Thanks for providing us with the actor component that's causing this crash. I have provided the project to our developers so they can look into this further. If you have any further questions on this topic, or would like to check up on this bug in the future, do not hesitate to reply back.

Have a great week!

avatar image John Alcatraz Jul 06 '15 at 11:05 PM

Hi Samantha, could you give me any info on whether anything was done in regarding this bug yet or if your devs might have a workaround for this? Thanks!

avatar image Samantha Sutton ♦♦ STAFF Jul 08 '15 at 04:11 PM

Hey John,

This bug is considered critical and is assigned to a developer at this time. Unfortunately, it's still unresolved at this time. Hopefully they will be able to fix it for 4.9 release, but I can't guarantee at this time.

Feel free to check back in the next week or two. Have a wonderful day. :D

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question