x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Getting compile error , cannot open InputCoreTypes.generated.h.

Hi , I have suddently started getting the below compile error , while trying to create any UE project from scratch in 4.8.

CompilerResultsLog:Error: Error c:\program files\epic games\4.8\engine\source\runtime\inputcore\public../Classes/InputCoreTypes.h(5) : fatal error C1083: Cannot open include file: 'InputCoreTypes.generated.h': No such file or directory

Kindly let me know what can cause this issue and how do i fix this

Product Version: UE 4.8
Tags:
more ▼

asked Jun 17 '15 at 09:13 AM in Bug Reports

avatar image

sameek4
145 38 40 69

avatar image Matthew J Jun 24 '15 at 07:47 PM

Hi sameek4,

I have a few questions for you about this report.

  • Are you using a binary version of the engine or have you built your engine from source code?

  • Is this happening in a project that you're making using a binary version of the engine, by hitting 'New Project', selecting C++, and then 'Basic Code'?

  • What version of Visual Studio are you using? This would be the year such as 2012 or 2013 and also the type such as Express or Community.

avatar image sameek4 Jun 24 '15 at 07:53 PM

Hello

I was using binary version. It occurred suddenly and was happening in both VS. 2013 ultimate and community And it happened when I opened new project and then basic code

However after building from source code, I am not having any issues

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

6 answers: sort voted first

Hi!

Has anyone managed to solve that problem? Cause I'm experiencing the same issue since I updated to UE 4.12. Also, this only happens when I'm trying to build in DevelopmentServer or DevelopmentClient configuration.

Any help would be much aprreciated!

more ▼

answered Jun 16 '16 at 07:07 AM

avatar image

gattusov
56 1 2 3

avatar image Matthew J Jun 16 '16 at 02:20 PM

Hello gattusov,

Unfortunately I was unable to continue looking into it as I hadn't reproduced it and the users experiencing it stopped responding. Are you receiving the exact same errors that Asher posted above? If not, could you post your error log / output log from Visual Studio? I'm assuming this is true based off the way you worded your message but were you able to compile for these configurations correctly in previous versions of the editor? Have you tried doing this with a project that was created in 4.12 to see if the results may be different?

avatar image adipFTW Jul 08 '16 at 10:05 AM

Hey Matthew, I'm experiencing exactly the same problem and it's keeping me from comipiling my server solution. This is the output and error log (partially german, sorry):

1>------ Erstellen gestartet: Projekt: WarForOrion, Konfiguration: Development_Server x64 ------

1> Performing 4 actions (4 in parallel)

1> PCH.WarForOrion.h.cpp

1>c:\program files (x86)\epic games\4.12\engine\source\runtime\inputcore\public../Classes/InputCoreTypes.h(5): fatal error C1083: Datei (Include) kann nicht geöffnet werden: "InputCoreTypes.generated.h": No such file or directory

1>ERROR : UBT error : Failed to produce item: C:\Users\Julius Lange\Documents\Unreal Projects\WFOTemp\Binaries\Win64\WarForOrionServer.exe

1> Total build time: 4,02 seconds

1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets(37,5): error MSB3075: Der Befehl ""C:\Program Files (x86)\Epic Games\4.12\Engine\Build\BatchFiles\Build.bat" WarForOrionServer Win64 Development "C:\Users\Julius Lange\Documents\Unreal Projects\WFOTemp\WarForOrion.uproject" -waitmutex" wurde mit dem Code 5 beendet. Stellen Sie sicher, dass Sie zur Ausführung dieses Befehls berechtigt sind.

========== Erstellen: 0 erfolgreich, 1 fehlerhaft, 0 aktuell, 0 übersprungen ==========

I'm using the binary version of 4.12.5 and VS 2015 Community Update 2. I've also looked if the github version of the engine includes the missing file, but also found it missing there: .

avatar image Matthew J Jul 12 '16 at 07:31 PM

Hello adipFTW,

That particular file is a .generated.h file. These are part of the Intermediate folder and are generated when you generate your project files. They would not be present on Github as the files on Github are of a build that has yet to have project files generated for it. It sounds like a red herring, an error that is saying something that we shouldn't really be focusing on.

Are you attempting to package a Dedicated Server? If so, this is something that you'll need a source build to do, as building for Development Server is not available in a Binary build.

avatar image laice Jul 09 '17 at 04:34 PM

Just wanted to highlight this answer because not finding the generated InputCoreTypes.generated.h file is the first compiling error someone new to dedicated servers will get when trying to compile and not using a source build. Switching to the source build is probably the solution for most of the people searching for this.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

We should start with the most simple solution available, seeing as your source code version is working. Please try verifying the install by hitting the arrow beside the version number in the launcher under the Library tab. If that doesn't change anything, can you try doing a fresh install of the binary version of the engine to see if that fixes the problem?

more ▼

answered Jun 24 '15 at 08:03 PM

avatar image Matthew J Jun 30 '15 at 09:43 PM

Hi sameek4,

Was my last comment helpful or are you still experiencing this issue? I'll be happy to assist you further if you are still blocked by this problem.

avatar image Asher S Einhorn Sep 23 '15 at 09:18 AM

Hi there, I am actually experiencing this issue by building the source code. I'm going to try a full recompile to see if that fixes the issue.

avatar image Asher S Einhorn Sep 23 '15 at 09:22 AM

if i make a new code project I get random other errors about missing generated files - alt text

capture.png (16.1 kB)
avatar image Matthew J Sep 23 '15 at 08:04 PM

Hello Asher,

Have you tried the binary version of the engine to see if that works correctly by comparison? If so, can you try generating project files again and if that doesn't work, redownloading the source code? It may simply be missing files that could be causing this compilation error.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This is caused by deleting Engine/Intermediate/Build for binary engine builds.

FIX: The solution is to use the launcher, click the triangle next to the engine version and select "verify" it will then re-download the missing Build folder, which contains the InputCoreTypes.generated.h among others.

I'd like to report that this issue is caused by deleting the Intermediate folder after generating the C++ project. I used 4.13.2 and created a new project, then added a C++ class and generated the VS2015 project. Then I deleted the Intermediate folder. Now re-generating the VS project does not re-generate the InputCoreTypes.generated.h

more ▼

answered Aug 14 '17 at 10:13 AM

avatar image

fxtentacle
86 3 8

avatar image fxtentacle Aug 14 '17 at 10:23 AM

Also, after this problem occurred for one of my uprojects sharing the same engine, it now occurs for all of them. So the problem seems to be some sort of "lost state" in the engine folder. I'm using the binary engine downloaded using the launcher.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

We haven't heard from you in a while, adipFTW. Are you still experiencing these issues? If so, have you tried what I suggested in my previous post? In the meantime, I'll be marking this issue as resolved for tracking purposes. Please leave a comment whenever you're available to continue.

more ▼

answered Jul 18 '16 at 08:27 PM

avatar image luizcarlosfx Jun 01 '17 at 12:21 AM

Hi I'm facing this issue too. I'm using the binary build of the engine and Visual Studio 2017 Community (UE 4.15.3)

avatar image Matthew J Jun 01 '17 at 03:39 PM

Hello luizcarlosfx,

As you can see from all of the previous posts, every person who I've attempted to assist with this issue hasn't responded back to let me know if what I suggested fixed their issue. Could you try all of the suggestions I gave to them to see if it can help you? If not, as this question has gotten a little out of hand, can you make a new post for further assistance?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

one more person facing this issue. i made installed build win64 with buildgraph for internal distribution.

one of my coworkers get duplicated installed build, he want to migrate his work from D drive somewhere to C drive somewhere. the first build editor works fine but second miss all generated header files in the engine/intermediate folder. i tried to regenerate visual project files with right clickingon my uproject, it didn’t work. after this, i deleted both build editors and remove the value of guid in registry ( epic games/build ). and then re-downloading my installed editor. but the problem still is there. cannot find inputcoretypes.generated.h.

my installed build editor couldn’t generate those header files. now i just copied my generated header files in engine/inteemediate into my coworker’s and it’ solved but it feels going tricky and naughty.

i want to fix this. any help plz.

more ▼

answered Jun 01 '18 at 12:03 PM

avatar image

gawoon
16 1 10 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I'm getting this same issue (missing InputCoreTypes.generated.h error) when attempting to compile a dedicated server with a binary engine. Going to try compiling from source next.

I also tried copying InputCoreTypes.generated.h from Engine\Intermediate\Build\Win64\UE4\Inc\InputCore into Engine\Source\Runtime\InputCore\Classes and the error was resolved... but it just moved onto the next missing generated file, I tried a few before giving up. It appears all of those files exist under Engine\Intermediate* but they just aren't properly linked or copied.

more ▼

answered Jun 26 '18 at 04:00 PM

avatar image

Dorian000
1 1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question