x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

VS 2013 build errors UE 4.8

Hey guys, I have a problem with compiling Unreal Engine source. alt text

Main problem is probably with windows.h. I read how to solve this problem, but nothing helps. I am using Windows 7 64bit and my VC++ Directories are set to inherit from parent. Unreal Engine 4.8 release source version from github.

What I've tried already:

  • reinstalled VS 2013/ installed different version.

  • installed Windows SDKs for Windows 7.

  • installed Windows Kits 8,8.1,10.

  • installed .NET 4.5+.

  • tried different VC++ Directories settings from my SDKs and Kits.

  • tried newer VS platform set (2015) - apparently not supported yet.

  • tried to run VS as an admin.

  • tried to check VS120COMNTOOLS path.. it's ok, probably even main path.

  • checked my Windows username - normal without bad characters.

  • tried to correctly check Setup.bat and Generate..bat whether my source is missing something.

  • tried to check anti-virus blocking or another program interference with access to files.

  • tried to update my Windows.

  • tried to check my DirectX - installed v11.

I feel like this is going to be a serious hardcore problem or really stupid easy one.

I don't know what to do now, so I ask for your help. Thanks for any answers !

Product Version: UE 4.8
Tags:
unreal.png (151.4 kB)
more ▼

asked Jun 17 '15 at 11:27 AM in Installation & Setup

avatar image

Aldraz
1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Aldraz-

Based on the errors shown (RC1015 and C1083) you're correct that the likely issue is with Windows.h. If you've already tried to install the SDK then you may want to check that the dependencies are correct by running Setup.bat and GenerateProjectFiles.bat again. Also make sure that your anti-virus is not blocking access to Epic/UnrealEngine.

Cheers

Doug Wilson

more ▼

answered Jun 17 '15 at 04:04 PM

avatar image Aldraz Jun 17 '15 at 05:33 PM

Hey Doug,

Thanks for your answer. I have tried to run Setup.bat and GenerateProjectFiles.bat to check that the dependencies are correct many times.. no warnings what so ever, so I think source is OK. But I probably try to download older version, to find out whether the problem sustains. Anyway I tried to turn off anti-virus and all potencial program which could interfere with access to files.. and even windows firewall.. I even allowed whole folder full access for every single account. Still nothing helps, but I am not giving up! Currently updating Windows 7 hoping it will help. Cheers.

avatar image Doug E ♦♦ STAFF Jun 22 '15 at 06:27 PM

Hey Aldraz-

I haven't heard from you and just wanted to find out if updating Windows was able to solve the build errors you were getting. If you are still having any problems getting the editor started please comment here and let us know if anything has changed or if you're still getting the same error messages.

avatar image Aldraz Jun 24 '15 at 05:42 PM

Hey Doug,

so I tried to update Windows, unfortunately it did not help. I also tried reinstalling couple times Visual Studio. I somehow managed to get into even worse state - my VS 2013 crashes on startup, so currently I am fixing this problem. I will hopefully post my final answer after couple days. I think I know where is the problem already, but first things first - I have to repair my VS.

avatar image Doug E ♦♦ STAFF Jun 30 '15 at 04:48 PM

Hey Aldraz-

Were you able to fix the issues with VS? Let me know if you've got that running again and if you were able to test the theory you had on fixing your compile issue as well.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question