x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Material Editor Crashing

Every time I try to open up the material editor in 4.8 my engine crashes. It doesn't print a crash report however. If I create a new material, I can try to put something in it but it just crashes. If I open certain materials already made, my engine will crash.

Product Version: UE 4.8
Tags:
more ▼

asked Jun 17 '15 at 07:00 PM in Bug Reports

avatar image

OriginalUmp45
1 1 3 3

avatar image Lovecraft_K ♦♦ STAFF Jun 17 '15 at 07:16 PM

Hi -

Can you go into your project's Saved SubFolder and find the Project Logs and upload those logs here? Also if you can include a copy of your DXDIAG and a copy of your Windows Event Viewer event for the crash in question?

For Windows Event Viewer, Type 'eventvwr' in Run and then select the Error event which occurred at the time of your engine crash. Save out that file to an *.evtx file and upload it here in a zipped file with your Logs and DXDIAG.

Thank You

Eric Ketchum

avatar image OriginalUmp45 Jun 21 '15 at 02:21 AM

link text Those should be all of the files. Notify if they are not. Thanks.

ue4_files.zip (93.6 kB)
avatar image OriginalUmp45 Jun 21 '15 at 02:30 AM

Also I tried to reproduce this bug in 4.7 and 4.6 and it did not occur.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi -

Thank you for the additional information. I dug through your logs and the event viewer and it seems that the DLL system file (igdusc64.dll) for your Intel Graphics card is causing a fault in the engine most likely when the Material Editor is trying to compile a shader. The best bet to correct this error is to download the latest version of the Intel HD 4600 Drivers, which can be found here. Your drivers are listed as being build 10.18.10.4061 and the latest driver version is 15.36.21.64.4222.

Eric Ketchum

more ▼

answered Jun 22 '15 at 01:51 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 735

avatar image OriginalUmp45 Jun 22 '15 at 05:26 PM

When I tried to install it I received an error stating that I have a custom graphics card. When I looked on the OEM's website I couldn't find the drive. Any ideas on how I can fix that? I am using a laptop if that changes anything

avatar image Lovecraft_K ♦♦ STAFF Jun 22 '15 at 05:36 PM

Does your laptop register any drivers or other updates from Windows Update? Try running that and see if a video driver does not show up as an optional update. Also often DXDIAGs will only show one graphics cards particular in laptops, do you have an installed Nvidia Graphics card or a piece of software called Nvidia Optimus installed?

Thank You -

Eric Ketchum

avatar image OriginalUmp45 Jun 22 '15 at 06:04 PM

I don't have any updates available in Windows Update. Also the only Nvidia software I have installed is Nvidia Physx.

avatar image OriginalUmp45 Jun 22 '15 at 08:19 PM

I tried that. Whenever it checked my drivers it said the Intel HD 4600 was "Good."

avatar image OriginalUmp45 Jun 23 '15 at 03:56 PM

Update: I tried a new project in 4.8 just to test. I was able to open up starter content materials without crashing however I couldn't open custom materials without it crashing.

avatar image Lovecraft_K ♦♦ STAFF Jun 23 '15 at 09:08 PM

Hi -

Can you send me the uasset file from one of the custom Materials that is causing the crash?

Thank You

Eric Ketchum

avatar image OriginalUmp45 Jun 24 '15 at 12:46 AM

link text

 I had to upload it to a zip. Hope you don't mind. 
uasset_files.zip (504.1 kB)
avatar image Lovecraft_K ♦♦ STAFF Jun 24 '15 at 01:53 PM

Hi -

Zip File is fine, but I only received a texture file? So is the crash occurring with the Texture Editor or when applying this texture to a material and if the latter then how are you using the texture, where is it getting plugged in?

Thank You

Eric Ketchum

avatar image OriginalUmp45 Jun 24 '15 at 04:48 PM

My bad. I didn't mean to send the texture file. Here is the texture (just in case) and the material. The problem is occurring when I do anything in the material editor with any of my custom textures/materials. The texture editor is fine. link text

uasset_files.zip (567.6 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question