x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Holes in tessellated landscape

Hello I am trying to use the C-Media Advanced Material Pack Edition 2 material for the creation of my landscape. It is quite handy but I found some issues which I hope you will help to resolve. The problem is that there are some holes appearing in the landscape geometry. They become more obvious when you switch to the lower quality settings. I discussed this issue with the creator of the material pack, but there is no solution so far and I would be glad to receive any help right now. This is the thread where we discussed the issue - https://forums.unrealengine.com/showthread.php?53766-C-Media-Advanced-Material-Pack-Edition-2&p=313787#post313787 alt text

Product Version: UE 4.8
Tags:
land2.jpg (248.4 kB)
land3.jpg (320.0 kB)
land4.jpg (255.5 kB)
more ▼

asked Jun 18 '15 at 05:24 PM in Rendering

avatar image

Kvazimodo
31 4 8 7

avatar image AndrewHurley Jun 18 '15 at 08:52 PM

Hey Kvazimodo,

Would you mind showing me your material and landscape properties?

I noticed you selected the 'Crack Free Displacement' but would like to see the tessellation option you are using as well as your multiplier.

Thank you,

Andrew Hurley

avatar image Kvazimodo Jun 19 '15 at 08:27 AM

Hi Andrew,

Thank you for the answer. The Crack Free Displacement didn't give the desired effect so I turned it off later. Here are the options of the material and the landscape. I don't think that I can show everything [like the node tree] cause the author of the material might be against that.

Regards, Ivan

land16.jpg (178.5 kB)
land17.jpg (188.3 kB)
land18.jpg (183.1 kB)
land19.jpg (177.4 kB)
avatar image AndrewHurley Jun 19 '15 at 01:35 PM

Hey Kvazimodo,

Thank you for the images as requested. Firstly, apply the material to the 'Landscape Hole Material' slot within the details panel. Then, crank down the 'Displacement Modifier' by a lot. I would even set it to 0.0 to see if it is the displacement that is causing the issue. Secondly, change the tessellation method to PN Triangles and re-check 'Crack Free Displacement.'

Set the 'Static Lighting LOD' of your landscape back to the default value. Use all of these options as suggested together to hopefully hide the seams in your landscape. If you are still having trouble I will try to get the material for testing purposes internally.

Thank you,

Andrew Hurley

avatar image Kvazimodo Jun 19 '15 at 02:54 PM

Hi Andrew, Do you mean "Max Displacement" modifier that is set to 50? If so then I wouldn't like setting it to 0 because it results in the new holes that appear right in front of the camera like on this screenalt text

As for other options - I will try it Thanks

land8.jpg (168.9 kB)
avatar image Kvazimodo Jun 19 '15 at 03:12 PM

Well I did everything as you told, but the problem is still there + the huge fps drop.

avatar image AndrewHurley Jun 19 '15 at 03:43 PM

There is a scalar parameter value labeled 'Displacement Multiplier' within your landscapes material instance properties. which is set to 2000. You can keep the 'Max Displacement' set to 50 which sets a radius in from the player/camera in which displacement will be applied. This helps improve performance across large landscapes using tessellation.

avatar image Kvazimodo Jun 19 '15 at 04:14 PM

Yes, but in this material this scalar parameter works exactly as the "Max Displacement" - it sets the radius for displacement. There is another parameter which determines the intensity of displacement - of course the holes disappear when you put it to 0, but then there is no displacement going on at all. alt text

land19.jpg (181.5 kB)
avatar image Kvazimodo Jun 20 '15 at 04:59 PM

Solved it finally :) The solution is in this thread - https://forums.unrealengine.com/showthread.php?53766-C-Media-Advanced-Material-Pack-Edition-2&p=315316#post315316

Thank you for your help, Andrew

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

You need to find the values in which you still get displacement without creating holes. If the holes disappear at 0 displacement, this means the issue is directly correlated with the values you are setting.

alt text

47060-land19.jpg (77.6 kB)
more ▼

answered Jun 19 '15 at 06:17 PM

avatar image Kvazimodo Jun 20 '15 at 12:21 PM

Ok will try to figure it out

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question