x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Paper 2D Unlit lighting issue

A similar issue has been posted before here, but no solution was found and I wanted to post a "workaround." The video below shows how to get the lighting of the sprites correct with a "new" project but I cant for the life of me find the setting/option in the example project that makes it work.

Below is a video of two brand new projects running side by side. The project on the left was completely blank on creation while the project on the right used the 2D side scrolling template when creating the project. As you can see when I add the same 2D side scrolling template to the left project, Unlit isnt Unlit.

https://www.youtube.com/watch?v=eaFwj0X-AlU

Product Version: UE 4.8
Tags:
more ▼

asked Jun 18 '15 at 08:39 PM in Bug Reports

avatar image

OpticalShadows
276 23 26 43

avatar image OpticalShadows Jun 18 '15 at 10:42 PM

I'd like to add that after closing and reopening the project, the issue occurs on the template project as well.

avatar image OpticalShadows Jun 18 '15 at 10:49 PM

I also tried this with tappy chicken and it doesnt happen unless you change the project's target hardware from Uncategorized to one of the presets.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

So it looks like I've found the solution to the problem when writing my last comment. Turns out that you need to change your 2D game to Mobile/Tablet and Scalable 3D or 2D. alt text

capture.png (4.8 kB)
more ▼

answered Jun 18 '15 at 10:53 PM

avatar image

OpticalShadows
276 23 26 43

avatar image OpticalShadows Jun 19 '15 at 02:24 AM

Turns out this is directly linked with Mobile HDR. However turning this option off disables things like Bloom. Could someone explain how to keep bloom and have correct unlit lighting?

avatar image AndrewHurley Jun 23 '15 at 08:03 PM

Simply enable Mobile HDR within your 'Project Settings' under the 'Rendering' section. You will then be able to use the bloom post processing feature.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question