x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Begin Play events launch in different order in a packaged project

Hello,

Today I moved my project to 4.8 and everything works fine in the editor so far. Strange thing happens in a packaged project (I tested Development and Shipping versions, both 64-bit) - Begin Play events in my Level BP and player character started to launch in different order. In the editor character always begins first, then Level BP starts. In the packaged project it launches the other way around.

I tested the same project in 4.7 again and there everything works fine, both in the editor and after packaging.

Product Version: UE 4.8
Tags:
more ▼

asked Jun 20 '15 at 03:17 AM in Bug Reports

avatar image

Nox_A15
284 16 135 191

avatar image Rudy Q ♦♦ STAFF Jun 22 '15 at 02:38 PM

Hello Nox_A15,

I was unable to reproduce this issue on our end. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed set of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any blueprints that may have been involved?

avatar image Nox_A15 Jun 22 '15 at 05:35 PM

Hello Rudy,

I've just tried this on clean TPP templates in both 4.8.0 and 4.7.6 and reproduced the issue quite easily. I just added Event Begin Play in Level BP and character BP and connected it with Print. At the beginning of the game strings appear in order BPs are launched (with recently launched always on top). Below I attach projects and builds (development ones, for strings to be visible on screen), but I will delete the files from Dropbox when we are done with them, so I also add a few screenshots to show a difference.

Project and Dev Build (64-bit) in 4.7.6:

https://dl.dropboxusercontent.com/u/32968434/UE4_AnswerHub/UE4%20-%20BeginPlay%20Test%204.7.6.zip

Project and Dev Build (64-bit) in 4.8.0:

https://dl.dropboxusercontent.com/u/32968434/UE4_AnswerHub/UE4%20-%20BeginPlay%20Test.zip

[4.7.6] Editor alt text

[4.7.6] Build alt text

[4.8.0] Editor alt text

[4.8.0] Build alt text

bugtest.jpg (68.0 kB)
bugtest_dev_64.jpg (117.9 kB)
bugtest_476.jpg (76.4 kB)
(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello Nox_A15,

I was able to reproduce this issue on our end. I have written up a report (UE-17473) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your information and time.

Make it a great day

more ▼

answered Jun 22 '15 at 07:46 PM

avatar image

Rudy Q ♦♦ STAFF
47.9k 544 132 521

avatar image Nox_A15 Aug 11 '15 at 08:49 PM

Hello,

Any new info on that? I don't see this bug's number in 4.9 preview. I currently finish my work on a save/load system which works perfectly fine in the editor and doesn't work in a packaged project due to this issue. I plan to submit my work to Marketplace, that's why it's so important to me.

https://forums.unrealengine.com/showthread.php?75808-BP-Save-Load-and-Game-Progression-System

avatar image Institute Games Jan 02 '19 at 09:06 PM

Rudy, this is still occurring even in UE4.21, in my case a pre-existing actor blueprint in my level is firing it's Begin Play ahead of my GameModeBP Begin Play on Windows, but on iOS GameModeBP's Begin Play comes first, this breaks one of my Bind Events so that it never gets fired correctly, as it hasn't been bound when I have called the dispatcher in my GameMode's Begin Play. Is there another way to Bind dispatcher events without using Begin Play? Possibly something earlier?

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question