x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't get OpenLevel to work

Hello all

A newbee posting his first question so please be gentle :)

I'm following the UMG UI Designer Quick Start Guide, but having trouble getting OpenLevel to work.

I have a main menu (widget) with an option to start a new game. In the EventGraph, I have this:

alt text

The problem is that the level won't open!

In the Output Log, I've got this two warnings:

LogActor:Warning: GameSession /Game/FirstPersonBP/Maps/WEDPIE_0_FirstPersonExampleMap.FirstPersionExampleMap:PersistentLevel.GameSession_19 has natively added scene component(s), but none of them were set as the actor's RootCoponent - picking one arbitrarily

and

LogActor:Warning: GameNetworkManager /Game/FirstPersonBP/Maps/WEDPIE_0_FirstPersonExampleMap.FirstPersonExampleMap:PersistentLevel.GameNetworkManager_19 has natively added scene component(s), but none of them were set as the actor's RootComponent - picking one arbitrarily

I suspect these warnings has something to do with why OpenLeven won't work, but what do the actually mean and how to I solve it?

Product Version: UE 4.8
Tags:
openlevelpng.png (46.3 kB)
more ▼

asked Jun 21 '15 at 08:29 AM in Using UE4

avatar image

kjelle392
16 1 1 2

avatar image thankstipscom Jun 21 '15 at 12:13 PM

don't have much time to reply right now but first I'd say start the game.. on any other map, then press ~ and type open mapname (the map you think is giving you problems)

also in your charBP, create an input and wire it to open map. Then go to a map and press that button and see if the map loads there, if it opens ok there, then there probably isn't an issue with your map.

avatar image gaetandelorme Aug 31 '15 at 09:05 PM

Do you still have the issue? I guess mine is close to yours : https://answers.unrealengine.com/questions/245709/cant-get-openlevel-to-work.html

avatar image KnightTechDev Sep 13 '15 at 01:48 PM

I had the same problem, I created a new Maps folder in the Content folder and dragged all my maps into that folder to re-organize things a bit, I had different maps for basic logo display and game menu option sequences with UMG widgets, and the maps/levels would open fine in the editor when played, but would not open in the mobile version because it wasn't finding the maps by name, using the console commands wouldn't work to manually open the maps/levels either, the fix was to place all maps directly into the Content folder only, and then it works.

You may also need to fix your paths in the DefaultEditor.ini and perform the adb logcat check for Android as is discussed here: https://answers.unrealengine.com/questions/216451/help-open-level-blueprint-not-working-on-mobile.html

Another issue that comes up is if you Launch to Android and have a map other than your first one loaded before launching, the map loaded to your Android device will be the map currently loaded in the editor, so if you wanted to load for instance UE4Logo and had your Level1 loaded, it will be on Level1 already bypassing the UE4Logo if you open the levels in series in a sequence such as by level script, per level script, per map.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question