x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

cannot open source file Blueprint/UserWidget.h

I am gonna go crazy. I did the exact same thing on the tutorial here: https://docs.unrealengine.com/latest/INT/Programming/Tutorials/UMG/2/index.html

it just won't work. It gives the "cannot open source file Blueprint/UserWidget.h" error on the include secdion of MyProjectGameMode.h why is this happening?

Product Version: UE 4.7
Tags:
more ▼

asked Jun 21 '15 at 12:26 PM in C++ Programming

avatar image

Iatsu
80 3 8 102

avatar image Billiam94 Jul 15 '15 at 05:38 AM

I'm having the same issue, have you figured out the problem yet?

avatar image Iatsu Jul 15 '15 at 11:35 PM

view the answer please

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

I figured it out, apparently it was something ridiculous... Just go to your project folder if you are having this issue and then find the ".uproject" file there and right click it. Select "Generate visual studio project files" this will resolve the issue...

more ▼

answered Jul 15 '15 at 11:36 PM

avatar image

Iatsu
80 3 8 102

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Make sure you have UMG as one of your dependencies in your .build.cs file. And don't forget to re generate your project files!

more ▼

answered Jul 15 '15 at 06:35 AM

avatar image

Zaucy
686 15 13 128

avatar image MrCorzell Jul 12 '16 at 11:58 PM

This was the answer for me. Thanks!

avatar image KrillzoX Aug 18 '16 at 06:53 PM

I'm using 4.12 and while this worked at some point in 4.11 for me, now it doesn't.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I use the Engine which version is 4.15.3, and the VS version is 2015.

I can not find the "Generate visual studio project files" option in my .uproject file right click menu.

I try in Unreal Editor, Select File, and click "Refresh Visual Studio project", it work.

Have fun~

more ▼

answered Jul 31 '17 at 03:50 AM

avatar image

Nu11Exception
6 1

avatar image peetaur Nov 19 '17 at 08:09 PM

Same problem and same solution works for Unreal Engine 4.18 and Visual Studio 2017 15.4.3.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question