x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4 freeze after double clicking or editing constant 3 vectors

Hi everyone,

Each time I double click or try to edit a constant 3 vectors in the material editor UE4 freeze and is not responding. It is the same result with both 4.8.0 and 4.7.6. My GPU is updated to the latest driver. Here is my config MSI ghost pro gs60 16 gb ram GeForce gtx 970m i7 5700HQ 2.7 GHZ

Thanx for your help guys

Erwan

Product Version: UE 4.8
Tags:
more ▼

asked Jun 21 '15 at 08:33 PM in Bug Reports

avatar image

waner_garouche
26 1 4 3

avatar image Adam Davis STAFF Jun 21 '15 at 08:56 PM

Hi waner_garouche,

Does this occur in a material with just one constant 3 vector or is it only in a more complex material? What specific steps are you taking that reproduce this on your end?

avatar image waner_garouche Jun 21 '15 at 10:25 PM

Hello Adam, thank you for your answer. I m just trying to follow the material tutorial. The material could not be more basic. I m just trying to assign a color to a material, nothing more. I forgot to say that this freezing occurs also when I try to import an fbx.

avatar image Adam Davis STAFF Jun 22 '15 at 06:30 PM

Do you have "live update" active or are you manually applying updates? Do you see any shaders compiling? Additionally, how long do you wait before shutting down the editor?

avatar image waner_garouche Jun 22 '15 at 11:12 PM

Hello Adam,

Live update is not active. I have made a research but I am very newbee in UE4 and I can t figure out how to see if any shader is compiling... The engine is really freezed and even after waiting 15mn it is still freezed.

avatar image Adam Davis STAFF Jun 23 '15 at 02:40 PM

Does this occur in a clean, blank project with no additional content or is it limited to one project?

avatar image waner_garouche Jun 23 '15 at 04:50 PM

Yes Adam it occurs in a blank project without nothing in it just the table and the two chairs of the template. The only thing I did was trying to add the example scene with vegetation but I never figure out how to visualize it. I hit the button "add to project" but nothing happened. Since I create a new project clean and the freezing problem is the same.

avatar image Adam Davis STAFF Jun 23 '15 at 05:57 PM

Hi waaner_garouche,

I'm attempting to reproduce this on my end but thus far have been unsuccessful. What specific steps are you taking that cause this freeze to occur. Here is what I've done so far, please let me know if you are doing anything else:

  1. Open Editor (any project)

  2. Create new material

  3. Add a Constant 3 Vector by pressing 3 + LMB in event graph

  4. Change the G value to 1

  5. Double click 3 vector node

  6. Plug output pin into base color

  7. Double click 3 vector node

avatar image waner_garouche Jun 23 '15 at 10:34 PM

Hi Adam

I followed the steps. I can change the G value to 1 by editing it into the left window but as soon as I double click the node, everything freezes. The window of the color picker doesn t pop up. It stays stucked in my Windows 8.1 task bar. Maybe it is a problem with windows???

avatar image waner_garouche Jun 23 '15 at 10:49 PM

Something new happened.

It try to follow the material tutorial without double clicking the color picker. But as soon as I add a constant parameter by drag and drop from the right palette I have a runtime Error:

Microsoft Visual C++ Runtime library runtime error! Program: C:\Progr... R6025 pure virtual function call

And then windows shuts down UE4

avatar image Adam Davis STAFF Jun 24 '15 at 02:43 PM

Are you using the binary version of the editor or the github branch? Additionally, which OS are you using?

avatar image waner_garouche Jun 24 '15 at 10:53 PM

Like I said in a previous post I m running windows 8.1. For the binary version or github branch I m not 100% sure. How can I check that? I ve just download the engine from the official site and then install and run it. I ve never mess around with "githud" things, just install and run it.

avatar image Adam Davis STAFF Jun 25 '15 at 10:30 PM

Hi waner_garouche,

Do you get these freezes with any other program or is it limited to UE4?

avatar image waner_garouche Jun 25 '15 at 10:54 PM

Hi Adam,

My computer used to freeze also with google chrome but since I ve made updates it is no more the case. But even after these windows updates, UE4 is still freezing....

avatar image Adam Davis STAFF Jun 26 '15 at 05:12 PM

Have you recently updated your GPU drivers? Additionally, do you have the editor and swarm agent set up as exceptions in your firewall?

avatar image waner_garouche Jun 26 '15 at 09:11 PM

Yes Adam my GPU is up to date (it's the first thing I've checked). I tried to run UE4 with both my firewall and my antivirus disabled but the result is always the same UE4 is still freeeeeeezing!

avatar image Adam Davis STAFF Jun 26 '15 at 09:45 PM

Try verifying your engine. I still haven't been able to reproduce this on my end. If you go to your launcher>library and click the dropdown context menu next to your engine then press "verify", it will check your engine folders for any missing/damaged files and repair/replace them. Additionally, can you post a copy of your full dxdiag here so I can take a look? Thank you!

avatar image waner_garouche Jun 27 '15 at 04:14 PM

Hello Adam, Always the same even after verifying the engine. Here is my dxdiag link text

dxdiag.txt (81.2 kB)
avatar image Adam Davis STAFF Jun 28 '15 at 01:40 PM

Can you send me an asset that is experiencing this behavior? I don't see anything in your dxdiag that would cause this to my knowledge. It is possible that the laptop is trying to use your Intel Integrated HD instead of the Nvidia, but that is not likely.

avatar image waner_garouche Jun 28 '15 at 03:11 PM

Hello Adam, I could send you an asset but I'm quite sure my problem have nothing to do with that because it occurs also when I create a brand new material... Is there a way to check if the engine is using the integrated HD instead of the Nvidia?

avatar image waner_garouche Jun 28 '15 at 03:43 PM

After all my google chrome is still freezing too...

avatar image Adam Davis STAFF Jun 28 '15 at 04:47 PM

If you open your Nvidia control panel>3D Settings>Manage 3D Settings>Global Settings tab, there should be an option for Preferred Graphics Processor Select. Open that context menu and select the Nvidia card and apply the changes there. If this does not work you may have to set some individual settings for UE4 in particular, but I don't know yet if that will be required.

avatar image waner_garouche Jun 28 '15 at 05:20 PM

I've changed the Nvidia settings so the graphic card is the one prefered but my engine is still freezing.

avatar image waner_garouche Jun 28 '15 at 05:23 PM

My C drive is pretty full. 2.58gb free on 118gb. Do you think this could be the reason of the freezing?

avatar image Adam Davis STAFF Jun 28 '15 at 05:46 PM

it is definitely possible, though not likely. The intermediate data folder saves shader compilation data, which can be bulky. If the folder has a lot of data in it it may be having difficulty adding additional information. Tomorrow our rendering team members will be in and I'm going to talk to them about what other possibilities there could be in regards to this error.

avatar image waner_garouche Jun 28 '15 at 09:08 PM

Again, trying to foolow the simple material tutorial I have this Runtime error (see the attached jpg file)![alt text][1]

This occurs just selecting a constant vector. Very fustrating. I just can't wait to begin pratcticing on the engine.... [1]: /storage/temp/48257-ue4+crash.jpg

ue4 crash.jpg (451.3 kB)
avatar image waner_garouche Jun 28 '15 at 09:46 PM

I have my engine freezing also when I try to import a simple Max Teapot fbx file. The problem seams to be the same as the material one because I have a pop up window stuck into my task bar and I cannot open it (this time a fbx import option window and for the material problem a color picker window) See the jpg attached.alt text

ue4 crash 2.jpg (353.9 kB)
avatar image Lovecraft_K ♦♦ STAFF Jun 29 '15 at 09:46 PM

Hi waner -

From the conversation that you and Adam have had it sounds like there is an issue with some of your Visual C++ Redistributables. First thing I would ask you to try is running Windows Update and make sure that there is no available updates. If there is download and restart you computer as necessary until you have no updates. Then Open the Launcher and Re-Verify the Engine Download.

If after you do both of those things you are still having an issue, then just after reproducing the freeze and I am assuming after you either crash a runtime as above or have to CTRL-ALT-DELETE out of the engine, open Windows Event Viewer and save out the last few errors and criticals messages generated by your PC (you can see Microsoft's website for the instructions for Windows Event Viewer.) Once you have saved out those files, zip them up and post them here so we can take a look.

From your descriptions above though I would imagine that updating those redistributables will fix the issue.

Thank You

Eric Ketchum

avatar image waner_garouche Jun 30 '15 at 12:50 AM

Hi Eric, I 've made the maximum of c++ updates i could do. Some of them couldn't install because it said that visual studio need to be install on my system to run these updates. Do I need Visual Studio to run the engine? After that I restarted my OS and then verify the engine before running it. Finaly I started the engine and I still have the same problem. I made a little research on how to use winows envent viewer. I started it after my freezing. I'm not 100% sure to have done what you asked me to do because all of these is a little bit chinese for me... I opened some of the errors (I could not find one with the same time the freeze happened) and I copy pasted it to a text file. Then I ziped the files as you told me.link text

avatar image Lovecraft_K ♦♦ STAFF Jun 30 '15 at 02:50 PM

Can you check your version numbers with the ones in the picture below:

Redist

Thank You

Eric Ketchum

redist.jpg (301.0 kB)
avatar image waner_garouche Jun 30 '15 at 05:30 PM

Hi Eric, I've made a prinscreen of my installed visual C++. It's not the same as your list but most of those which are missing are x86 and when I tried to install it the installer told me it was not compatible with my OS (since I'm running in 64 bits). I see that you have Visual Studio Professional 2013 installed on your system whitch is not the case for me. Do I need to install it to run the engine? Thanksalt text

c++ installed.jpg (473.8 kB)
avatar image Lovecraft_K ♦♦ STAFF Jun 30 '15 at 11:22 PM

HI Warner -

You should not need to have Visual Studio Installed but the runtime error you are getting has to be associated with an error in the Redistributables or the dotNET Framework. Take a look at this Microsoft Answer article and see if you can follow it to a solution,

http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/runtime-error-p6025-pure-virtual-function-call-on/89e10d2f-b949-e011-8dfc-68b599b31bf5?auth=1

avatar image waner_garouche Jul 20 '15 at 10:32 PM

Hi Eric,

Sorry for the long time... I followed step by step the instructions of the link you gave me but the problem is still the same with my engine. The article talk about "Microsoft .NET framework 3.5.1" but in my system it is written "3.5" not "3.5.1". Do you think this could be a problem?

Thank you Eric

avatar image Lovecraft_K ♦♦ STAFF Jul 21 '15 at 02:38 PM

Hi waner_garouche -

Not a problem. NET Framework from Microsoft is running on version 4.5.1. Try downloading this latest version which can be found here:

https://www.microsoft.com/en-us/download/details.aspx?id=40773

and see if your problem clears up. If not feel free to comeback and comment here.

Thank You

Eric Ketchum

avatar image waner_garouche Jul 21 '15 at 03:34 PM

Hi Eric It says that it is already installed in my system....

avatar image Lovecraft_K ♦♦ STAFF Jul 21 '15 at 07:31 PM

Hi -

Are you using ReadyBoost on your CPU while trying to use the engine?

Thank You

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Alleluia!

I fixed my problem thanks to GTA V. I hadd trouble running this game and after a research on the web I figured out that I had to exit some of MSI graphics softwares optimisation that were running. After closing all this stuff my game was running without problem (before it was crashing all the time). Then I tried my UE4 engine and.....boom! Everthing is now running nice and clean. Hope this will help someone else!

Cheers

more ▼

answered Aug 12 '15 at 05:09 AM

avatar image

waner_garouche
26 1 4 3

avatar image AarunJon Aug 18 '15 at 07:19 PM

Hey waner_garouche, I've also got a similar problem with my MSI! I've opened it up as a question hoping to find a solution, but could you tell me what MSI graphics optimization softwares you're referring to? It may just fix my problem too!

Thanks.

avatar image waner_garouche Aug 19 '15 at 11:29 PM

Hi AarunJon,

I could not determine what was the cause of the bug but if you close all apps running in the right side of your task bar it should work.

Hope this will help you

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question