x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Why are my animations incorrect outside the preview window?

I'm having a strange issue with animations not showing up correctly.

I have a relatively terrible walk animation I've created in the Persona editor that shows up correctly when previewed: http://gfycat.com/ShockedBetterJabiru

When I view it in the Animation Montage editor, or the Animation Blueprint editor, however, it shows up like this: http://gfycat.com/RemoteWarmheartedDarwinsfox

This seems to happen with every animation I create from the animation editor; why would this be happening?

My animation is only 4 frames long and is running at 0.1 rate, but the same result happens with a rate of 1.

Product Version: UE 4.8
Tags:
more ▼

asked Jun 22 '15 at 06:16 AM in Bug Reports

avatar image

Lucien Greathouse
1 1 4

avatar image Lucien Greathouse Jun 22 '15 at 06:41 AM

I tried exporting and importing the animation as a new asset and it caused a crash, which I've reported through the crash reporting tool. Fantastic!

avatar image Lucien Greathouse Jun 22 '15 at 06:53 AM

After successfully reimporting the animation, the skeletal mesh is now tiny and showing the incorrect animation in the animation preview as well: http://gfycat.com/DismalLivelyFly

avatar image Lucien Greathouse Jun 22 '15 at 06:57 AM

I imported the skeletal mesh + animation exported from UE4 into Blender and it produced a terrible abomination? http://i.imgur.com/O8e0inM.png

It also has the same corrupt animation data.

avatar image Matt.Williams Jun 23 '15 at 10:25 PM

Hi Lucien,

Any chance I can get a copy of the original fbx that you imported into the engine?

-Matt W.

avatar image Lucien Greathouse Jun 27 '15 at 04:06 AM

Are there any updates to the issue? I assume it's an error on my end, but some users in the Unreal Engine IRC on Freenode had hinting that the UE4 animation creator/editor was still not production-ready.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Lucien,

I have an email out to our devs to see if they know what's wrong with this fbx. It appears to have some issues that I don't have the Blender knowledge to advise you on.

The Additive Layer Tracks in the editor are really meant to add a new layer of motion to an existing animation. It is not meant for creating animation from scratch like you're attempting to do. It is (and I hesitate to say this) "possible", but it is lacking many of the useful animation tools that your 3D modeling software of choice provides to you. I wouldn't say that it's not production-ready though as it is not intended for animating characters from scratch. I would highly recommend animating in Blender and importing those into the engine.

On another note, Blender's FBX importer doesn't always agree with the FBX files that come from the editor. We are working with them to resolve some of these issues, but that's an ongoing process.

-Matt W.

EDIT: Concerning the character scale issues, I haven't been able to reproduce that. If you'd like to continue trying to work this way, we can take a closer look at your UE4 Project.

more ▼

answered Jul 02 '15 at 06:25 PM

avatar image Lucien Greathouse Jul 02 '15 at 06:27 PM

Thanks for looking into that, I changed my workflow after reporting the issue to build the animations in Blender instead, which has worked out pretty well.

avatar image Matt.Williams Jul 02 '15 at 06:32 PM

That's great! Have you had any of those scale issues since implementing the new workflow?

avatar image Lucien Greathouse Jul 02 '15 at 06:35 PM

Nope! Once I got my units set to centimeters in all my tooling and got export working correctly it all worked fine. I had some interesting issues with the forward vector being incorrect in the animation preview, but I imagine that's also a tooling issue on my end.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question