Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Certain BP class properties keep losing value

Since the 4.8 update I noticed that certain properties of certain BP classes placed on the map lose data from time to time. Here is the details panel of such an actor:

alt text

The Transform and Items categories are fine but General and Drone get reset occasionally. (Enemy Waves is unused currently so I'm not sure if it's affected.) Interestingly I don't seem to recall a category partially losing data: it's always all the properties on those two groups and only those groups.
I tried to reproduce the issue but couldn't. I tried the following:

  • Modify BP class slightly to force a recompile.

  • Modify parent class to force a recompile.

  • Force recompile any of the referenced BP classes.

  • Save the map and restart the editor.

I think I always noticed this data loss right after starting the editor in the morning. I'm on binary 4.8 and I do not have versioning, all files are writable.

Product Version: UE 4.8
more ▼

asked Jun 22 '15 at 08:46 AM in Bug Reports

avatar image

1.6k 80 94 146

avatar image Adam Davis STAFF Jun 22 '15 at 06:33 PM

Hi ZoltanE,

Does this happen with any blueprint or is it limited to specific blueprints/types of blueprints?

avatar image ZoltanE Jun 22 '15 at 06:45 PM

So far I've only noticed it in one particular BP class which is game logic critical so it was obvious that something went wrong. I don't know if others are affected so I'm going to place all currently unused classes on the map too and see what happens to them.

avatar image Adam Davis STAFF Jun 28 '15 at 01:49 PM

Hi ZoltanE,

Have you found any additional information on whether it was limited to the one class or if any other classes have been affected? Thus far I have not been able to reproduce this on my end. Do you get any errors when this occurs?

avatar image ZoltanE Jun 28 '15 at 02:02 PM

I keep a locked details panel open on the second monitor but couldn't yet catch the reset happening.

avatar image Adam Davis STAFF Jun 28 '15 at 03:06 PM

I'll leave this thread open for a few more days just in case it does occur again. If it does, please list the steps that you took to recreate this and I'll be happy to try to reproduce it on my end.

avatar image Adam Davis STAFF Jul 02 '15 at 05:32 PM

Hi ZoltanE,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If this occurs again please comment here with additional information on how to reproduce the error.

avatar image ZoltanE Jul 10 '15 at 08:59 AM

It happened again in the last 4 hours, but I don't know exactly when, I was focusing on other things. It really slows down work when I check the placed actors after each BP change.

That approach haven't helped me so far either so I was wondering if there is a mechanics inside the editor which would instantly alert me if a particular actor's given property changed (not in-game)? Some kind of a plugin or blutility thing or I don't know. Something to help me narrow down the repro steps from "working on the project for a few hours".

avatar image Adam Davis STAFF Jul 10 '15 at 05:50 PM

Unfortunately I don't know of any at this time. What were you focusing on and what changes did you make before you noticed this occur? Were you updating a parent class of the actor?

avatar image ZoltanE Jul 10 '15 at 06:37 PM

I was working on the following things:
- Minor update to the player pawn base class.
- Modification of a BP struct used in both the pawn and the engine actors. Changing it set half a dozen blueprints dirty, those needed recompile.
- Extensive editing of an engine class. ("Engine type" in the screenshot above.)

I did not touch the class displaying the problem.

When I saw the lost properties I went through the obvious steps: changed the pawn class, changed the BP struct, changed the engine base class, changed the engine child class. I checked the placed actors for data loss between each step, no bug...

One thing tho: My persistent level gets dirty every time I quit a PIE session. I'm not sure if it means anything, it's been like that since forever. It's just interesting and now I'm really grasping at straws.

avatar image Adam Davis STAFF Jul 13 '15 at 05:05 PM

In the struct, do you have any references to actors in your project? For example, do you have a variable for an actor blueprint in your struct? If so, has this recently been moved in your content browser?

avatar image ZoltanE Jul 14 '15 at 09:20 AM

The struct only contains a few floats, no actor derived blueprint references.
Two of the resetting properties are for storing a reference to a class which should be spawned at runtime. However those classes have not been moved/renamed in the past 6 months.

avatar image Adam Davis STAFF Jul 14 '15 at 06:48 PM

Unfortunately I haven't been able to reproduce this on my end at all. Do you have a test project this occurs in that I'd be able to take a look at?

avatar image ZoltanE Jul 14 '15 at 07:30 PM

As soon as I figure out how to repro this I'll post the steps and the project. In the meantime I guess I'll just store the fully set up actors in a text file to replace the existing ones when they reset.

avatar image skeleton60 Oct 22 '15 at 12:47 PM

Hey i suffer from this bug too... problem is that i had 20 maps, with many blueprints and properties manually edited in them.... and sometimes.... somes properties reset.... 1 week of work lost (or more) so i wont redo all my map again till this bug is fixed...

I feel so bad right now :( but quite happy that is a know bug now...

avatar image HyperBolo Feb 22 '16 at 07:57 PM

I have this bug too and i'm on 4.10.4

It's a shame this hasn't been fixed yet since it's a bug that makes the map editor useless

avatar image Adam Davis STAFF Feb 22 '16 at 08:54 PM

Hi HyperBolo,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?

  • What steps can I take to reproduce this error on my end?

avatar image MiniTurtle May 19 '16 at 03:21 PM

I still have this bug in 4.11.2

Scratch that fix, didn't work for long... weird

 I managed a temp fix
 In Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectGlobals.cpp line 2708
     UObject* ClassDefaults = bCopyTransientsFromClassDefaults ? DefaultsClass->GetDefaultObject() : NULL;
 Change to
     UObject* ClassDefaults = DefaultsClass->GetDefaultObject();

Unreal seems to think that the variable is transient even when it's not.

In this line of code (2724) ClassDefaults is NULL causing the variable i.e. float to be set to 0.0

 P->CopyCompleteValue_InContainer(Obj, ClassDefaults);

Well my fix works for me, but I would be cautious to implement it in other projects (not to break anything).

P.S. My variable that keeps being zeroed is ACharacter(UE4 Class) -> C++CustomCharClass -> BlueprintChar -> float

avatar image Higuy8000 Oct 01 '16 at 07:34 PM

Just had this issue happen again today in a very large level after having it not happen for a couple of months. Every single puzzle element in this level now needs to be recreated. It happened after saving everything, closing the editor, putting the computer to sleep and coming back after a few hours and opening it back up.

Seriously, this is a very important issue, and I assume that it's hard to fix, otherwise it'd be fixed by now. But really, can we at least get some sort of status update on it? It feels obvious to me and a lot of other people that this issue is affecting quite a lot of projects and is becoming a major roadblock in trying to polish pretty much anything.

avatar image Marcio Daniel Oct 03 '16 at 03:42 AM

It happened again here too...

This is very serious. A hotfix on 4.12 already fixed an error related to data on components, and now this...

I never seen a mesh disappear on 3dx max, or a layer disappear on Photoshop, or a function disappear on Visual Studio... but it's the second time I see data disappearing on Unreal Engine. I really don't know why, but for me is clear that the storage system is not good, it appears to be messy... I mean, for me, it's completely unreliable.

(And I insist that it doesn't happen when the editor is closed or opened. The cause happens while you are using, but the data are still in memory, so you only see when you restart the editor. See my answer below.)

avatar image Higuy8000 Oct 03 '16 at 01:44 PM

Ditto. Yesterday while I was working on my project I noticed the same issue of memory loss WHILE working inside it. I had my project open, was working on something completely unrelated to these classes, and everything was working fine in the editor. As soon as I tried opening a standalone game version, the issue was quite apparent that memory had been loss with the classes, and that could only be seen in the editor once it had been restarted. This is really ridiculous. I am not sure if putting these classes into C++ would fix the issues or not, but if it is proven to then I'm willing to go ahead and do so for the integrity of my project, but I'm hesitant considering the amount of work and unsure if it'll even fix the issue.

ZoltanE's solution where you include the parent classes in the level worked for about 2 months until about 2 days ago.

avatar image Adam Davis STAFF Oct 03 '16 at 02:10 PM

Hi Marcio and Higuy8000,

  • Do you have any steps I can take to reproduce this error on my end in a clean, blank project with no additional content?

  • Can you describe specifically what is occurring?

  • Do you have any circular dependencies within your project that could be overwriting your content?

avatar image Marcio Daniel Oct 03 '16 at 02:23 PM

Hi, Adam. 1 - We don't have the steps to reproduce. I tried many times to find these steps, but I couldn't.

2 - Please se my answer below, there is a link to a video.

3 - I don't think so. What kind of circular dependencies? Memory references? Class hierarchy? Can you give us an example?

avatar image Higuy8000 Oct 03 '16 at 02:26 PM

Hi Adam,

I'm not sure about exact repro steps, since it seems to occur randomly, but heres it how it usually happens for me:

  1. Open up a new or exisiting project.

  2. Create a Actor Blueprint

  3. Add some sort of variables to it - booleans, ints, etc.

  4. Create a child of this blueprint.

  5. In the child, add more variables, such as booleans, floats, ints, and references to other actors.

  6. Create a child of that blueprint, and place instances of it in the level.

  7. Using the detaisl panel, fill in the variables with whatever you want, as long as it is not the default values.

  8. Close editor, reopen

  9. Notice the values of variables that are contained in the first child (child of class created in step 2) of the instances all get reset to their default values.

Some notes: I've had the issue happen when the computer is shutdown and restarted, put to sleep (without editor open), while the editor is open (issue can be seen in standalone version of game, but not inside regular editor), and also just restarting the editor. It's not consistent either, but the above repro steps is essentially how it occurs - it very much does seem like some sort of child BP / inheritance issue, as I have other blueprints that are not childs (with parent class Actor) and do not have this issue at all. Another interesting note is that the base parent, at least in my class, does not have the values reset, only variables from the first child of that class...

I do not have any circular dependencies that could be overwriting it. I'll also say I've noticed this issue since at least 4.10. I'm currently on 4.12.5 but from what I can gather 4.13 does not resolve the issue either. There is also more repro steps listed by other uses near the bottom of this thread that seem pretty consistent with things I've seen as well.

If you'd like me to upload my entire project for any sort of analysis (through a private message or email) I'd be more than happy to send it to you.

avatar image Cinebeast Oct 05 '16 at 04:55 PM

I too am suffering from this issue, and on 4.13. The only workaround I can see is to set all the relevant variables on Begin Play in the level blueprint, but that doesn't help with static meshes using blueprint components.

avatar image Rapid_Wirehead Oct 07 '16 at 05:22 PM
  • very strange issue,,,, also in 4.13.1 child blueprints values are reseting or even setting to none -- > for skeletal mesh ,, material etc.

avatar image EchelonV Oct 08 '16 at 11:30 PM

Same here, 4.12.5 - started happening today for a reason I do not understand yet.

Things I noticed: It happens for child blueprints of a base blueprint class. Only properties are affected that are inherited. The moment I set these values to "none" in the parent class and specify them in the child instead, they "stick" after a restart. Workaround - but not nice.

These child blueprints are in a folder. I cannot verify this 100%, but it seems to affect the first blueprint in the folder, not the second any other after that. I tested it by renaming them (switching order) and it started affecting the "new" first child blueprint.

It started happening after I cleaned the project up a bit. I have 2 skeletal meshes and pawns I use in game and a base SK mesh and pawn that I had around because it came from a sample project. I cleaned the two base versions up, including the skeleton they had and replaced the now missing references in the animation blueprint with one of the 2 skeletal meshes I actually use. Once I restarted the editor, I noticed that this behavior started

avatar image Marcio Daniel Oct 09 '16 at 12:01 AM

Hi EchelonV.

When you say "The moment I set these values to "none" in the parent class" and "specify them in the child", do you mean the "Class Defaults"?

The folder part is weird. For me, the bug happens with all child blueprints, but each one is in separated folders.

avatar image Marcio Daniel Oct 09 '16 at 01:56 PM

I found that the data is still there when importing. But these data is being exported with wrong property names. For example, instead of "DestroyDistance=50000.000000" (where "DestroyDistance" is the name of the property), the data is being exported as "FloatProperty_1256=50000.000000".

On UnrealType.h, there is a function called "FindField" and this line: "if( It->GetFName() == FieldName )". "GetFName()" returns "DestroyDistance", but "FieldName" is "FloatProperty_1256", so it returns false and the value "50000.000000" is never setted to anything. I tried to find some variable inside the UField class to identify the field as "FloatProperty_1256", but it appears to not exist.

Before that, when exporting, the properties are with the wrong name in the array UStruct::PropertyLink and I didn't found any clue how to get the correct name. So, someone before the exporting is messing around with the property names.

The good news is: I can now repeat the issue anytime.

The bad news is: not in a blank project.

So, Adam, I can give you access to my Github project and pass the steps to reproduce, if you need.

avatar image DaGaffer Oct 09 '16 at 09:29 PM

Great find, Marcio. This issue has been haunting us (we ended up writing a system to store the data outside of the classes). This should lead to a fix.

avatar image CleanCut Nov 10 '16 at 11:30 PM

@AdamDavis Marcio Daniel gave some really good low-level finds in the parent comment. Has that been passed on to the developers?

Sounds like he found the symptom on the reading-in-of-the-data. Now we just have to find what is writing the incorrect FieldName out in the first place, eh?

avatar image polygon Oct 12 '16 at 08:40 AM

I'm experiencing this issue too. But I have to add that the child blueprint doesn't need to be placed in a level to make this strange behaviour happen. It also happens for child classe in the content browser.

For example I have got a custom enumeration that defines the character type (like human, vampire, etc.) in the parent class. In the child classes the variables have to be set individually to create different characters that are based on one parent class. This variable will be reset REGULARLY for no reason. It happens completely randomly without any obvious cause. I did not rename the enum or the variable in the parent class for ages and nevertheless it happens almost daily after closing the editor, shutting down the PC and reopening the project.

It's really hard to build a game if your work gets destroyed in regular intervals and it's simply impossible to check every custom variable every time this happens.

I'm really desperate about this... Please prioritize fixing this bug :(

avatar image Kain Shin Oct 13 '16 at 01:30 PM

I am getting this in 4.13.1 I believe I have a repro. Will test with a clean project if I can find the time.

Here are my repro steps:

  1. Make a UObject class and CreateDefaultSubobject that inside an Actor, such as Character. Have it be instanced. Use DefaultToInstanced if you like

  2. Make another UObject class and CreateDefaultSubobject inside the UObject class you made in step 1. Have it be instanced. Use DefaultToInstanced if you like

  3. Make a EditDefaultsOnly property inside the UObject class in step 2, maybe to an AnimMontage or something

  4. Make a blueprint of that Actor in step 1. Set its property that you created in step 3

  5. Make a child blueprint from the one you made in step 4. Note that it has inherited the property correctly

  6. Save and then Close the editor

  7. Open the editor. The property in the child blueprint from step 5 will be zeroed out

  8. Also note that instances must rely on GetArchetype() to obtain the correct value of that property that was set by a human in data... at least this was the case with ones that came from a dynamically spawned Actor, such as an NPC that came from a spawner

This pattern is specifically the one we use for our StateMachines, which are UObjects that contain embedded UObject states with EditDefaultsOnly properties

avatar image Kain Shin Oct 13 '16 at 04:22 PM

I have attached a minimal repro project here: link text

MyActorArchetype is the base Blueprint class from the C++ MyActor class. That works fine.

Repro Steps:

  1. MyActorArchetype_Child is a Blueprint derived from MyActorArchetype. Note that the FText MyProperty in it is blank.

  2. Set it to defaults, compile the blueprint, and save, then close the editor.


A) When you reopen the editor, that FText field is blank again within the child blueprint. Its inherited value got lost.

B) In addition to loss of values within child blueprints, instances of the parent blueprint class, which is not inherited from any other blueprint, will have uninitialized properties and must rely on GetArchetype() to find the serialized values that were set by humans in data on that archetype.


A) For inherited child properties of an instanced UObject to persist between editor sessions when embedded inside another instanced UObject

B) For properties within instanced UObjects to serialize into every other instance when embedded inside another instanced UObject.

Additional Notes:

i) Property values will not get lost if you set the child archetype's property to something that does not match the parent's.

ii) A workaround solution is to not embed UObjects within UObjects but instead, have the embedded UObject be sub-objects of the outer Actor (maybe outer component, too, but did not test that)

alt text

capture.png (40.3 kB)
avatar image Marcio Daniel Oct 13 '16 at 05:30 PM

I'm not sure if this error and the one from polygon's answer are the same bug we are having. Maybe the cause is the same, but i'm not sure. But it's also very serious.

avatar image Ian_Tetrault Dec 09 '16 at 10:48 PM

To reiterate; "I copy all the logic in the Parent blueprint's construction script. Then, in the child's constriction script, I paste the logic between the "Construction script" node, and the "Parent Construction script" node." That is my fix. Does this defeat the purpose of a child BP? Partially I suppose, but since the issue is only for random cases, maybe its worth the loss of identical logic in Parent and child....

avatar image phil.harlow Dec 15 '16 at 09:54 AM

This issue still occurs in 4.14.1. Holy moly Unreal

avatar image Mootjuh Feb 02 '17 at 04:39 PM

What's worse is apparently they can't reproduce it.

avatar image Marcio Daniel Feb 05 '17 at 01:20 AM

They can reproduce it. They have a sample project and the steps to reproduce.

avatar image GAME3D Mar 10 '17 at 01:18 AM

This happen in every version! And i think, if you cant fix this annoing bug, then pleas let new ppl know about this, so they don't think they doing some thing wrong!

But i think, you really should fix this problem, about it break the system of inheritance (parent/child). If you create a larger game, you end up with loosing a lot of developing time, just about this bug.

I can't say how many time i used to fix all my lost values into a large world, every time i changed some thing into the parent, and some times without change any thing. UE4 is really a great engine ! But such bugs should not exist! Hopefully we will see a bug fix about this, or a usable solution.

Thanks! GAME3D

avatar image shaq_mobile Apr 04 '17 at 04:15 PM

yup, ran into this today. i can create child actors, save, close, and mesh/camera settings are blank.

parent works fine. i can consistently reproduce this with my project. it just started happening though after months of work. :/

avatar image Ridgelon Jul 08 '17 at 03:42 PM

Still happening in 4.15, noticed it happens on any editor crash. I have a respawn actor set in the world, main enemy has respawn area which is set on children in the world. After the crash all children's respawn actors are set to "None".

avatar image SomeDude12 Dec 26 '17 at 09:51 PM

Reporting from UE V4.18.2 Happens every time i restart the editor. I got a widgetBP i set the tool tip widget to some UI i created and works OK. After restarting the editor the option is reset and have to do it all over again. It only resets the specific option on the widget not everything else....

avatar image Sn_a_ke Feb 16 '18 at 08:54 AM

UE 4,18,3 the bug is still present... the way of reproduction is not known to me.

avatar image alleysark Aug 03 '18 at 07:38 AM

4.19, bug still alive.. I think that my case is more difficult to debug. All the UPROPERTY members are fine until I package the game. After packaging the game, UCurveFloat property (EditDefaultsOnly, BlueprintReadOnly, with DisplayName meta spec.) inside CustomHUD blueprint actor becomes Null!

avatar image Xanadron Apr 15 '19 at 03:56 PM

4.20 the bug is still on

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

19 answers: sort voted first

Hi ZoltanE,

I experienced the same issue with various blueprint classes (but with version 4.7.6). All variables that were reseting on startup were inherited from a parent BP. So far, it seems to be fixed for me by placing the parent BPs in the level (they were just only in the content browser before).

Maybe this is also helpful for you!

more ▼

answered Sep 10 '15 at 11:40 AM

avatar image

36 1 7 6

avatar image Adam Davis STAFF Sep 10 '15 at 04:44 PM

Hi mgreg,

Do you have any reproduction steps I can take to reproduce this on my end? If we can nail down some way for me to recreate this I'll be happy to put in a bug report!

avatar image ZoltanE Sep 10 '15 at 04:58 PM

Interesting observation mgreg! In my case the affected properties are inherited from the class' parent's parent. The immediate parent's added properties and other properties from the grandparent stay intact.
I added an instance of both ancestors to the level, we'll see if they fix this.

avatar image mgreg Sep 10 '15 at 05:34 PM

Unfortunately, that didn't solved the problem finally. After a crash of the editor I had to reset all variables. (But simply restarting worked before.) Sorry!

(I didn't restore anything after the crash, just opened before saved map.)

avatar image Adam Davis STAFF Sep 14 '15 at 05:45 PM

Hi everyone,

Has there been any update that may help me to reproduce this on my end?

avatar image ZoltanE Sep 14 '15 at 06:02 PM

I'm currently monitoring a placed instance of the parent class to see if it produces data loss like its child. Stay tuned.

avatar image mgreg Sep 15 '15 at 01:39 PM

Hello Adam,

all I can tell, what I have done in my project, is that I have multiple child-blueprints of some parent blueprint. All are placed as instances in the level and have editable variables (some inherited from parent, some own). The types of these variables range from Integer to other blueprint classes. I set values for these in child and parent (before placing parents in level, only children had values set). The weird thing is, that at some instances some variables are reset to default and on other instances of other children classes they stay as I set them (the same variables).

I don't know, what else I could say about that issue. Maybe I have too much blueprints in my project?

avatar image Adam Davis STAFF Sep 15 '15 at 02:03 PM

Can you send me a sample project this is occurring in? It would be easier for me to see what may be occurring if I had assets to look at. If privacy is a concern you can send them to me in a private message on the forums.

avatar image mgreg Sep 15 '15 at 04:22 PM

Hello Adam,

no problem. I can send you my project. But I don't know how to write a private message in this forum. If I go on your user page, there is no option to do that.

avatar image Adam Davis STAFF Sep 15 '15 at 05:25 PM

If you go to the forums and press "Notifications" in the top right of the screen, then press "send new message" and put the recipient as "Adam Davis". Post a link to an FTP service such as dropbox containing your project and I'll download it from there.

avatar image mgreg Sep 16 '15 at 12:23 PM

Hello Adam, thank you for explaining! My newest obersation is, that all variables stay as I set them. As for now, I don't know which changes I made, that cause the fix. As soon as I can I will upload for you a old revision of the project, where the problem should occur again.

avatar image MistaShoes Apr 06 '16 at 03:38 AM


This bug is still here in 4.11.0. It's really annoying for our game and level designers. Adam, I have been able reproduced the bug in a new project which I'm uploading to my dropbox now with instructions inside the map and blueprint files. I'll PM you in the forums.

For brevity sake: 1. Make a blueprint and add a variable (I used a static mesh and turned it into an array).

  1. Make that variable public.

  2. connect it through a for each to to a print node on either begin play or a key. -> Compile

  3. make a child of this blueprint and put it into the world.

  4. Add array elements to the child variable in the world.

  5. Select static meshes in the world to fill the element slot/s.

  6. play the game. -> when it prints it will show what in the array.

  7. Exit game. Open up parent blueprint.

  8. Change the variable's name. -> compile

  9. Play game

  10. Print -> The child array is empty... :(

I hope this helps. :)

avatar image Adam Davis STAFF Apr 06 '16 at 07:19 PM

Hi MistaShoes,

This seems more related to another bug in our system, UE-22557. Unfortunately I do not have a timeframe of when a fix will be implemented.

avatar image MistaShoes Apr 06 '16 at 11:01 PM

Okay. Thanks Adam.

avatar image elecorn Aug 19 '16 at 05:36 PM

I followed the steps above outlined by MistaShoes and have confirmed that this is still broken in 4.12.5

avatar image phil.harlow Apr 05 '17 at 12:57 PM
avatar image tstex May 23 '16 at 06:00 PM

We are experiencing this as well, and were wondering if there was an update on the time frame for any potential fix?

avatar image paradoc May 28 '16 at 04:15 PM

was this fixed in any 4.11.x updates? i'm considering migrating my project if this bug is resolved. alternatively, does this inheritance error exist in code projects as well? would also consider putting in the time to convert to code if class inheritance doesn't have this problem with persistent code based actors.

avatar image sbounds Jun 21 '16 at 06:24 PM

We're still seeing this in 4.11.2. By far the most annoying bug in the engine right now. :(

avatar image esquire Jul 07 '16 at 04:49 AM

Im getting this in 4.11.2

Could be on restarts but I don't think so. I work on a project each night and usually launch in editor, fire off some guns, test things haven't noticed any breaking on restarting.

However as I add new child blueprint weapons I might go back and adjust for some new functionality in the parent weapon class. Then when I open up one of the older children that has A LOT of information setup, it will be defaulted to the parents values.

This is insanely annoying as I've setup about 8 or 9 guns a dozen times since they keep getting reset if I just plug a new node in somewhere in the parent. Not even like breaking the parent, or redoing huge sections of the parent.

Adjusting the parent BP for some reason is defaulting the children is my best guess.

Any update on this???

avatar image abeccu Sep 14 '16 at 11:42 AM

This is happening on my project as well. There are dozens of blueprints that switch to default parameters. I worked around some of it by overriding the parameters with literal values on BeginPlay, but that doesn't help at all for blueprints that are either never spawned or come into play via c++. Also it's a mess.

My problem does not involve any blueprint actors placed in levels. Everything is spawned at runtime, It may involve creating a new child of a parent, which then triggers some of the other children of it losing their values, though that is speculation at this point.

As our game is very content driven and it'll only get worse as the number of blueprints continues to mount, it'd be great to have an update here.


This is with version 4.13

avatar image Mootjuh Oct 13 '16 at 05:51 AM

I too still have this issue occuring in 4.13.1

avatar image Grant Margison Nov 03 '16 at 12:15 PM

How is this even marked as resolved?

I shut the editor down last night after playing with AI. I also remember doing a few changes to one of the events on the weapons. Opened it up again this morning and all the children of the base class weapons have lost their data!

The weapons have all gone back to the values as set in there parent class, which is nothing.

The more weapons I have the more I have to toil to fix this. Am I expected to set every variable for every class every time the editor restarts? How does somebody even complete a game using this engine?

There was a comment I read ages ago about how somebody had to spend a good portion of time fixing things whenever they started the editor. I'm now in the same boat.

This original question is from 22 June 2015 - It's now 03 November 2016 and this hasn't been fixed.......... Come on Epic!

avatar image Marcio Daniel Nov 03 '16 at 09:32 PM

I don't know why this is marked as solved too. But at least the issue is tracked now, you can upvote here: https://issues.unrealengine.com/issue/UE-37428 and follow my tips below to avoid the issue while it's not fixed.

avatar image CleanCut Nov 10 '16 at 11:05 PM

This should not be marked resolved. This is driving me crazy in 4.13.2. I keep losing all of the configuration of blocks within my knock-down-the-blocks levels. I have repeatedly had to reconfigure all the blocks in my levels for no reason! GRRRR.

Marcio's workaround steps have worked for me so far. Compiling a blueprint that has configured instances in the currently-open level is dangerous! My simplified workaround (based on Marcio's info below) is 1) Save level before working on blueprints, 2) After working on blueprints, restart engine without saving level.

Prototyping productivity is really crappy now, what with the need to shut down and restart the editor between every blueprint change.

I voted for UE-37428. I'm sad the target fix is 4.15. That's a long ways away. Seems like blatant data-loss would be hotfix-worthy.

avatar image Marcio Daniel Dec 09 '16 at 07:39 PM

Epic changed the issue's "target fix" to 4.16...

I really think Epic is underestimating the severity of this issue.

avatar image CleanCut Dec 09 '16 at 08:31 PM

Aaargh! Clearly.

avatar image jinyuliao Feb 06 '17 at 12:17 PM

This issue still occurs in 4.15 preview3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Here is the link for this issue on Unreal Engine Issues, so you can keep tracking:


(You may be confused because the issue's name says "duplicating", but don't worry, it's just one of the ways this bug appears. It's exactly the same issue that resets the properties when you reopen the editor.)

more ▼

answered Oct 17 '16 at 09:41 PM

avatar image

Marcio Daniel
515 16 33 100

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This issue is still occurring in 4.12.5. I see UE-22557 in but I don't think its accurate - I haven't renamed any variables and still get all variables reset in certain child classes.

I have the same issue as ZoltanE, I usually notice it right when the level is reloaded or the engine reloads (from just regular startup or after a crash). Sometimes they stay perfectly fine, but they usually reset at least once a day, if not more. I have a child blueprint (and its parent also has a parent to a higher level class). Things that get reset range from arrays full of world actors to simply just checked or unchecked booleans.

I'm tempted to try and recreate my parent classes in C++ at this point but it'd be a lot of work considering how much code I have in them and I'm not even sure if that'd fix the issue at this point.

I would be more then happy to upload my entire project (its quite large though) so someone can get a better idea of what is happening. This issue really needs to be fixed IMO, just from this thread it seems like many peoples projects are crippled because of it and I can say myself it will be very hard going forward without having a solution to this issue.

more ▼

answered Aug 10 '16 at 08:57 PM

avatar image

183 11 12 28

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

HI everyone,

I was able to reproduce this and have entered a bug report, UE-21201, to be assessed by the development staff. The error is specifically for inherited values that are set to default values and cannot be edited in 4.9, however I am currently working on several bug reports of values resetting in packaged and launched projects that may be tied to this as well.

more ▼

answered Sep 17 '15 at 07:27 PM

avatar image CraveClone Oct 13 '15 at 01:04 AM

Hi there,

Any updates on a fix for this? I believe I am suffering from the same issue.

BP child class objects that have been placed in a level are getting a subset of their editable variables reset to the parent class defaults, seemingly at random. I usually notice it after opening a level in editor.

It has been plaguing me for a while, so any advice or updates would be a huge help.


avatar image Adam Davis STAFF Oct 13 '15 at 01:42 PM

Try this in 4.9.2, there was a fix for another bug report, UE-20258, which this bug report ended up being a duplicate of.

avatar image skeleton60 Oct 21 '15 at 02:38 PM

its not fixed on 4.9.2 i suffer from this. this a huge bug, i had 20 maps with many blueprint with property manually edited and.... here we go the random propertie reset BOOM

so many hours of work lost

avatar image Adam Davis STAFF Oct 21 '15 at 03:25 PM
  • What specific properties were reset?

  • What steps can I take to reproduce this on my end?

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?

  • Was this project from a previous engine version, such as 4.8, or was it created in 4.9?

  • Do you have any circular references in your blueprints that are experiencing this error?

avatar image skeleton60 Oct 22 '15 at 12:33 AM

-Properties concerned: an array of vector, a boolean, an enum, a reference to an actor.

-Step to reproduce: i dont have exact step but i didnt suffer from this bug before i reworked the code. was working fine when it was simple blueprint based on actor. i reparented most of my blueprint to have parent and made them to be child. Since i did this, i have now some childs properties (and always the same properties seem to be impacted) are reset when i restart editor

-Project information: limited to this project as i use parent&child for the first time

-Project created in 4.8 if i remember

  • think i dont have circular references (circular reference mean that i have a reference of my child in my parent and a reference of my parent in my child?)

as usual sorry to not have steps to reproduce this, but for sure it happened when i rearranged my code to parent&child

i will try to make a blank project with parent&child bp, and then try to see if i can reproduce the bug and send you this project

avatar image skeleton60 Oct 23 '15 at 11:26 AM

Ok i found why it does reset for me

i often do change in my blueprint parent, doing some cleaning, some renaming, and here we go... renaming a variable in parent reset the property of childs placed in level

is that normal behavior?

tell me this is a bug, because i love to rename and clean my blueprints :P

avatar image Adam Davis STAFF Oct 23 '15 at 03:58 PM

Hi skeleton60, I was able to reproduce this on my end and have entered a bug report, UE-22557, to be assessed by the development staff.

avatar image ZoltanE Nov 13 '15 at 11:40 AM

I've just lost data again in 4.10. Any new info why this happens and how to avoid it?

avatar image ZoltanE Dec 04 '15 at 06:43 AM

The solution I proposed earlier, to copy-paste affected actors to a text file for safe keeping, does not actually help: it seems that if they are broken under the hood then they will be copied as such even if everything looks okay from the outside (editor UI, PIE). I was happily producing backups for a while then realized that they contained the same broken actors as the map.
I'm looking at two dozen actors, fundamental to the project, and no way to keep their data safe so I'd really appreciate any ideas for a backup solution.

avatar image ColdIronZinc Dec 17 '15 at 05:30 PM

Any update on this?

My team is also running into this (or an extremely similar) issue in 4.10.1.

At first it was relegated to our Character classes - a class in the middle of the inheritance chain would randomly stop referring to its skeletal mesh and reset it to that of it's grandparent. We also saw some resetting of the collision capsule component's values. After deleting ALL of our child classes and rebuilding them from scratch - the issue still remained. To work around, we've "hacked" the values to be set at runtime in the "BeginPlay" event.

Last night another Actor class chain (our weapons) started exhibiting the same issue - child class data randomly being reset to parent or grand-parent values. We're losing valuable development time, and a bit of confidence.

Would love to help debug this in any way we can.

avatar image Adam Davis STAFF Dec 17 '15 at 05:47 PM

Hi ColdIronZinc,

This bug is still under assessment by the development staff. Unfortunately, I do not have a timeframe of when a fix will be made available.

avatar image ColdIronZinc Dec 17 '15 at 06:47 PM

Thanks Adam - please let me know if there's anything my team can do to help find this issue.

avatar image Spoondog Mar 07 '16 at 05:02 AM


Although I don't have much good repro info to add, I thought I'd mention that:

a) This is happening for me in 4.10.3, in my GameMode (just a subclass of GameMode, the variables are not inherited and are a mixture of floats, ints and enums) b) One possible out-of-the-norm thing I did beforehand was cutting and pasting a shared macro from another class into my GameMode (but I haven't been able to narrow that down as a cause). c) Coincidently, this has happened to me a couple of times today, and at the same time, I've also been running into yet another impossible-to-repro bug where the editor will crash if I try to run PIE without compiling and saving changed classes manually (i.e. letting pie auto-recompile). And that problem I think I fixed by getting rid of a new shared macro I had made that had a "Cast to MyGameInstance" node in it. Shared macros have caused me many hours loss in the past (though I thought that was just when using Structs as params) so I wouldn't be surprised if it has something to do with them.

The only other possible helpful thing I can mention is that the project was started in either 4.8 or 4.9. Will update if I have anything more concrete..

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Im on 4.18.3, i have this happening for my weapons occasionally too. Its a pain in a**. It also happens a few times for my AI. The only thing i can see in common with these, are that they're inheriting from a baseclass.

The worst part is, that i've gotten reports from some of my testers, that even on a packaged game, it sometimes happen. This is a serious game breaker, and should not in anyway be marked as solved.

Is it seriously not possible to get someone to escalate this issue and take a deeper look at tracking down the issue? I mean, from all the info in the previous posts, it seem obvious to me, that there's a bug in how properties are reset for objects inheriting from another object, and then it's gotta be a matter of maybe a timing issue or something, that a variable internally is having a wrong state which could trigger the reset.

more ▼

answered Mar 15 '18 at 07:04 AM

avatar image

51 3 7

avatar image ZoltanE Mar 21 '18 at 02:05 PM

Apparently I don't have permission to remove the "solved" state...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Until this issue is not fixed (I am waiting for Adam to give him access to my project), I recommend two precautions to avoid the bug:

  • Never save your map after compile a blueprint which have an instance in the map (even if this blueprint doesn't suffer with the issue).

  • If you are in doubt if you can save the map or not, select an actor which frequently loses it's properties and duplicate it. If the properties are all correctly duplicated, then your map is ok and can be saved; otherwise, close without save and reopen the map.

more ▼

answered Oct 13 '16 at 12:02 AM

avatar image

Marcio Daniel
515 16 33 100

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This is happening again in 4.14

more ▼

answered Dec 23 '16 at 08:54 PM

avatar image

41 2 6 10

avatar image CleanCut Dec 26 '16 at 07:15 PM

Yep. Hasn't been fixed.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I get this now into 4.15, but also had such problems in older versions. This is really anoying, if you loose all values to be replaced with default setup, into all instanced bps. You can loos hours of work with this.

So, is there a solide solution, so Instanced BPs/classes dont get replaced by default?

more ▼

answered Mar 09 '17 at 11:53 PM

avatar image

86 3 5 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi ZoltanE,

We have not heard from you in several days. I am marking this thread as answered for tracking purposes. If you are still experiencing this error, please comment back with the requested information.

more ▼

answered Jul 20 '15 at 03:28 PM

avatar image ZoltanE Jul 31 '15 at 10:08 AM

It seems that most of the time I notice the problem right after loading the project. So the data loss occurs between the end of the last PIE run (which worked fine) in the previous editing session and the start of the editor next time around.

I checked the startup logs for anything suspicious. All the warnings seem to be unrelated, although I'm not sure about these two:

 LogD3D11RHI: InitD3DDevice
 LogUObjectGlobals:Warning: Failed to find object 'Class None.'
 LogUObjectGlobals:Warning: Failed to find object 'Class None.'
 LogLoad: Full Startup: 31.60 seconds (BP compile: 9.38 seconds)

Maybe it's nothing relevant but I thought here I take a note of anything I find.

avatar image ZoltanE Aug 03 '15 at 03:59 PM

I set up realtime backup / file versioning. It seems that during an editor session (for whatever reason) at some point it starts saving the map with the data already lost. The map keeps working (I still see those properties with valid values) right until I restart the editor and the permanent level is loaded back.

avatar image ZoltanE Aug 16 '15 at 11:11 AM

I made a python script which monitors the persistent level's file and searches for the binary representation of the properly set up actor once every 4 seconds. If the hardwired pattern is not found then it alerts me. It often gives false positives but it's still helped me to catch 8 data losses instantly. And the thing occurs very very very randomly.
Last night I thought I found solid repro steps: I was able to make the data loss happen at will 3 times, doing the same thing, modifying and recompiling a BP class. I went to bed, got up next morning ready to send you guys the info. Tried the steps once again, no bug.

Is it at all possible that something outside the editor matters? Something in the OS, background processes, the way the editor is started (directly or through the launcher), hibernation or anything like that?
I know it sounds unlikely but the bug is so unpredictable that I want to leave no stones unturned. Even with the instant notification the best I can say is that it seems I'm always working with 2 important BP's when stuff happens: my pawn and my game state.

avatar image Adam Davis STAFF Aug 17 '15 at 06:40 PM

Hi ZoltanE,

It is possible. Try running a virsu scan (to eliminate the possibility of a virus) and if you could please post your dxdiag here so I can take a look.

avatar image ZoltanE Aug 18 '15 at 06:50 AM

Comodo's virus scan came back negative. (I uninstalled Java and flash some time ago and I'm also monitoring traffic through the firewall but haven't seen anything suspicious in a while.)
Please find the dxdiag results attached. link text The sound card driver is unsigned because the manufacturer haven't produced a Win10 version yet so I had to resort installing an unofficial package. However I was using WHQL drivers back on win 7 when the issues started.

dxdiag.txt (96.6 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Any news on this? This issue is making me lost many hours redoing things. It makes the engine very unreliable for me. Data lost is, in my opinion, one of the worst errors that can happen.

One thing I noticed is that sometimes the issue happens when I duplicate an actor. For example, I have an actor X with a value Y on some property. I alt+drag the actor to create a copy of the actor. The new actor is created, and it is almost perfect, BUT the property doesn't have the value Y. Instead, the property of the new actor is empty (the original actor remains with the value Y).

more ▼

answered Sep 21 '16 at 12:07 AM

avatar image

Marcio Daniel
515 16 33 100

avatar image Calemb Sep 21 '16 at 11:26 AM

Well, I try to reproduce this and cannot. Are You sure that You are duplicate this onto the same level (when You have more than one layers)? However I still have same problem, but cannot create clear reproduction path.... (4.13)

avatar image Marcio Daniel Sep 21 '16 at 02:43 PM

This is the worst part, I don't know how to reproduce the issue. I am duplicating the actor by just dragging some actor in the viewport while the ALT key is being pressed. I am not using more than one layer. When it happens, if I restart the editor, more properties lose it's values.

My conclusion is: the issue doesn't happen when the editor is restarted. It happens before. But we see bigger consequences when the editor is restarted.

I was using 12.5, I changed to 13.0 today. Without any hope...

avatar image EchelonV Oct 09 '16 at 02:01 PM

It's the default pawn of the shooter game template, that I based child pawns on. I did leave the 3rd person mesh and animation BP blank in the properties of that blueprint and only set them in the children. That fixed it for now.

avatar image Marcio Daniel Sep 21 '16 at 04:41 PM

Here are some details about my project that may be relevant. Some were already cited above, other are my assumptions:

  • the issue only happens with blueprints instances which parent class is also a blueprint.

  • the entire category of properties loses the values.

  • it's not always the same category.

  • when the issue happens, all instances in the level of the same class loses the values of the properties.

  • as I said above, I don't think the issue happens when the editor is started. It happens before, while we are doing... stuff. But, when the editor is restarted, is when we see the damage.

  • I am doing a 2D space shooter. It has hundreds of enemies. So, I don't know if it is relevant, but my level has a lot of actor instances.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Epic team, I am a programmer and I know that issues without a proper scenario to repeat are very hard to fix, BUT I think this is a huge issue. I mean, data is being lost and sometimes we don't even see when it happens (when we noticed, can be too late). Maybe someone should take a look and try to find the issue on the code? I would do it by myself, but my knowledge on engine's code is not enough, I don't even know where to start.

I made a video of the issue. Again, I don't know how to repeat. I just noticed it was happening, so I turned on the video capture.


As you can see in the video:

  • I select an actor and it have an "Orders" property filled.

  • I "ALT+click_and_drag" the actor to create a copy. The duplicated actor doesn't have the value on the "Orders" property as it should have.

  • I select the first actor again and it still have the "Orders" property filled.

  • I save and restart the editor.

  • The editor crashes... I don't even know if it is related or not (I think it's not), but anyway... I restart the editor again.

  • I load the same level.

  • Now, all actors are with the "Orders" property without value.

And that's it.

more ▼

answered Sep 24 '16 at 09:44 PM

avatar image

Marcio Daniel
515 16 33 100

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

So I have the same issue, I gues... 4.13.1 How to reproduce7 Eample - I have a child actor with an array of actors. it is puplic array. So I have to set all variables manually. but when i do any changes in the parent blueprint. my manually set variables come to none. I will keep searching the method to set actors befor game starts... but if this will help you to improve the bug...

more ▼

answered Nov 11 '16 at 06:23 PM

avatar image

10 2 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi everyone. I found this problem too on 4.13. It's totaly mess and lost of time. I've discribed it here in contex of location loosing https://answers.unrealengine.com/questions/499077/random-actor-lost-location.html and here https://answers.unrealengine.com/questions/499479/actors-losing-map-location-after-compile-realy-ama.html

Since two months I'm trying to understand this, to make better bug report but with no result. This issue occurs on realy simple basic c++ and BP actors. There's nothing problematic in code. Unreal, please help. This is realy serious problem and my work with this is realy hard if even posible.

more ▼

answered Nov 13 '16 at 04:03 PM

avatar image

Waw K.
70 13 24 33

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Here is my fix that has worked so far in V13, using Blueprints. I am running tests to see if it will stick, but as people have observed, the reset seems to be random.

I have children derived from a base class. The blueprint is a pick up that can have the static mesh and variables changed in the editor, including variables that are sent off to the player's UMG hud, an inventory, and audio.

I copy all the logic in the Parent blueprint's construction script. Then, in the child's constriction script, I paste the logic between the "Construction script" node, and the "Parent Construction script" node. How is that for a confusing sentence? But the fix has worked so far, and I can live with the extra work.

Good luck all!

more ▼

answered Nov 20 '16 at 05:28 PM

avatar image

0 2 3 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

No, didn't work after several restarts. I guess I have to make individual classes for each pickup, until build 4.x. I still love UE4 anyway, its still in dev, keep up the great work! -Ian

more ▼

answered Nov 21 '16 at 12:45 AM

avatar image

0 2 3 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question