x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaged game (debug/development) crashes on startup

Hello,

This is the first time I'm trying to package my game, and it seems like the debug and development configurations build a packaged game that crashes on startup. The logs are attached: Debug/Development, and since I have no other information, a screenshot: ![Error[3].

If there's anything I can do to get more information on this for you, please let me know, and as always, any help is appreciated!

[3]: /storage/temp/47483-error.jpg

Product Version: UE 4.8
Tags:
error.jpg (135.5 kB)
debug.txt (13.3 kB)
development.txt (13.1 kB)
more ▼

asked Jun 23 '15 at 10:23 AM in Bug Reports

avatar image

MkII
143 15 16 27

avatar image wittlief ♦♦ STAFF Jun 23 '15 at 02:43 PM

Hi MkII,

Were you ever able to package your project before? Are you running source or binary/launcher?

This may be a known issue, but I do want you to try one thing before I declare it's the issue (which luckily should make it into a potential hotfix):

In the Engine folder, delete the DDC (Derived Data Cache). In your project, delete the Intermediate, the Saved, and the Binary folders.

When you next try to package it will take considerably longer as the shaders will need to newly compile, but this should get rid of any old or corrupted files that haven't gotten deleted.

Thanks!

avatar image MkII Jun 23 '15 at 08:46 PM

Hi wittlief,

This is the first time I'm packaging my game - I tried briefly in 4.7 but ran into packaging errors so never got to a fully packaged game. In 4.8 these were resolved, allowing me to test the package result.

I will try your suggestion tomorrow and get right back to you. Thanks :)

Edit: Also, I'm running 4.8 off of the launcher download, not compiling from source.

avatar image MkII Jun 24 '15 at 09:55 AM

So I tried as you suggested, and the debuggame and development configurations still exhibit the problem.

avatar image wittlief ♦♦ STAFF Jun 24 '15 at 03:19 PM

Ok, on which device are you testing? Can you get logcat logs for the device? If you can run the app long enough so that it catches the crash a number of times that would be the most help.

Thanks!

avatar image MkII Jun 25 '15 at 10:12 AM

Oh sorry! I didn't mention I'm packaging for Windows 64bit, not Android (logcat is an Android thing, right?)

I'm going to try the new 4.8.1 update, since the release notes mention:

"UE-17087 Assertion failed: !Result || Result->LinkerLoad == Linker crash"

which I think is related to this since that error message is very familiar (it seems it wasn't on the screenshot, maybe I forgot to include the debug symbols with the package?)

I will let you know how it goes. Thanks!

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Good news! It seems 4.8.1 solves my problem. Thank you for your time!

more ▼

answered Jun 25 '15 at 11:37 AM

avatar image

MkII
143 15 16 27

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question