x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android crash/content not installing

Hi.

After transitioning to 4.8 from 4.7.3 we are experiencing a problem with our projects on Android. Apparently there is a problem with proper installation on the device. A project which takes about 500mb in development version on IOS, installs only 122mb of data on Android devices, so it crashes on launch.

I tried both launch button and packaging from editor or command line, then installing. I also tried both compressed and uncompressed versions. What's interesting i created template project, which runs fine, and after installing it has the same size as our project on the device.

Tested on Motorola Moto E 2nd gen, Acer Iconia Tab 8 and Nexus 7, everywhere the same result.

I'm attaching crash logs for both compressed and uncompressed versions. They are mostly similar, but compressed version shows some interesting lines about corrupt assets, which seems relevant.

Any help would be appreciated.

Product Version: UE 4.8
Tags:
more ▼

asked Jun 23 '15 at 03:11 PM in Bug Reports

avatar image

Zimo
56 5 9 11

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Zimo,

In your logs I'm seeing references to two different (but possibly related) issues. Luckily they are both known and reported, and I'm going to include both here for reference in case you're actually seeing both, they are UE-17532 and UE-16970. I will update this thread when I have more information regarding either issue.

Good luck!

more ▼

answered Jun 23 '15 at 06:09 PM

avatar image Zimo Jul 15 '15 at 03:07 PM

Hi.

Any update on those issues? The problem persists in 4.8.2.

avatar image wittlief ♦♦ STAFF Jul 15 '15 at 03:19 PM

Hi Zimo,

UE-16970 was included in the 4.8.2 hotfix, so we can at least exclude that from the issues you're seeing. UE-17532 unfortunately was not. Can you include a new set of crash logs from the engine update?

avatar image Zimo Jul 16 '15 at 02:48 PM

Including a log from Nexus 6. Size of the build is the same as before, so it looks like there is no content.

log.txt (51.5 kB)
avatar image wittlief ♦♦ STAFF Jul 20 '15 at 05:36 PM

Hi Zimo,

It looks like the crash is occurring at this point:

D/UE4 (18718): [2015.07.16-14.36.10:141][ 0]LogTemp:Display: AndroidAdvert::InitializeInterstitialAdProvider

UE4 does not actually support interstitial ads for mobile at this point, were you following the workaround instructions thread here for putting interstitial ads into your project? If so, can you remove that code and see if you get the same crash? If you do crash can you add new logs?

Thanks!

avatar image Zimo Jul 20 '15 at 05:41 PM

It's my own implementation of interstitial ads, which worked without a problem in 4.7. I'll check that tomorrow, but this seems unlikely. Also i suspect the problem lies in the install/deploy mechanics. The app size is 122 mb on the device, while it should be around 500-600 mb.

avatar image Zimo Jul 21 '15 at 03:14 PM

Hi there.

So i found out several things, which helped me run the project on Android.

What threw me off, was the fact, that app is 122mb. Turns out, that for some reason Unreal apps just show this size on Android, regardless of an actual size. You have to check difference in actual memory usage, and it lists all data above this 122mb in miscellaneous category. Apps were showing correct size on 4.7.

I'm still narrowing down reasons for crashes, because i turned off several systems at once, but i'm fairly sure it was either connecting to google play services or shop. Advertising worked without a problem. I'll post a final update when i find out what happened.

avatar image Zimo Jul 22 '15 at 09:40 AM

Hey, after checking all systems i found out, that attempting to connect to Google Play without having it properly configured caused the crash this time. The earlier compression/asset problems were fixed.

Sorry for the confusion and thanks for the help.

avatar image wittlief ♦♦ STAFF Jul 22 '15 at 02:29 PM

excellent, glad you got it sussed. Good luck out there!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question