x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.8 Blueprint Editor Crash Bug!

I was able to find a bug that happens when you migrate from 4.7 to 4.8 which completely crashes your blueprint editor preventing it from ever opening again. I have reproduced this in the following way:

1)Open a New 4.7 blank project.

2)Create a BlueprintFunctionLibrary

3)Inside of the FunctionLibrary, create a new function

4)Create a local variable of HitResult

5)Drag a get reference to the blueprint graph

6)One the HitResult variable get node you just pulled out, Right click and "Split Struct"

Save the project.

7)Create a New 4.8 blank project

8)From your 4.7 project, Migrate your BlueprintFunctionLibrary to your new 4.8 project.

9)Open your 4.8 project and try opening the level blueprint.

It crashes the engine hardcore. The root cause I have it down to is that the HitResult Split Struct is not supported when moved to 4.8.

Product Version: UE 4.8
Tags:
more ▼

asked Jun 23 '15 at 05:54 PM in Bug Reports

avatar image

Devero
2.3k 114 62 234

avatar image Devero Jun 23 '15 at 07:45 PM

I also confirmed that splitting the struct from a LineTraceByChannel node causes the same crash.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Devero,

Thanks for the report! I was able to reproduce this in 4.8.1, however it appears to have already been fixed in our internal build, and this fix should be included in the next major release (4.9). I'll let the developers know regardless, to see if they are able to include the fix in a hotfix. Thanks again!

more ▼

answered Jun 24 '15 at 09:42 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question