x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

How to completely disable Eye Adaptation in a scene?

How to completely disable Eye Adaptation in a scene?

A similar question from the Beta era was left unanswered:

https://answers.unrealengine.com/questions/10521/how-to-completely-disable-eye-adaptation-in-a-scen.html

Speed Up and Speed down can't be set to 0 (they default to 0.02), so the suggested approach is not working.

Is there another way to disable it entirely?

Thanks,

Product Version: Not Selected
Tags:
more ▼

asked Apr 04 '14 at 04:28 PM in Using UE4

avatar image

Onoa
230 14 27 41

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hey Onoa,

In your camera (whichever is active during runtime), look in the Auto Exposure section. Check the Min Brightness and Max Brightness boxes, and set each value to 1.

You can play with the values there (and check the tooltip when hovering over these options for a more in-depth explanation), but as long as those two are equal (and are > 0) eye adaptation will be disabled.

Hope that helps!

Ben Halliday

more ▼

answered Apr 04 '14 at 05:48 PM

avatar image Onoa Apr 04 '14 at 06:20 PM

I am using a post process volume right now. I don't see any Auto Exposure section in the camera settings. Did you mean the post process?

avatar image Ben Halliday STAFF Apr 04 '14 at 06:23 PM

You'll have to do the same for both, because each will try to enable eye adaptation. It will look the same in both, however. Where is your camera? Is it attached as a component of your character?

avatar image Onoa Apr 04 '14 at 06:27 PM

It's inside the blueprint for my character as a component (FollowCamera) attached to the CameraBoom. I'm using the Third Person C++ template. I don't see any section labeled Auto Exposure in the details pane when it's selected.

avatar image Ben Halliday STAFF Apr 04 '14 at 06:44 PM

In your character blueprint, select the camera component, and look at the Details panel inside the blueprint editor. Is Auto Exposure one of the options there?

avatar image Onoa Apr 04 '14 at 06:46 PM

No, it doesn't show. alt text

camerasettings.jpg (126.6 kB)
avatar image Ben Halliday STAFF Apr 04 '14 at 07:07 PM

Ah, I missed it when you said this was a C++ template project. Yea, the default FollowCamera does not include the Auto Exposure settings. You'll need to make some adjustments to the FollowCamera in your [YourProjectName]Character.cpp ... let me dig around and see if I can find what you need to add for that.

avatar image Ben Halliday STAFF Apr 04 '14 at 08:33 PM

Okay, while I try to find a more C++ based answer for you, I do have a work-around you can try. Open your [YourProjectName]Character.h and comment out the Follow camera UProperty. Then open [YourProjectName]Character.cpp and comment out the FollowCamera area (under CameraBoom).

Now you won't have a camera, so add a camera component to your character blueprint and attach it to the CameraBoom. Your new camera will have all the normal options for a camera exposed, so you will be able to adjust the Min Brightness and Max Brightness under Auto Exposure.

Hope that does helps! Let me know if you run into trouble with that work-around.

Ben Halliday

avatar image Ben Halliday STAFF Apr 04 '14 at 10:45 PM

And one more way to do it without touching code:

In your character blueprint's EventGraph, right click and find the Get Follow Camera Component. Drag off that node and type Set PostProcessSettings. Off that Set node, drag off the Post Process Settings and type Make PostProcessSettings. If you expand that node, you'll see a huge list of all the post process settings you can adjust for that camera.

Included within that list are Auto Exposure Min Brightness and Auto Exposure Max Brightness inputs. Promote those to variables and give each of those variables a default value of 1, as described above, and that will disable Eye Adjustment for that camera, without having to touch any code.

alt text

Ben Halliday

avatar image Onoa Apr 05 '14 at 01:30 AM

Thanks for the information Ben. This method is useful if people want to avoid touching the code. I have found a code solution to display/access the camera post process settings in the Blueprint editor, posted below.

avatar image kenmorechalfant Apr 14 '17 at 02:59 AM

Note to anyone doing this in C++, such as in a CalcCamera function, you have to set bOverride_AutoExposureMinBrightness = true; AND AutoExposureMinBrightness = 1;... and then do that for the Max versions, too.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

In CameraComponent.h, remove meta = (ShowOnlyInnerProperties) from the macro and add EditAnywhere:

 UPROPERTY(Interp, BlueprintReadWrite, Category = CameraSettings, meta = (ShowOnlyInnerProperties))
 struct FPostProcessSettings PostProcessSettings;
 
 // Display Camera PostProcess settings by default in the Blueprint editor
 UPROPERTY(Interp, EditAnywhere, BlueprintReadWrite, Category = CameraSettings)
 struct FPostProcessSettings PostProcessSettings;

Recompile the engine, and the properties will now be displayed under Camera Settings->Post Process Settings

more ▼

answered Apr 05 '14 at 01:42 AM

avatar image

Onoa
230 14 27 41

avatar image Ben Halliday STAFF Apr 05 '14 at 02:02 PM

Thanks Onoa, this is very helpful!

avatar image TorQueMoD Aug 04 '14 at 08:04 AM

Sorry guys, just to clarify since I'm a programming Noob,

On line 44 inside CameraComponent.h I'm simply changing it to read

 UPROPERTY(Interp, EditAnywhere, BlueprintReadWrite, Category=CameraSettings)

Correct?

And once I rebuild the solution, where do I find Camera Settings -> Post Process Settings? I couldn't find it in World Settings or Project Settings or Editor Preferences.

avatar image Ben Halliday STAFF Aug 04 '14 at 08:37 PM

Hey TorQueMoD,

That is correct. If you set Line 44 to that, the settings should be accessible in the Editor in a code based project.

You can find them in the Camera Component. So for the camera attached to your character, go to the details panel and scroll down to the Auto Exposure section. You should see Min Brightness, Max Brightness, and Auto Exposure Bias there now.

Let me know if you have any questions.

avatar image TorQueMoD Aug 05 '14 at 12:28 AM

Sorry where do I find the camera component inside the editor? Since its coded in, its not used in a blueprint. How else do you access it?

avatar image Ben Halliday STAFF Aug 05 '14 at 12:41 AM

If you're using a Blueprint for your character, and it's based on the character class, you can open up the Blueprint and look in the Components tab at the top. If you then look over to the left, there will be a My Blueprint section with several dark blue components listed, one of which will probably be the FollowCamera:

alt text

This should be pretty similar for the Third Person, First Person, and Top Down code templates. I think some of the templates don't have a camera hard-coded into the character class, in which case you wouldn't see one in the Components list. If you don't have a default camera in there (or you removed the camera from the character class via code, as mentioned above), then you can simply go to the Add Component drop down and select a new Camera component, which should have the Auto Exposure already accessible.

Hope that helps! Let me know if you have more questions.

followcamera.png (501.6 kB)
avatar image TorQueMoD Aug 06 '14 at 04:56 AM

I'm confused. If I'm using the 3rd person C++ template, it bypasses the buleprint for the character all together so being able to adjust the settings inside a blueprint isn't really useful since the code isn't using one anyway.

I figured you'd have to - or maybe more appropriately be able to - turn off different post process effects like lens flare and eye adaptation somewhere in the code. Is this possible?

avatar image Ben Halliday STAFF Aug 06 '14 at 06:57 PM

A C++ project doesn't bypass anything. The Character Blueprint is your in-Editor way of accessing the class you set up in code. The C++ templates create a Character class, and the MyCharacter Blueprint is a child of that class. The adjustments we made above are to the CameraComponent class, which appears inside the Character class by default, among other places. Anything that uses a CameraComponent that is hard-coded in will now have the Auto Exposure settings exposed.

If you're not using the Character class, then any CameraComponent you use should already have those exposed, so the above code alterations wouldn't be necessary.

Your project is using a default pawn, which you can see by opening the World Settings and looking at the Game Mode settings. If the Game Mode is set to "None", it uses a default pawn created from MyCharacter. If you're using that pawn, and want to make the adjustments to the camera, you can do so in the Editor after altering the code above.

Auto Exposure is going to be a part of any camera actor or camera component that you use. If you're not using the default pawn, then you'll need to find which camera you are using and make those adjustments to it. Most likely you won't need to do it via code, but you can if you want to.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I think this can be found under the defaults panel in your MyCharacter blueprint.

alt text

more ▼

answered Apr 12 '14 at 04:43 AM

avatar image

zoid
326 11 14 226

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question