x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4 V8 Error

An error occurred while trying to generate project files.

Running C:/Program Files/Epic Games/4.8/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project="C:/Users/Antonio/Documents/Unreal Projects/test/test.uproject" -game -rocket -progress Discovering modules, targets and source code for game... UnrealBuildTool Exception: ERROR: Failed to read environment variables from XML file: C:\Users\Antonio\AppData\Local\Temp\tmp6840.tmp

Product Version: UE 4.8
Tags:
more ▼

asked Jun 24 '15 at 11:50 AM in Installation & Setup

avatar image

HolytoneProductions
1 2 2

avatar image Doug E ♦♦ STAFF Jun 24 '15 at 03:36 PM

Hey HolytoneProductions-

Could you elaborate on what exactly is happening? Are you trying to create a new project or convert a project from a previous version? Did this message appear when right clicking on the .uproject or when trying to build inside Visual Studio? Please give more detail to explain what you were doing when you received this message.

Cheers

Doug Wilson

avatar image HolytoneProductions Jun 26 '15 at 02:39 AM

Im creating one C++ project, i got VB Studios 13 Community and i can create BluePrint projects but i cant C++ ones i get errors like those

avatar image Doug E ♦♦ STAFF Jun 26 '15 at 02:34 PM

Does the tmp6840.tmp file exist in the file path shown (C:\Users\Antonio\AppData\Local\Temp\tmp6840.tmp)? If so can you try deleting/removing the file and then try to create a project again? If you are still unable to create a code project you may want to try uninstalling/reinstalling Visual Studio and/or the engine version you're working with.

avatar image HolytoneProductions Jun 26 '15 at 06:18 PM

deleting the file didnt worked :/ it just create other with the same kind of error :(

avatar image HolytoneProductions Jun 26 '15 at 08:55 PM

reinstalled the visual studios and unreal engine still nothing :/

avatar image Matthew J Jun 30 '15 at 07:37 PM

Hi HolytoneProductions,

Can you post the contents of the new tmp file? This issue could be related to the following post and I'll need to see the contents of that file to know if it is or not. https://answers.unrealengine.com/questions/248195/unrealbuildtool-fails-on-new-c-project.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi HolytoneProductions,

We haven't heard from you in a while. Are you still experiencing this issue or were you able to solve it? I'll be setting this issue to resolved in the meantime for tracking purposes but please feel free to reopen the question by commenting at any time if you're still experiencing these issues or would like to share what fixed it.

Have a nice day,

Matthew Clark

more ▼

answered Jul 08 '15 at 07:41 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question