x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

engine crash when changing "gamemode override"

So im trying to change the game mode in each level of a project that I am working on and ever since I have upgraded to 4.8.1 when I click on the GameMode Override in the world setting and a game mode is already in there the whole engine will crash and a bar will pop up saying "rebuilding class heiarchy" and it will not allow me to change the gamemode through the override. is there another way of changing the game mode from level to level or is this the only way? if so how do I fix it?

alt text

Here is an image of the crash and the error report. also this does not happen in 4.7.6, so it may be a bug.

Product Version: UE 4.8
Tags:
crash_image.png (2.3 MB)
more ▼

asked Jun 25 '15 at 03:25 AM in Bug Reports

avatar image

Lewa1000g
51 5 4 6

avatar image popawheelie Jun 25 '15 at 04:26 AM

I am getting the same crash after 4.8.1. Although my game crashes with no report to desktop.

avatar image smokeBONES Jun 30 '15 at 09:57 PM

If you press any of them, its starts to rebuild and crashes

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi all,

Thanks for the report! I was able to reproduce this in 4.8.1 as well as our internal build, and I've created a bug report for the crash (UE-17673). I'll post here as soon as I see an update on it and have a timeline for the fix.

In the meantime, it appears that if you open the GameMode Blueprint once and compile/save it, the editor won't crash when making adjustments in the World Settings tab. Please let us know if this is not the case for you.

Thanks!

more ▼

answered Jun 25 '15 at 02:31 PM

avatar image Ben Halliday STAFF Jun 25 '15 at 03:09 PM

Additional workaround: Select the gameMode in the Content Browser, and next to the "GameMode Override", use the arrow button to use that asset.

avatar image ShadowPie Jun 26 '15 at 02:29 PM

Unfortunately opening the GameMode Blueprint, compiling and saving didn't solve the issue for me.

Setting default GameMode in project settings seems to have solved the issue though.

avatar image rXp Jun 30 '15 at 12:58 PM

I have the same issue when changing the default playercontroller but the workarounds are not working and I can't override the project settings (I can but it would break the game) Although I was able to modify it by selecting the new controller and clicking on "set selected asset..." (an arrow pointing to the left at the right of the combobox)

avatar image Lewa1000g Jun 30 '15 at 02:38 PM

I did find one way of working around it to change the gamemode go to that panel and next to the gamemode override dropdown menu click the small YELLOW arrow to reset the override to "none" once you have done that you can change the the overrides and not have the engine crash you only have to do this the first time

avatar image Dannyk90 Jul 11 '15 at 05:21 PM

thank you lewa100g that worked :D

avatar image Gam3r Jul 12 '15 at 04:11 PM

Any ETA for this bug fix?

avatar image Ben Halliday STAFF Jul 13 '15 at 03:29 PM

We don't have a firm date yet, but a fix will be included in an upcoming hotfix. Shouldn't be too much longer.

avatar image Embeddetech Jul 13 '15 at 09:00 PM

Hi Ben, This is a very similar issue, don't know if it should be in a different thread or not. But I have a game mode defined in C++ and a player controller class defined in C++. When I create a new project, I can't select my C++ game mode override and then select my player controller class because it is grayed out. But if I create a new game mode blueprint in the GameMode Override area by clicking the '+' symbol, the default pawn class, HUD class, player controller class, and game state class are no longer grayed out, I can change them. So I have to create this new blueprint game mode, and then select my C++ player controller class, and then select my C++ game mode, and everything appears to work. When selecting my C++ game mode, the four "Selected GameMode" combo boxes are grayed out again, however my player controller class still shows my C++ player controller class because that is what was selected when I selected my C++ game mode.

Let me know if I should create a new thread.

Thanks!

avatar image Ben Halliday STAFF Jul 13 '15 at 09:17 PM

It doesn't appear to be related. This crash simply involves clicking the GameMode Override options in the World Settings tab in the Editor. You're running into a completely different issue, sounds like. You can open a new post in Bug Reports, and we'll assign someone to look into it.

I don't believe it's a bug, but I'm not 100% sure on that yet so I'll get some C++ savvy people on it. Thanks!

avatar image Embeddetech Jul 13 '15 at 08:53 PM

So weird... I logged in to report this very bug and saw it as the first one.

avatar image Philty Dragonbreath Jul 28 '17 at 08:28 AM

Sorry for opening this up again, but I'm getting kind of the same problem. (Using 4.16.2 source build)

Whenever I switch my gamemode override to NONE and then try to play the game, the editor crashes. Any solution to this?

It does not crash when I run it as a single process. But I do not want that (for dedicated server testing purposes)

avatar image Philty Dragonbreath Jul 28 '17 at 08:40 AM

Crash reporter is giving me this:

 Assertion failed: PIEInstanceID != -1 [File:C:\Users\Hover\Desktop\UE4Source\Engine\Source\Runtime\Engine\Private\World.cpp] [Line: 2557] 
 
 
 
 UE4Editor_Core!FDebug::AssertFailed() [c:\users\hover\desktop\ue4source\engine\source\runtime\core\private\misc\assertionmacros.cpp:349]
 UE4Editor_Engine!UWorld::ConvertToPIEPackageName() [c:\users\hover\desktop\ue4source\engine\source\runtime\engine\private\world.cpp:2558]
 UE4Editor_Engine!UWorld::RenameToPIEWorld() [c:\users\hover\desktop\ue4source\engine\source\runtime\engine\private\world.cpp:2531]
 UE4Editor_Engine!UEngine::LoadMap() [c:\users\hover\desktop\ue4source\engine\source\runtime\engine\private\unrealengine.cpp:10150]
 UE4Editor_Engine!UEngine::Browse() [c:\users\hover\desktop\ue4source\engine\source\runtime\engine\private\unrealengine.cpp:9563]
 UE4Editor_Engine!UEngine::TickWorldTravel() [c:\users\hover\desktop\ue4source\engine\source\runtime\engine\private\unrealengine.cpp:9752]
 UE4Editor_UnrealEd!UEditorEngine::Tick() [c:\users\hover\desktop\ue4source\engine\source\editor\unrealed\private\editorengine.cpp:1572]
 UE4Editor_UnrealEd!UUnrealEdEngine::Tick() [c:\users\hover\desktop\ue4source\engine\source\editor\unrealed\private\unrealedengine.cpp:386]
 UE4Editor!FEngineLoop::Tick() [c:\users\hover\desktop\ue4source\engine\source\runtime\launch\private\launchengineloop.cpp:3119]
 UE4Editor!GuardedMain() [c:\users\hover\desktop\ue4source\engine\source\runtime\launch\private\launch.cpp:166]
 UE4Editor!GuardedMainWrapper() [c:\users\hover\desktop\ue4source\engine\source\runtime\launch\private\windows\launchwindows.cpp:134]
 UE4Editor!WinMain() [c:\users\hover\desktop\ue4source\engine\source\runtime\launch\private\windows\launchwindows.cpp:210]
 UE4Editor!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:259]
 kernel32
 ntdll
(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question