x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Landscape at low LOD , in standalone game

Hello , this is the worst timing for this problem , I hope someone could help me soon , I am supposed to show the project (universcity project) in a day or two . So I have this large map with one landscape tile on it . I have everything build , road with a spline tool , meshes on top , foliage etc. In editor everything is looking great . The moment when I start up the packaged project , the landscape dials down the LOD . It deforms , engulfs the spline meshes , everything , just terrible . And it cant change at all , console commands don't do anything , tried , sg.View Distance quality , r.View Distance Scale . Not helping at all . I have a quality level menu , bought it from the store , it works fine with option , but even with everything on max , it just doesnt help . I tried removing it and setting options manually , the same occurs . I tried setting the terrain lod's level differently but again nothing . Later I will update with a screenshot when I can . II really hope someone will be able to help me with this , otherwise I will have to just show it broken ... :(

Product Version: UE 4.7
Tags:
more ▼

asked Jun 25 '15 at 02:09 PM in Rendering

avatar image

Samuil
32 6 10 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi,

in MyProject/Config/DefaultEngine.ini

add:

 [ConsoleVariables]
 r.Streaming.PoolSize=3000


Also you can run game with texture streaming switched off. Add -notexturestreaming to your executable command line parameter.

more ▼

answered Jun 26 '15 at 06:54 AM

avatar image

ddvlost STAFF
1.3k 18 7 48

avatar image Samuil Jun 26 '15 at 08:44 AM

Thank you ! That is great information to have, both ways work for me. Although I have noticed something strange. Yesterday after some testing I made a "fix" of my own , runing a console command on begin play in level blueprint. But I found out that poolsize of 3000, doesnt actually work. What I mean is when I run the command off of the blueprint and run in standalone, everything is blurred (at their lowest mip i am guessing) . Poolsize of 2000 though - works. I found that, when running the stat streamingdetails command. When I set the 3k , in the stat where poolsize is shown, there is nothing. When using 2k or lower it shows the pool correctly. Everything above 2k results in no stat and if executed from blueprint - blurred textures. I tried your solution, and it works. No blurring of the textures , game in standalone doesnt have the issue, but the stat streamingdetail still doesnt show the poolsize. Although, you can see that the pool is set to 3k from the "under budget" stat , that reads 2.9gb at start, for example. I wonder why is that ? Also I am wondering if there is a way to add that same console command to some of the ini files of the already packaged game. I tried Engine.ini , but it didnt work . Again, thanks for your time !

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I found what the problem was . It turns out it isnt the LOD's of the terrain but the texture quality . Texture streaming to be exact . The default pool is too small , even in the highest level . When running the command r.Streaming.PoolSize 3000 , everything clears out immidiatly , terrain is fixed . Now at least I have some solution , but I can't find a way to change that other than the command . I will open another question for , how to change default scalability settings . This is one is kinda resolved.

more ▼

answered Jun 25 '15 at 05:11 PM

avatar image

Samuil
32 6 10 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question