x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

How to change default scalability settings .

I have an issue with my terrain . It deforms when playing in packaged game or standalone . After alot of frustration I found it is the Streaming Pool size that affects it . The maximum amount of 1000mb , is just not enough , and the terrain heightmap is mip-ing , and deforming my terrain . Now when I use the command r.Streaming.PoolSize 3000 , everything is fixed . The question now is how do I do that without always entering the command . I tried making blueprint to execute the command on begin play - doesnt work , everything is worse . I tried searching around here for some other way fo starting the game with the command - nothing . I tried changing the Scalability.ini files , changing the PoolSize to 3000 in every place even the low levels . It doesnt whant to take the change . After I enter the game , the file reverts to its default . I tried setting it to read only - again nothing . So my question is where and how do I set my own custom values for the engine scalability settings . The scalability.ini doesn't work .

Product Version: UE 4.7
Tags:
more ▼

asked Jun 25 '15 at 05:19 PM in Rendering

avatar image

Samuil
32 6 10 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I would set the "Never Stream" setting in the texture asset that defines the heightmap.

more ▼

answered Sep 28 '15 at 10:23 AM

avatar image

anticto
23 1 3 5

avatar image Samuil Sep 29 '15 at 07:27 AM

That did cross my mind , but it appears the heightmap is not stored the usual way. You can't find it in the content browser. Since then I use a blueprint to increase the poolsize in the very begining of the game. That's not ideal though.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question