x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

'Finding Path to Actor/Location Synchronously' works differently in v4.8

Hi, I'm using 'Finding Path to Actor/Location Synchronously' to get path points to determine if a path exists between two points. Everything was working fine in v4.7, as it created zero path points when there was something obstructing the path.

But after updating to v4.8, it continues to create partial paths that stop near the obstructing mesh. Combined with the 'Does Path Exist' bug when dealing with dynamic nav mesh rebuilds, I'm not aware of any methods to check if a path exists between two points. Of course there are some hacks that could work in very specific cases, but no direct approach to deal with this in v4.8.

It would be great if someone could clarify if this change in functionality was intentional or if I need to report it as a bug.

Product Version: UE 4.8
Tags:
more ▼

asked Jun 26 '15 at 04:17 AM in Blueprint Scripting

avatar image

Stormrage256
1k 82 75 117

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

This is a bug. The reason it broke is because we unified some parameters that are driving path finding under the hood, and the blueprint functions you mention didn't get a way to set these parameters - namely disallowing "partial paths", because that's what your getting now. I'll file this as a bug to fix and I have a workaround for you.

All you need to do to figure out if the path you got is partial or not is to see if the last point of the received path is within TetherDistance of the your goal location.

Regarding that "Does Path Exist" issue I wasn't able to repro it (out QA is looking into consistent repro), but have you tried configuring the decorator to use regular pathfinding rather than hierarchical (the PathQueryType parameter)?

Cheers,

--mieszko

more ▼

answered Jun 27 '15 at 04:06 PM

avatar image

MieszkoZ STAFF
7.3k 223 56 410

avatar image Stormrage256 Jun 27 '15 at 04:47 PM

Cool, thanks Mieszko. I'm using a similar workaround to the one you suggested, for now by comparing the last path point with my target location projected to nav mesh.

As for the 'Does Path Exist' issue, I had submitted a bug report couple of weeks back along with a sample project and crash report data: https://answers.unrealengine.com/questions/241261/using-does-path-exist-decorator-with-dynamic-nav-m.html

As per your suggestion, I tried out Regular Pathfinding. It is crashing in that scenario as well. The only scenario where it's not crashing is when I use 'Navmesh Raycast 2D' path query. But when I use that, it's showing that a path doesn't exist.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question