x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Atmospheric Fog only active in editor

Hello,

I'm having a problem with UE 4.8 regarding Atmospheric Fog: It only renders in Editor. Doesn't render anymore while in Standalone or even in a packaged build. Notes: - It always worked before without any problem since UE 4.4 when I first implemented it. - I triple checked for it being active and it is. - I even tried putting in a new one and it behaves exactly the same. - I tried disabling Height fog, sun, gppv and no result. - It's a component of a blueprint BUT not being affected in any way, it's just there for global use.(I did try adding a new Fog outside the blueprint and no change)

I spent a lot of hours already trying to fix this and have given up. I have no other ideas of what could cause this.. Here is an image of the Fog settings, maybe it helps. Thank you! alt text

Product Version: UE 4.8
Tags:
more ▼

asked Jun 27 '15 at 07:37 PM in Bug Reports

avatar image

Virgil Tuser
31 4 7 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Virgil -

Thank you for your report. I was able to reproduce this internally and have entered a bug report as UE-17850. As we investigate a fix for this issue I will keep you informed here.

Thank You

Eric Ketchum

more ▼

answered Jun 29 '15 at 06:31 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 735

avatar image AdrianLazar Jul 11 '15 at 03:59 PM

I have a related issue with the atmospheric fog - worked perfectly in pre 4.8 but if I compile the blueprint that contains it it will stop rendering in play mode. Even if I don't do any change, just compiling the blueprint and the fog stops rendering. If I restart the editor then works fine in play mode, still not really ideal when I need to make changes.

Anyway, I wanted to know if there's any ETA on this since I assume it will fix my problem as well.

Thank you.

avatar image Virgil Tuser Jul 11 '15 at 04:23 PM

Your problem sounds like it has something to do with blueprints. In my case it never works outside of the editor even if it's outside of a blueprint or not.

Just curious, are your blueprints responsible for turning on/off the atmospheric fog, Adrian? If so, then it's maybe some faulty initialization somewhere along the way. Just maybe.

Also, did you try to use an atmospheric fog outside of the blueprint, in play mode? I'm curious if it works on your end.

avatar image AdrianLazar Jul 11 '15 at 04:38 PM

Hi Virgil, If I place the atmospheric fog outside the blueprint it works fine, both in play mode in the viewport and also if I launch it in standalone. I'm on 4.8.1 btw.

Cheers.

avatar image Virgil Tuser Jul 11 '15 at 05:09 PM

I'm going to update to 8.1 and see how it behaves on my end after that. I'm on 8.0 right now. Having it work outside of a blueprint would be a step in the right direction for me =)) I'll update here once I get to try it.

avatar image Virgil Tuser Jul 11 '15 at 06:07 PM

Upgraded to 8.1 and absolutely no change. I can't get to make an atmospheric fog show up outside, nor inside a blueprint in play standalone, no matter what I do.. I can have 2 of them working at the same time in editor play, but nothing in standalone or windows build.. I'm just going to wait on Epic to fix this one :|

avatar image Lovecraft_K ♦♦ STAFF Jul 13 '15 at 02:32 PM

Hi Virgil Tuser -

I ran a check on the issue for you and found that it has been fixed in the latest internal version of the engine and barring any QA issues should be included the an upcoming major engine release.

Thank You -

Eric Ketchum

avatar image Virgil Tuser Jul 13 '15 at 03:40 PM

Eric, I believe you have an awesome name :D And thank you for the update. I'll be getting back to this thread first thing after the new release will be available to tell you if it did the trick! Thank you!

avatar image Hyperloop Jul 30 '15 at 07:20 PM

Did this make it into the 4.8.2 hotfix?

avatar image Lovecraft_K ♦♦ STAFF Jul 30 '15 at 07:38 PM

Hi Hyperloop -

The fix for this issue is integrated in 4.9 and should be corrected in the current Preview 1 release.

Thank You

Eric Ketchum

avatar image Hyperloop Aug 03 '15 at 08:24 PM

Awesome! Thank you so much!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question