x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Game Module could not be found

I noticed this question has been asked before but there was no solution mentioned so I am putting it out here again.

I am on Mac OSX 10.9. i7 2.6Ghz 16GB RAM.

Following are the repro steps. Repro rate is 100%.

  1. Open UE4 Editor. Start a blank project. Dont import starter content.

  2. File->Add code to project. Create a Dummy class

  3. Close the editor

  4. Add BeginPlay(). Display "Hello world" on the screen.

  5. Compile. Select target ($ProjectName) -> Mac (I also tried ($ProjectName)Editor -> Mac)

  6. Build Successful

  7. Go to unreal launcher. Launch the editor and error (attached). Cant do anything.

I tried above steps 3 or 4 times before giving up. I also tried right-clicking on the .uproject and selecting 'Generate XCode Files', then recompiling still no success.

Please let me know what I am missing. Cant do a thing right now.

Error

Product Version: Not Selected
Tags:
more ▼

asked Apr 05 '14 at 01:00 AM in C++ Programming

avatar image

Anshul
153 9 12 216

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

So after creating millions of projects and trying various combinations I finally figured out the problem.

In XCode, chose ($ProjectName)Editor -> My Mac as your compile target and then Product -> Build For -> Profiling. This worked for me and I am able to open the project in in the editor. Compiling for any other configuration seems to produce "Game Module not found" error as mentioned above.

May be it was documented somewhere but I couldn't find it. At least its working now :)

more ▼

answered Apr 05 '14 at 01:48 PM

avatar image

Anshul
153 9 12 216

avatar image piinecone Apr 10 '14 at 05:01 PM

Thanks! This worked for me on OSX 10.9.2 with XCode 5.1.

I'm considering building from Source so I can take advantage of this answer: https://answers.unrealengine.com/questions/14637/from-source-the-game-module-could-not-be-found.html#answer-15311

avatar image Ghar Jun 02 '14 at 03:23 PM

Thanks you so much! "Build for Profiling" did it.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question