x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Problem with textures shading?

Hello, I opened a copy of a current project in unreal 4.8.1, converted it from unreal 4.7.6.. and there's something wrong with the textures, not all of them but only certain objects..

textures are perfect in the older version (4.7.6)

now in (4.8.1) some of the objects have some kind of wrong shading, when I'm far or near some of the objects the textures gets black or blurry, when i move the camera away or near the object it returns normal then get blurry again. and I'm sure how can I fix it. does has something to do with texture streaming from project settings? any ideas?

Images

wrong shading (near the object)

alt text

wrong shading (far from the object)

alt text

correct shading (far from the object)

alt text

correct shading (near the object)

alt text

Product Version: UE 4.8
Tags:
01.jpg (30.5 kB)
02.jpg (26.2 kB)
03.jpg (17.7 kB)
04.jpg (32.6 kB)
more ▼

asked Jun 28 '15 at 01:10 AM in Rendering

avatar image

blackdoomy
57 6 9 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I think that this effect could be caused by the mesh normals or normal map. Maybe try to check "recompute normals" in details panel of the mesh and apply changes. If this doesn't help try to change normal map in material to something else and then change to previous normal map.

more ▼

answered Jun 28 '15 at 03:13 PM

avatar image

Z3ZU
6 2 3

avatar image blackdoomy Jun 28 '15 at 10:05 PM

Thank you for your reply Z3ZU, Now I'm rebuilding the lighting after re-importing the mesh.. hoping that may solve this. what's confusing me is everything in 4.7.6 is perfect, opening a copy of the project in 4.8.1 caused that problem.. maybe all what I need is a light build.. it's around 21 hours of waiting xD

avatar image blackdoomy Jun 29 '15 at 11:53 PM

problem were solved only in the editor after re-build the lightning.. when I package the project it's still there.. also the same material problem with some other objects

alt text

alt text

bad.jpg (55.4 kB)
good.jpg (79.5 kB)
avatar image FaustyWalk Jul 01 '15 at 05:17 PM

Hi Yahiya Jasem, Same problem here with a 4.7.6 project loaded in 4.8.0 (problem started here) then 4.8.1. As I use Substance plugin, maybe this could cause the issue. Do you use it ?

avatar image blackdoomy Jul 02 '15 at 01:10 AM

Hello, FaustyWalk No I'm not using it, but I did several things and that solved the problem for me.. maybe at least for now.. still testing options

avatar image jblessing Sep 25 '15 at 02:37 AM

Any more solutions? I'm having the same issue...a level looks fine in 4.7 (what it was built in) and I'm having these issues in 4.9.

avatar image blackdoomy Sep 27 '15 at 10:37 PM

hey jblessing Sorry for my late reply I just saw your comment, in my case I solved this problem by turning off Texture Streaming from "Rendering" Tab at "Project Settings" and restarting the engine! I hope that'll work for you

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Ok, problem solved too, without knowing what was wrong... Just turned off the streaming texture option in the project settings/rendering. So I have to find out why streaming causes so much issues.

more ▼

answered Jul 02 '15 at 08:32 AM

avatar image

FaustyWalk
31 3 4 12

avatar image blackdoomy Jul 16 '15 at 04:58 AM

that worked for me too.. very strange problem :/

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question