x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

When generating light maps, quality differences in light of Mobility

Hi. alt text

When using the light map, there are huge gap according to options. Especially, If we select Stationary for DirectionLight Mobility with low Lighting Resolution, result shadow seems like some incomplete figures. So with low resolution, we’re using Static light instead of Stationary light. Is this normal? Or Is there an option to improve quality with low resolution. Or any advice for us? We would appreciate your reply.

Product Version: UE 4.8
Tags:
more ▼

asked Jun 29 '15 at 11:40 AM in Rendering

avatar image

sharbong
13 5 9 13

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Sharbong,

This is expected. Stationary directional lights are a hybrid between dynamic lighting and static lighting. With the directional stationary you have the option to set the Cascaded Shadow Map (CSM) distance so that when you're within so many meters of the camera view the static lighting (used in your images) will use dynamic lighting for better quality up close.

These shadows, aren't necessarily meant to be seen up close like this and is pointless to use softer shadows like with Static only.

Try selecting the Stationary Light and in the details panel locate the Cascaded Shadow Maps tab > Dynamic Shadow Distance StationaryLight. By default it is disabled and needs to have a value of 1 or higher to work. 1000 = 1 meter.

Try using a higher value and see if you get the results you're looking for. If you're beyond the CSM shadow distance and it reverts back to the static baked lighting, you may want to increase the shadow quality and rebuild there to make the transition better or more natural.

I hope this helps.

Tim

more ▼

answered Jun 29 '15 at 04:28 PM

avatar image

Tim Hobson ♦♦ STAFF
48.9k 887 101 877

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question