x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Mac, UE4.8.1] Engine crash on every hot reload

Hi all,

I previously thought this might have been caused by something in my code, but I've tried commenting the whole lot out and still it happens.

I have been experiencing this crash ever since version 4.8.1 as far as I can recall, and I've tried many things, including deleting the Intermediate and Saved directories inside my projects, clearing the Derived Data Cache and removing blueprint assets.

It's an annoyance more than anything, as the compile seems to work. After I restart the engine after the crash my code runs perfectly. The stack trace is below, which has come out pretty much identical for every crash (and there have been a lot!)

Hopefully someone can clarify if this is a bug or make any suggestions as to something I might be doing wrong.

 FOutputDeviceMacError::Serialize(wchar_t const*, ELogVerbosity::Type, FName const&) Address = 0x107af4d2f (filename not found) [in UE4Editor-Core.dylib]
 FOutputDevice::Logf(wchar_t const*, ...) Address = 0x107bb7def (filename not found) [in UE4Editor-Core.dylib]
 FDebug::AssertFailed(char const*, char const*, int, wchar_t const*, ...) Address = 0x107b8a794 (filename not found) [in UE4Editor-Core.dylib]
 FBlueprintEditorUtils::PostDuplicateBlueprint(UBlueprint*) Address = 0x10f7311af (filename not found) [in UE4Editor-UnrealEd.dylib]
 StaticDuplicateObjectEx(FObjectDuplicationParameters&) Address = 0x1084add28 (filename not found) [in UE4Editor-CoreUObject.dylib]
 StaticDuplicateObject(UObject const*, UObject*, wchar_t const*, EObjectFlags, UClass*, EDuplicateForPie) Address = 0x1084ac956 (filename not found) [in UE4Editor-CoreUObject.dylib]
 ProcessNewlyLoadedUObjects() Address = 0x108498258 (filename not found) [in UE4Editor-CoreUObject.dylib]
 TBaseStaticDelegateInstance::ExecuteIfSafe() const Address = 0x108388ba7 (filename not found) [in UE4Editor-CoreUObject.dylib]
 TBaseMulticastDelegate::Broadcast() const Address = 0x1079b2430 (filename not found) [in UE4Editor-Core.dylib]
 FModuleManager::LoadModuleWithFailureReason(FName, EModuleLoadResult&, bool) Address = 0x107bedb5f (filename not found) [in UE4Editor-Core.dylib]
 FModuleManager::LoadModule(FName, bool) Address = 0x107bec62e (filename not found) [in UE4Editor-Core.dylib]
 FHotReloadModule::DoHotReloadInternal(bool, ECompilationResult::Type, TArray, TArray, FOutputDevice&) Address = 0x119c12967 (filename not found) [in UE4Editor-HotReload.dylib]
 FHotReloadModule::DoHotReloadCallback(bool, ECompilationResult::Type, TArray, TArray, FOutputDevice&) Address = 0x119c1244b (filename not found) [in UE4Editor-HotReload.dylib]
 _ZN21TMemberFunctionCallerI16FHotReloadModuleMS0_FvbN18ECompilationResult4TypeE6TArrayIP8UPackage17FDefaultAllocatorES3_I5FNameS6_ER13FOutputDeviceEEclIJRbRS2_RKS7_RKS9_SB_EEEDTclpmdtdefpT3ObjdtdefpT9MemFunPtrspcl7ForwardIT_Efp_EEEDpOSM_ Address = 0x119c2a557 (filename not found) [in UE4Editor-HotReload.dylib]
 TBaseRawMethodDelegateInstance, TArray, FOutputDevice&>::ExecuteIfSafe(bool, ECompilationResult::Type) const Address = 0x119c2a45c (filename not found) [in UE4Editor-HotReload.dylib]
 FHotReloadModule::CheckForFinishedModuleDLLCompile(bool, bool&, bool&, FOutputDevice&, bool) Address = 0x119c09c47 (filename not found) [in UE4Editor-HotReload.dylib]
 FHotReloadModule::Tick() Address = 0x119c08863 (filename not found) [in UE4Editor-HotReload.dylib]
 UEditorEngine::Tick(float, bool) Address = 0x10eb007b4 (filename not found) [in UE4Editor-UnrealEd.dylib]
 UUnrealEdEngine::Tick(float, bool) Address = 0x10f1b26ec (filename not found) [in UE4Editor-UnrealEd.dylib]
 FEngineLoop::Tick() Address = 0x1078bc2f3 (filename not found) [in UE4Editor]
 GuardedMain(wchar_t const*) Address = 0x1078c2df3 (filename not found) [in UE4Editor]
 -[UE4AppDelegate runGameThread:] Address = 0x1078d2583 (filename not found) [in UE4Editor]
 -[FCocoaGameThread main] Address = 0x107a583ce (filename not found) [in UE4Editor-Core.dylib]
 Unknown() Address = 0x7fff88805d8b (filename not found) [in Foundation]
 _pthread_body Address = 0x7fff82eb4899 (filename not found) [in libsystem_pthread.dylib]
 _pthread_struct_init Address = 0x7fff82eb472a (filename not found) [in libsystem_pthread.dylib]

Product Version: UE 4.8
Tags:
more ▼

asked Jun 29 '15 at 12:09 PM in Bug Reports

avatar image

DarwinLives
26 1 4

avatar image Doug E ♦♦ STAFF Jun 29 '15 at 06:46 PM

Hey DarwinLives-

Can you post the log files from the crash as well? Also, does a new project crash when you try to hot reload code added to it? If it's possible could you send us a stripped down version of your project or a sample project where this crash is occurring?

Cheers

Doug Wilson

avatar image DarwinLives Jun 29 '15 at 08:24 PM

Hey Doug,

No, it's something that's in my project that's causing it. Here are the log files for the last few crashes today, if that helps. The critical error in most cases seems to be this, but I'm not completely sure what this means.

Assertion failed: Blueprint->GeneratedClass != NULL

I'm seeing a lot of console spam for something called SlugSkeletalMesh not having a skeleton, which is odd as I haven't got anything by that name, at least not anymore. Could it be trying to reference an old name for a UPROPERTY?

Thanks in advance!

avatar image Doug E ♦♦ STAFF Jun 29 '15 at 09:33 PM

Many of the errors seem to be from missing assets. If you've moved/deleted/renamed assets in the content browser or have changed the hierarchy of folders you may need to clean up redirectors to make sure "ghost" objects aren't being called. You can do this by selecting the Content heading of the content browser and right clicking and selecting "Fix Up Redirectors in Folder".

avatar image DarwinLives Jun 29 '15 at 10:05 PM

I've done this – there were a couple of references to old objects which were deleted, but the engine is still crashing on every compile unfortunately.

I've also cleaned up some of my code so as to rid myself of some of the console spam, here's a more recent log file

avatar image Tim C ♦♦ STAFF Jul 27 '15 at 09:09 PM

Hi DarwinLives,

Sorry for the delay in responding to your post. Do you still see this crash occurring in 4.8.2? Do you still see references to SlugSkeletalMesh in the console (the latest set of information you provided does not seem to mention that)?

Having looked over the information provided so far, we are not sure that this is something that is specific to Mac. Have you had any opportunity to see if the same crash occurs on a Windows machine?

Tim

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi DarwinLives,

We have not heard back from you for a few days. Do you still need help with this issue? I will be marking this post as resolved for internal tracking purposes, but if you still need any assistance please feel free to add a comment at any time and re-open the post.

Tim

more ▼

answered Aug 06 '15 at 08:16 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question