x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Linux] Running Engine with -opengl4 causes crash

 Failed to open BO for returned DRI2 buffer (1110x714, dri2 back buffer, named 21).
 This is likely a bug in the X Server that will lead to a crash soon.
 Signal 11 caught.
 EngineCrashHandler: Signal=11
 [2015.06.29-16.40.10:046][417]LogCrashTracker: 
 
 
 [2015.06.29-16.40.10:046][417]LogLinux: === Critical error: ===
 Unhandled Exception: SIGSEGV: invalid attempt to access memory at address 0x00000014
 
 [2015.06.29-16.40.10:046][417]LogLinux: Fatal error!
 
 [Callstack]  02  0x00007fb61fc19e01  ReportCrash(FLinuxCrashContext const&)
 [Callstack]  03  0x000000000042f19b  EngineCrashHandler(FGenericCrashContext const&) [/home/ceset/EpicGames/UnrealEngine/Engine/Source/Runtime/Launch/Private/Linux/LaunchLinux.cpp, line 31]
 [Callstack]  04  0x00007fb61fc1d628  PlatformCrashHandler(int, siginfo_t*, void*)
 [Callstack]  05  0x00007fb620695660  /usr/lib/libpthread.so.0(+0x10660) [0x7fb620695660]
 [Callstack]  06  0x00007fb5f27251b9  /usr/lib/xorg/modules/dri/i965_dri.so(+0x3fa1b9) [0x7fb5f27251b9]
 [Callstack]  07  0x00007fb5f23b2d0e  /usr/lib/xorg/modules/dri/i965_dri.so(+0x87d0e) [0x7fb5f23b2d0e]
 [Callstack]  08  0x00007fb5fc3eb5bf  /usr/lib/primus/libGL.so.1(+0x275bf) [0x7fb5fc3eb5bf]
 [Callstack]  09  0x00007fb62068c354  /usr/lib/libpthread.so.0(+0x7354) [0x7fb62068c354]
 [Callstack]  10  0x00007fb614fc3bfd  /usr/lib/libc.so.6(clone+0x6d) [0x7fb614fc3bfd]
 
 [2015.06.29-16.40.10:046][417]LogExit: Executing StaticShutdownAfterError
 Starting ../../../engine/binaries/linux/crashreportclient
 [2015.06.29-16.40.14:760][  0]LogGenericPlatformMisc: FPlatformMisc::RequestExit(0)
 [2015.06.29-16.40.14:770][  0]LogExit: Preparing to exit.
 [2015.06.29-16.40.14:771][  0]LogExit: Exiting.
 [2015.06.29-16.40.19:397][  0]LogGenericPlatformMisc: FPlatformMisc::RequestExit(0)
 [2015.06.29-16.40.19:407][  0]LogExit: Preparing to exit.
 [2015.06.29-16.40.19:408][  0]LogExit: Exiting.
 [2015.06.29-16.40.29:582][  0]LogGenericPlatformMisc: FPlatformMisc::RequestExit(0)
 [2015.06.29-16.40.29:592][  0]LogExit: Preparing to exit.
 [2015.06.29-16.40.29:594][  0]LogExit: Exiting.
 Aborted (core dumped)


Shaders starts compiling and it crashes after a little while. This happened to me more than once.

Product Version: UE 4.8
Tags:
more ▼

asked Jun 29 '15 at 01:45 PM in Linux

avatar image

Corpse0327
186 26 25 36

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

?alt text

alt text

For the reflection stuff open the console in the editor type what you see in the picture or what is mentioned in the link and hit enter. Or you can make the second one permanent if you edit your Engine/Config/ConsoleVariables.ini and add r.ReflectionEnvironment=0.

more ▼

answered Sep 09 '15 at 04:28 AM

avatar image

Yaakuro
304 13 7 19

avatar image SalahAdDin Sep 12 '15 at 11:07 PM

yeah, it works, thank you very much man.

But, i think that this bug should be fixed in the next release versions yet.

(comments are locked)
10|2000 characters needed characters left

What are your drivers/hardware? Also, could you paste the part of the log where GL_VENDOR and such is printed.

This is most likely a problem with Intel drivers though, as indicated by the above message (which is not ours BTW).

more ▼

answered Jun 29 '15 at 02:15 PM

avatar image

RCL STAFF
2.7k 59 6 88

avatar image Corpse0327 Jun 29 '15 at 02:38 PM

Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller]) NVIDIA Corporation GF108M [GeForce GT 540M] [10de:0df4] (rev a1) (prog-if 00 [VGA controller])

Linux *** 4.0.6-1-ARCH #1 SMP PREEMPT Tue Jun 23 14:25:08 CEST 2015 x86_64 GNU/Linux

mesa 10.6.0-1, nvidia 352.21-1, xf86-video-intel 1:2.99.917+364+gb24e758-1, bumblebee 3.2.1-10, primus 20150118-2

By the way i run UE4 by using primus

avatar image Yaakuro Jul 03 '15 at 08:25 AM

Are you using Mesa drivers? What is this:

[Callstack] 06 0x00007fb5f27251b9 /usr/lib/xorg/modules/dri/i965_dri.so(+0x3fa1b9) [0x7fb5f27251b9]

to me it looks like your UE4 is using mesa drivers, i965_dri.so but Mesa doesn't support OpenGL 4.1 at the moment. make sure you use nvidia prop. drivers.

avatar image Corpse0327 Jul 03 '15 at 12:47 PM

With optirun i can't open a project, it crashes. With primusrun i get random crashes out of nowhere in the middle of everything while a project is open. By the way i use propriority drivers v352.xx

I run it wiht primus since it doesn't hurt while opening a project.

avatar image SalahAdDin Sep 17 '15 at 07:41 PM

I'm using the oficial nvidia graphics repository, nvidia-355 drivers, not Mesa drivers.

(comments are locked)
10|2000 characters needed characters left

I have a similar problem with Ubuntu, but, my problem is that Editor's Viewport showme a black screen, when i do play for reproduce the game, showme all good.

Can anyone help me with this?

more ▼

answered Sep 07 '15 at 03:24 PM

avatar image

SalahAdDin
21 4 10 9

avatar image Corpse0327 Sep 07 '15 at 05:30 PM

Just use opengl 3(which is default) for now. Before Linux Editor becomes officially supported, i doubt it will get any attention

avatar image Yaakuro Sep 08 '15 at 04:45 AM

Read this https://wiki.unrealengine.com/Running_On_Linux#OpenGL_versions. That might solve your problem.

avatar image SalahAdDin Sep 09 '15 at 03:10 AM

Sorry, but, i want to know, how set Anti-Alias level to "Medium"? And how do the second step?

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question