x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Program.Main: ERROR: ERROR: cmd.exe failed with args /c "C:/NVPACK/apache-ant-1.8.2/bin/ant.bat" debug

When i build the project in the mode turns Shipping error:

link textProgram.Main: ERROR: ERROR: cmd.exe failed with args / c "C: /NVPACK/apache-ant-1.8.2/bin/ant.bat" debug.

I installed: Visual Studio 2013, all tools SDK mamager. Version Unreal 4.8

Sorry for the my English is not my native language.

Product Version: UE 4.8
Tags:
logmyproject2.txt (23.0 kB)
more ▼

asked Jun 29 '15 at 08:53 PM in Packaging & Deployment

avatar image

BlackSailsCMP
16 2 3 5

avatar image BlackSailsCMP Jun 29 '15 at 08:55 PM

In version 4.6 build was successful

avatar image wittlief ♦♦ STAFF Jun 30 '15 at 03:34 PM

Hi BlackSailsCMP,

Are you using binary or source for your engine? Are you able to package anything, for instance the Tappy Chicken project from the Learn tab of the launcher? Can you try packaging Tappy for development and ETC1 and posting the output logs here regardless of whether it succeeds or fails?

Are you using the native Android SDK or the recommended TADP tools from the documentation?

Thanks!

avatar image BlackSailsCMP Jun 30 '15 at 07:08 PM

Hi, wittlief !

I did not manage to build a blank project or Tappy Chicken if I chose Shipping and for distribution, but if you choose to development, the building well.

I can not to build etk1, all and other.

In version 4.6 I can build projects even with the Shipping and for distribution.

I use a binary engine.

I use TADP this location: "D:\UnrealEngine4\Epic Games\4.8\Engine\Extras\Android\tadp-2.0r8-windows"

Output logs Tappy Chicken : link text

log.txt (978.4 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hi BlackSailsCMP,

The relevant error you're seeing is this:

C:\NVPACK\android-sdk-windows\tools\ant\build.xml:1135: The following error occurred while executing this line: C:\NVPACK\android-sdk-windows\tools\ant\build.xml:1147: C:\Users\????\Documents\Unreal Projects\TappyChicken\Intermediate\Android\APK\UE.keystore

Here is a forums thread with instructions on how to fix that.

Good luck!

more ▼

answered Jun 30 '15 at 07:24 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Try this one: https://answers.unrealengine.com/questions/720605/android-packaging-build-fail-ue-418.html

(Enable Gradle instead of Ant)

OR

I tried this and worked:

alt text

more ▼

answered Feb 04 '18 at 05:24 PM

avatar image

Jean Rangel
6 2 3

avatar image M Ahmed Zahid Feb 24 '19 at 08:03 AM

Thank You so Much It Works . Really Helpfull

avatar image draguninio Mar 14 '19 at 11:00 AM

Thanks man, the uncheck "For Distribution" and check "For Rebuild" worked!

avatar image silverfish1000 Jun 10 '19 at 05:01 PM

Ya but doesn't for distribution have some kinda significant use that might do something bad to you while your sleeping.

avatar image silverfish1000 Jun 10 '19 at 05:05 PM

You can't ship to google play store without (for distribution). Besides it doesn't work.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

MY ERROR. UATHelper: Packaging (Android (ETC1)): ERROR: cmd.exe failed with args /c "C:/NVPACK/apache-ant-1.8.2/bin/ant.bat" release -Djava.source=1.7 -Djava.target=1.7

more ▼

answered Jun 10 '19 at 06:06 PM

avatar image

silverfish1000
124 12 23 29

avatar image DiMpUlTiOnZ Jun 26 '19 at 08:43 PM

did you fix it?

avatar image and9229 Jul 02 '19 at 04:03 AM

Hi, I get the same error, could you fix it?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question