x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging failed - Black screen (DefaultMap)

Hi, so here I am again (Editor build from sources - Packaging does not yield game Binaries); since I was told that the packaging problem was a known bug of the 4.0.x editor (see Why does packaging produce UE4Game.exe instead of gamename.exe?) I tried the "master" (4.1) branch.

But now, with a Blank project without any asset I do get a black screen only. And with starter assets, I do get error during the cooking/packaging process.

Edit: I was wrong, see my answer above about DefaultMap

Development PC:

  • Windows 7 SP1 - 64bits - 8GB RAM

  • Intel Core2 Quad Q6600 @2.40GHz

  • workspace on the system 220GB SSD

  • Visual Studio Express 2013 for Windows Desktop - Version 12.0.30110.00 Update 1

Sources:

  • GitHub source 4.0 branch - SHA 2092a941 by TimSweeney, 25/03/2014 15:47

  • Required_1of2.zip + Required_2of2.zip

Build Procedure:

  • GenerateProjectFiles.bat -> UE4.sln -> VS2013.1 - Development - Win64

Product Version: Not Selected
Tags:
more ▼

asked Apr 05 '14 at 06:44 AM in Packaging & Deployment

avatar image

SRombauts
1.1k 22 17 97

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi! Problem solved! So basically, Packaging was successful, but it was not loading my map; the Saved/Logs showed it was launching the default Engine "Entry" Map.

Solution came from "Setting default map for standalone game":

  • Edit > Project Settings > Maps

  • And select the preferred Game Default Map from the dropdown list.

  • Then use the Set as Default button

So thanks and sorry for the annoyance. SRombauts

more ▼

answered Apr 15 '14 at 08:33 PM

avatar image

SRombauts
1.1k 22 17 97

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question