x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Hot reload crashing since upgrade

I'm not sure if it's something in my code, but I recently upgraded to 4.8 and now everytime I try to hot reload by compiling the C++ code with the Unreal Editor open it crashes and I get the following callstack: Callstack.txt

Product Version: UE 4.8
Tags:
more ▼

asked Jun 30 '15 at 10:34 AM in Bug Reports

avatar image

repwolfe
56 2 7 11

avatar image Matthew J Jun 30 '15 at 07:22 PM

Hi repwolfe,

I have a few questions about your report:

  • Are you using version 4.8 or 4.8.1?

  • Are you using a binary version of the engine or a version built from source code?

  • Does this issue only occur when hot reloading in this particular project? In example, if you make a new project and hot reload, does it still crash?

  • Can you provide me with the code files themselves?

According to the callstack you posted, it's crashing due to an assert that is checking to see if something else in code is referring to an element of an array that actually exists. In this case it would be going out of bounds so the editor crashes. This could be caused by a multitude of things so it would be very helpful to see all of the code in your project for reference.

avatar image repwolfe Jun 30 '15 at 07:26 PM

1) 4.8 2) Binary version of the engine 3) I haven't tried with a different project, I hope to soon 4) https://github.com/repwolfe/ProjectMishkan is the source repo, it doesn't have my latest changes though. I hope to push those soon.

Thanks for your reply.

avatar image Matthew J Jun 30 '15 at 07:29 PM

Does this repo include code that is recent enough to reproduce this crash?

avatar image repwolfe Jun 30 '15 at 07:40 PM

Yes, sorry I didn't make that clear.

avatar image Matthew J Jul 06 '15 at 06:20 PM

I'm looking through your code as we speak and it may take me some time to find the issue, due to the size of the project. In the meantime, from the assert that failed in the first line of the callstack, it seems as though an array is going out of bounds in some manner. As you are more familiar with this code, I saw it best to mention this in case you may be able to narrow down the issue before I can.

Also, have you had a chance to try to see if this issue occurs with a fresh project as of yet?

Edit: Forgot to add; When downloading the project that you sent, I run into a crash when attempting to launch the project in UE4 after generating project files and successfully building the project. Is this something that occurs for you as well?

avatar image Matthew J Jul 13 '15 at 09:06 PM

Hello repwolfe,

We haven't heard from you in a wihle, are you still experiencing this issue? Have you tried reproducing this issue in a fresh project as of yet? I see that upon your latest commit that the crash isn't happening on my end. Are you experiencing the same outcome?

avatar image MickD777 Jul 15 '15 at 05:25 PM

Hi, I'm also experiencing problems with the hot reload since upgrading my project to 4.8.1 from 4.7.1. For example, my functions marked as Blueprintcallable are not recognized anymore after the dll reloaded.

Is it a known issue?

avatar image Matthew J Jul 15 '15 at 08:54 PM

Hi Michael,

Are you experiencing a crash when attempting to Hot Reload? If so, could you provide your callstack? When you mention that the functions are being recognized do you mean that the blueprint isn't acknowledging that they exist?

avatar image MickD777 Jul 16 '15 at 02:49 PM

No I'm not experiencing a crash, but a lot of my blueprints now have errors since some Blueprintcallable functions seem to not be found in the new dlls. Example of an error:

 LogBlueprint:Error: [compiler ChariotAct1] Error Could not find a function named "AttachToChariot" in 'JotunnNPCCharacter'.
 Make sure 'JotunnNPCCharacter' has been compiled for  Attach to Chariot 

I always need to close the editor and recompile. It's new from 4.8.1. We started the project in 4.5 and updated to 4.7.1 which was still working fine and now 4.8.1 where hot reload is completely broken for us.

Would it be better if I open a new thread for this issue?

avatar image Matthew J Jul 16 '15 at 08:27 PM

That would be helpful as this seems to be a different issue entirely.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I no longer have the crash when I hot reload. I guess I fixed something without realizing it. Any way to figure out what the fix/issue was?

more ▼

answered Jul 16 '15 at 11:05 AM

avatar image

repwolfe
56 2 7 11

avatar image Matthew J Jul 16 '15 at 08:29 PM

The only thing I could think of would be the look at your previous commits since the issue occurred and see what you have changed in the code. As the issue was fixed somewhere in this time, it is bound to be in those changes if you haven't upgraded to a new version of the engine.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question