x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Drag n' Drop-ing assets into folders within Content Browser's folder contents has no effect

If I want to copy or move an asset from one folder to another, I must click and drag the asset onto the appropriate folder in the list of folders within the Content Browser. While this is the appropriate functionality, it seems odd that one cannot do the same with the folder listed alongside the assets themselves (when you have a folder within another folder). Didn't think that was by design. If you try to do so, nothing occurs at all.

Product Version: UE 4.8
Tags:
more ▼

asked Jun 30 '15 at 06:56 PM in Bug Reports

avatar image

Envisioner
189 10 17 24

avatar image Samantha Sutton ♦♦ STAFF Jul 01 '15 at 05:37 PM

Hey Envisioner,

Are you claiming that you are not able to drag and drop folders into other folders from the Content Browser? I'm currently in 4.8.1 and I was able to move my blueprints folder into the audio folder from the Content Browser.

Please explain further how you're encountering this issue, thanks!

avatar image Envisioner Jul 01 '15 at 07:24 PM

No, I'm claiming that I am unable to drag and drop assets (not folders) into folders from the Content Browser, but only the folder icons that are displayed inside a folder's contents. Dragging assets onto folders in the folder hierarchy works fine. If, however, I have a folder, and within it, an asset and a subfolder, I cannot, while looking into the folder, drag the asset icon over the subfolder icon and "drop" it. I can drag the asset into the sidebar of the Content Browser where the folder hierarchy is, drop it onto the corresponding subfolder there, and have it "drop".

avatar image Samantha Sutton ♦♦ STAFF Jul 01 '15 at 08:42 PM

Would it be possible to upload a video of you reproducing this issue? I haven't had any trouble with dragging and dropping within the content browser.

I appreciate your assistance. :)

avatar image Envisioner Jul 03 '15 at 10:22 PM

Video isn't uploading for some reason. I just put it on my Google Drive. https://drive.google.com/file/d/0ByCSeEMuymAZSHlBQVJZYy1hcjQ/view?usp=sharing

avatar image Samantha Sutton ♦♦ STAFF Jul 06 '15 at 07:38 PM

Hey Envisioner,

Thanks for providing me with the video of the issue you're experiencing, I thought that was what you were talking about. I've had a few members on my team as well as myself replicate this and we did not run into this issue.

  • Could I see your DXDiag logs please?

  • Has this always happened or just since you've moved to 4.8.1?

Thank you!

avatar image Envisioner Jul 07 '15 at 07:33 AM

How do I acquire the DXDiag logs? (I've only ever run dxdiag.exe previously)? I'll try googling tomorrow to see if I can find out on my own as well...

As for the appearance of the bug, I never really noticed it until after 4.8.1, but I'm pretty sure that was because I hadn't directly tried it before since I usually use the folder hierarchy anyway.

EDIT: Got the log (I think) link text

dxdiag.txt (29.7 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Envisioner,

Thanks for providing me with your DXDiag logs, I wanted to make sure your computer specifications weren't causing trouble within the editor and they're not. I looked thoroughly through Jira again and found a bug that's only for 'List View' in Content Browser referenced as: UE-1206. This bug has not been fixed yet. The way you can get around this bug is by changing the view within the Content Browser.

If you have any further questions, please let us know and we'll be more than happy to assist you further!

Have a great day!

more ▼

answered Jul 08 '15 at 02:00 PM

avatar image ChrisMa130 Dec 22 '17 at 07:20 PM

I can't believe they haven't fixed this bug yet. It's nearly 2018 now.

avatar image Envisioner Dec 22 '17 at 07:55 PM

This is part of the reason I moved over to Godot Engine. I got fed up with waiting for bugs to get fixed. Lo and behold, now when I run into a bug during development, I can usually identify and implement a fix within hours, often even minutes. Cheers.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question