x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Crash on project startup

I saved my .umap and think that I may have closed the editor before it was fully done as now unreal engine crashes when trying to load the project. Ive tried changing the map it loads on startup; this results in the editor reporting a crash but opening anyway but unable to discover assets. Im guessing this is because its trying to read the corrupted map and getting stuck; I tried to make a backup of the map so that I could remove it from the project directory and see what happens but i am unable to see the most recent iteration through explorer unless it is launched through the UE4 environment, however when i try and copy the file from there it comes out as the older version.

So overall I have two questions:

  1. How easy will it be to recover the blueprints and other assets that were in the project; can i just delete the map and make a new one but keep the old assets?

  2. Why cant i interact with recent saves through explorer? The files in the project directory seem to be from the very first time i saved it.

I have attached 2 logs; one (CodenameDark.log) details an attempt to start with the potentially corrupted map, the other (log.txt) is an attempt using a different map.

Product Version: UE 4.8
Tags:
log.txt (16.4 kB)
codenamedark.log (38.1 kB)
more ▼

asked Jul 01 '15 at 05:24 AM in Everything Else

avatar image

Ascedmor
45 5 7 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first
  1. How easy will it be to recover the blueprints and other assets that were in the project; can i just delete the map and make a new one but keep the old assets?

You should be able, if you can get the project to open, to just make a new umap and trash the corrupt one. All of the assets you created or imported for that map, should still be there.

If the project doesn't open, what I would do, is create a new blank project, then copy and paste everything but the maps folder over to the new project. When you launch the new project all the blueprints and assets should still be there.

You could also try to just make a new umap in another project, copy and paste it into the folder with the broken umap and just name it the same as the broken umap

As for your second question, I don't know. You should be able to. It may have something to do with why the file is corrupt.

more ▼

answered Jul 01 '15 at 05:46 AM

avatar image

b16redlined
139 3 4 11

avatar image Ascedmor Jul 01 '15 at 09:11 AM

Yeah I thought of making a new project and copying everything over but the files i need are not present in the project directory for me to copy. I think i might try just deleting the corrupted .umap.

avatar image Ascedmor Jul 01 '15 at 09:25 AM

Deleting the .umap and starting still resulted in a crash i looked through the log and found what i think to be the problem; this is an excerpt from the log:

"[2015.07.01-09.14.47:343][ 0]LogThreadingWindows:Error: Runnable thread FAssetDataGatherer crashed. [2015.07.01-09.14.47:343][ 0]LogWindows: === Critical error: === Assertion failed: InPos<=Bytes.Num() [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.8\Engine\Source\Runtime\Core\Public\Serialization\Archive.h] [Line: 171] ... ... ... Crash in runnable thread FAssetDataGatherer"

It seems that the asset loader is crashing for some reason: possibly more corrupt files?

avatar image b16redlined Jul 01 '15 at 03:33 PM

Try removing the current version on the editor and redownloading it. This may correct the FAssetGatherer crash and this will not delete any of the projects you have, only the editor.

avatar image Ascedmor Jul 01 '15 at 09:46 PM

I ran "verify" on the engine version im using; doesnt seem to have fixed it, also i am able to load other projects so I dont think it would be a problem with engine file integrity.

avatar image Ascedmor Jul 01 '15 at 10:14 PM

I just remembered that the project im working on was made in version 4.8.1 and the ones that i have to open at the moment are all from 4.8.0 or earlier.

I also remembered that just before this crash started happening i opened the Epic Games Launcher with a bad internet connection; this caused it to fail during its update check and i think it may have reverted its version number to 4.8.0 for some reason.

Im updating back to 4.8.1 so fingers crossed it works after this.

avatar image Ascedmor Jul 01 '15 at 11:18 PM

Running in 4.8.1 doesnt seem to have helped; ive pretty much given up on getting this project to open but i would like to keep some of the blueprints that i had made.

Since im unable to interact with the .uasset files i want without being in the UE4 context (green border around window); what will be the easiest way for me to recover blueprints?

avatar image Ascedmor Jul 01 '15 at 11:27 PM

I think the invisible asset problem is due to ue4 running in some sort of sandbox; I assumed this was intended but i just realised that this might be a third party program (im using my friends computer and he has done a lot of customising to his windows) and could be causing problems.

avatar image b16redlined Jul 01 '15 at 11:41 PM

If you are in a sandbox or parallel when using ue4 you'll need to have it open when trying to work with explorers file system.

As long as both your corrupt project and the new blank project are the same version (4.8.1 in your case) you should be able to go to Documents>Unreal Projects>Old Project(the corrupt one)>Content and copy all but the maps folder and paste it into the new project. Located at Documents>Unreal Projects>New Project>Content

I'm not sure if it matters but I would close the Epic Launcher while copy and pasting the files, just to be safe.

When you launch the project it may take longer then usual to load in the new assets, it should work though. I just tried it to double check and it worked for me.

avatar image Ascedmor Jul 02 '15 at 12:00 AM

Yeah it was definitely the sandbox that was causing all the issues finding assets; i guess thats what i get for using someone elses computer as a workstation.

The only problem now is that some of the assets have completely dissapeared; even in the sandboxed explorer :( oh well thats much better than losing everything i suppose.

I appreciate the help man.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question