x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cannot build lighting (Mac)

I am making a 3d sidescroller game demo and lighting will not build. I left it to cook overnight and it was still at 0% this morning. Some kind of menu pops up with a progress bar, which flashes by too quickly to read, then the "Building Lighting... 0%" shows and the icon animates but it's not doing anything productive. Activity monitor shows "UnrealLightmass" taking up 0.5% CPU resources. Beyond that I see nothing else going on in the background. Then it just sits and thinks about nothing for however long you wish to let it sit and ponder (24+ hours and still 0%). It doesn't crash, but it doesn't go anywhere either. The only lights in the scene are a skylight and an omni light, the same default stuff that came in the template, unmodified.

I tried this same experiment with a fresh template level (3d side scroller), brand new, right after reboot, and it does the same thing. So I don't think it's my level specifically (all I did to mine was move some of the default sidescroller blocks around to make the scene wider).

Machine is an iMac, 3.5ghz core i7, 16gb RAM, running Yosemite, unreal engine Version: 4.8.1-2591939+++depot+UE4-Releases+4.8

I read the article https://answers.unrealengine.com/questions/60462/lighting-issue.html but it seems irrelevant.

Installed UE4 Windows in virtual desktop, loaded the same project in that, and the lighting built in less than 5 seconds. Why it doesn't work on Mac, seems that the swarm launch thing does not start. Tried reinstall on mac, swarm is still broken by default.

Product Version: UE 4.8
Tags:
more ▼

asked Jul 01 '15 at 05:37 PM in Rendering

avatar image

JBernal
11 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I'm having an extremely similar problem on my mid 2010 2.93Ghz Intel Core i7 iMac. Leaving lighting to build overnight and nothing happens, or the computer locks up.

more ▼

answered Jul 12 '16 at 09:37 PM

avatar image

keplerspacepilot
1 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question