Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Input Mode UI keeps showing standard mouse cursor

Hi Epic,

this might be a known issue, as it has been discussed previously: When I change the Input Mode to "Game and UI" or "UI only" and focus my menu widget, a standard mouse cursor appears. Unfortunately, this is not what I want, as I have built a menu which needs mouse input, but deliberately works without a cursor and looks just weird when it pops up in the center of the screen.

I have set the "Cursor" property to "None" in the PlayerController and the Widget, yet it still appears every time, even in standalone.

The user creasso has provided a workaround in the Forums: https://forums.unrealengine.com/showthread.php?56728-UMG-Compatibility-Code-Changes-SceneViewport-cpp-to-4-7

As I am no programmer, however, I can not use it. I would be very glad if there was a fix or a BP workaround to this problem. Any suggestions appreciated!

Best, Artax

Product Version: UE 4.8
more ▼

asked Jul 01 '15 at 07:23 PM in Bug Reports

avatar image

68 5 10 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Artax,

If you would like for no mouse at all to show up you could apply a blank widget to the default mouse. This can be done in the project settings (Project settings > User Interface > Default mouse). Once there you can simply apply an invisible widget to the default mouse (This can also be edited at runtime if a mouse is needed). I hope that this information helps.

Make it a great day

more ▼

answered Jul 02 '15 at 03:38 PM

avatar image

Rudy Q ♦♦ STAFF
47.3k 545 132 525

avatar image Artax Jul 05 '15 at 05:17 PM

Cool, that worked :) Thanks Rudy!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question