x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Child blueprints not maintaining values set after relaunching engine?

Using UE4 4.8.1 I've made a child blueprint of a blueprint called BP_PlayerCharacter. I've not changed the inherited mesh or animation that is attached to it. However when I close the editor after saving everything and relaunching the engine the mesh and the animation are set to "none" instead of the inherited values. Even if I change them to something completely different to the parent they just reset. I've tried re-creating both blueprints but to no avail. It just ends up being different things not loading correctly.

This occurs on both restarting the editor and packaging the game.

Any help is appreciated.

EDIT: Unable to delete so it's posted here instead: https://answers.unrealengine.com/questions/257788/child-blueprints-not-maintaining-values-set-by-eit.html

Was told to move it to bug report section :)

Product Version: UE 4.8
Tags:
more ▼

asked Jul 01 '15 at 11:47 PM in Blueprint Scripting

avatar image

Haigen
96 8 14 17

avatar image John Alcatraz Jul 06 '15 at 11:09 PM

You should move this into bug reports, since it's obviously a bug and not a question about blueprint scripting ;)

avatar image Frozenfire Nov 08 '15 at 09:05 AM

I have created another thread regarding this with an attached project. If the information could help anyone to solve the problem whether on engine side or workaround. would be great.

https://answers.unrealengine.com/questions/330290/bug-wprojectfiles-default-value-of-blueprint-reset.html

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

same problem for me happened and still happen on 4.9.3

more ▼

answered Oct 23 '15 at 08:46 AM

avatar image

skeleton60
620 41 59 88

(comments are locked)
10|2000 characters needed characters left

We had the same problem.

Did you convert from 4.7.6 to 4.8.1?

We fixed it by recompiling all the blueprints - watching unreal crash - then it magically worked. Try compiling your blueprints with the 4.8.1 version I guess.

Wish I had a better idea of what fixed it. Wish I knew that it was actually fixed too. I'm worried it might suddenly not work again.

more ▼

answered Jul 03 '15 at 01:34 PM

avatar image

Bullborn
21 1 2 3

avatar image President Jul 06 '15 at 06:59 PM

same here...Super lucky I'm not further down the level design pipeline otherwise this version would be unusable for me...but for now I'm accepting a few of my enemies and random other things are incorrect due to going back to defaults....I'm on 4.8.1 still not working.....

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question