x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Emissive material disappears when far from camera

In my material I have masked emissive, but the problem is, it's visible only when camera is close to the object. When i move camera further, emissive effect disappears:

alt text

Emissive intensity (multiply node) is already set to 50000. Is there some distance-emissive-culling happening here? My game will have isometric/top-down view and my camera will not be close to characters. Is it possible to make the emissive material to be visible with further camera distances?

Product Version: UE 4.8
Tags:
more ▼

asked Jul 03 '15 at 03:40 PM in Rendering

avatar image

Slavq
2k 157 153 210

avatar image Burnrate May 11 '16 at 07:35 PM

Did you ever figure this out?

avatar image Slavq May 11 '16 at 08:01 PM

As far as I remember, it's because of on of AA methods. Try to turn off Anti Aliasing options in your postprocess settings and see if that helps. No other real solution for this I'm afraid... (besides disabling AA)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Slavq,

The issue here isn't the emissivness, but instead it's a post process issue with Bloom. Since the post process is screen space oriented the smaller the object on the screen the smaller the effect. When TXAA is enabled it's blending with the previous scene to smooth the result which can reduce the amount of bloom shown at further distances. You can adjust the Bloom Settings in the Post Process to get better results at further distances, although you would probably need to adjust the threshold to reduce other objects or lights from producing too much bloom as well.

I hope this helps.

Tim

more ▼

answered May 12 '16 at 05:00 AM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 888 103 878

avatar image IhorSavaryn May 21 '18 at 12:13 PM

damn it works! thanks :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question