x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

My third person character does not move when I test my level, TryGetPawnOwner returns None. What am I doing wrong?

I have been following the Third Person Game With Blueprints tutorial series. I've followed up to video 14 where the system is tested for the first time. When I run the game I possess the actor that I placed in the level and can orbit the camera with the mouse but the problem is that none of the keyboard controls move the character. I created the blend spaces which work well when I manually set values. I created the animation blueprint with all of the logic to initiate and stop the walk. I have created the character blueprint, added the skeletal mesh to the mesh component and told it to use my animation blueprint. I set up my input axes as in the vids. I set my default pawn class in my world settings to my character blueprint. I set up the MyGame blueprint as in the vid too. I've been stumped by this for almost a week now. Could it be a bug? Any help would be great.

alt text alt text alt text alt text

Product Version: UE 4.8
Tags:
more ▼

asked Jul 03 '15 at 05:30 PM in Using UE4

avatar image

AdamMc
11 1 2 3

avatar image ttolujob Jan 20 '17 at 12:35 AM

Was this problem every solved? I having the same issue.

avatar image shotty46290 Jan 20 '17 at 12:42 AM

in your project settings are you using your correct game mode, and the game mode has all the correct settings as well? when they fails that usually means in some setting there is a wrong pawn setting.

avatar image ttolujob Jan 20 '17 at 12:47 AM

I made a new game mode when creating a main menu for the project. Do I need to revert back to the default settings?

avatar image ttolujob Jan 20 '17 at 01:04 AM

I coordinated the game modes in both project and world setting but its still not working

ue4help01.png (194.0 kB)
avatar image shotty46290 Jan 20 '17 at 01:16 AM

Could you put a sample project up? Have you tried to make a new project, game mode, and casted to the game mode and got it working? I'm trying to think of what else it could be.

avatar image ttolujob Jan 20 '17 at 01:44 AM

It worked! Thank you so much!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I'm glad you were able to get it working. Could you accept this answer? so everyone knows the question has been answered.

If you create a custom game mode you have to pick it here.

alt text alt text

other wise you are casting to your game instance, which is invalid, because the engine is not running it for the game instance, but running the default

71.jpg (127.5 kB)
72.jpg (239.4 kB)
more ▼

answered Jan 20 '17 at 02:46 AM

avatar image

shotty46290
348 12 7 20

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question